View Issue Details

IDProjectCategoryView StatusLast Update
0000128Cinelerra-GG[All Projects] Featurepublic2019-02-16 19:39
ReporterSamAssigned Togoodguy 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-02 
Summary0000128: Keyframes for camera view XYZ and projector view XYZ
DescriptionI almost got mad when I made yesterday's video. Zooming in and out is still very cumbersome in Cinelerra and makes it only conditionally suitable for the creation of explanatory videos.

I would have this concerning a small improvement wish.

1. to assign a key combination that inserts empty keyframes for the camera view and project view at the position of the playback. For example Shift + F11 for the camera (X, Y, Z) and Shift + F12 for the projector (X, Y, Z). Especially when zooming in and out a lot I would be really grateful if I had such a function. The constant copying of the keyframes cost me a lot of time yesterday. It was much too cumbersome and had almost no desire to create the video anymore. Such a key combination would be an absolute relief. Please have a look at the picture.

2. the key F11 resets the camera view. But sometimes only two coordinates are offset, like X and Y, and Z is unchanged. When pressing the F11 key in my example only X and Y are reset, at the playback position a keyframe for X and Y is created at this point. No keyframe is created for Z because nothing has changed. My suggestion would be to also create a keyframe for Z, although this value has not changed. Because I want to change the positions in the timeline two to three seconds later. The zoom would change in the current case from the beginning of the video to this position, X, Y but only the two to three seconds from the last change. The movements of the camera view would not fit together. I could change the zoom manually by double-clicking on the zoom line to create a keyframe, but it's very awkward when you're constantly zooming in and out.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-02-16 19:39

manager   ~0000923

Feature appears to be working as Sam requested and illustrated. And IgorB tested to verify. Even detective Columbo -PeterFalk, would be happy.
IgorBeg

IgorBeg

2019-02-14 10:46

reporter   ~0000899

GG/Phyllis, thanks for the build (dated Feb13 2109). I tested it quickly.
The new feature works very well; I used the shortcuts F11, F12, Shift+F11, Shift+F12, and also with dragging in Compositor, but not with new submenu in Compositor. Also created new autos between two, like the Good Sam showed to me ("keyframe-set.jpg"). Seems to me it works fine.

But, how the detective Columbo -PeterFalk- (in italian TV series was “Tenente Colombo”) said, a new problem occur. See 0000135 issue please.

Tested with “cinelerra-5.1-ub16-x86_64-static, build dated Feb13 2109”
PhyllisSmith

PhyllisSmith

2019-02-14 01:03

manager   ~0000896

Sam: " changing the camera position doesn't work anymore". This should now be fixed with the latest GIT checkin. I did a bad job of testing this because I am not familiar with it. But now I learned more.

IgorB: there is an ubuntu16 build out there and we would be very appreciative if you could test that and just some general editing because there has been code changes to get rid of a potential playback engine deadlock.
     https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

Also, a new Mint18 build with the same mods in + another shuttlerc modified file (getting closer to better key definitions).
    https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-mint18-x86_64-static.txz
IgorBeg

IgorBeg

2019-02-13 18:16

reporter   ~0000892

Ooh, thanks Sam for all information and screenshot. Yes, very well; it interpolate between two (triplets or couples in your exhaustive "keyframe-set.jpg" image) keyframes. Thanks a lot!
Sam

Sam

2019-02-13 18:04

manager   ~0000891

I have to correct myself, it always creates keyframes at the height of the current XYZ line at the playback position, so it doesn't act like a copy. I put an image on it, which makes it clear what is meant.

Keyframe-set.jpg (31,807 bytes)
Keyframe-set.jpg (31,807 bytes)
Sam

Sam

2019-02-13 17:52

manager   ~0000889

It creates new keyframes at the playback position without changing the XYZ line. No matter which value the XYZ line has, these are taken over by the keyframes. I wouldn't call it Copy for this reason, but it behaves like copying the previous keyframes.
IgorBeg

IgorBeg

2019-02-13 17:19

reporter   ~0000888

Sam, thanks for the video. It explain very well. The new feature Shift+F11 and Shift+F12 is very good. Does It duplicate the previous keyframes (X,Y,Z) or interpolate between two (x1,y1,z1 and x2,y2,z2) keyframes?
Thanks.
Sam

Sam

2019-02-13 15:57

manager   ~0000884

Thanks for your feedback.

The test refers to today's/yesterday's changes. It's hard to explain with words, so I've added a video:

https://streamable.com/p5q1h
IgorBeg

IgorBeg

2019-02-13 12:20

reporter   ~0000882

I am still using "cinelerra-5.1-ub16.04-20190131.x86_64-static" for good ripple and others things.

If I enable "Generate keyframes while tweeking (j)", move the cursor on the timeline, where there are not any keyframes, and press F12, it creates 3 keyframes, one for X, one for Y and one for Z (X=0, Y=0, Z=1). Same thing for F12. More Zoom In and Zoom Out works right.
Seems to me a regression. Maybe I wrong or I didn' t understand.
Sam

Sam

2019-02-13 06:22

manager   ~0000881

Thanks for the improvements.
Setting the keyframes works very well. But changing the camera position doesn't work anymore. I can make the video smaller and try to change the position in the compositor, but the image in the compositor remains frozen. I see in the timeline that the XYZ lines are changing, but it has no effect on the compositor display.
PhyllisSmith

PhyllisSmith

2019-02-13 04:45

manager   ~0000880

A change has been checked into the GIT repository. Shift-F11 for the camera and Shift-F12 for the projector will create an identity keyframe at the current position. The menu in the compositor when you do a right mouse was getting too big with the addition of the 2 extra shift shortcuts, so the Zoom portion was put into a submenu. A couple of other changes checked in to fix potential problems.
PhyllisSmith

PhyllisSmith

2019-02-09 21:47

manager   ~0000831

Sam: gg says this is a good idea and he will attempt to implement it soon. Right now he is stuck on another bug.
Sam

Sam

2019-02-07 15:06

manager  

Keyframes.jpg (112,990 bytes)
Keyframes.jpg (112,990 bytes)

Issue History

Date Modified Username Field Change
2019-02-07 15:06 Sam New Issue
2019-02-07 15:06 Sam File Added: Keyframes.jpg
2019-02-08 22:39 PhyllisSmith Assigned To => goodguy
2019-02-08 22:39 PhyllisSmith Status new => assigned
2019-02-09 21:47 PhyllisSmith Note Added: 0000831
2019-02-13 04:45 PhyllisSmith Status assigned => acknowledged
2019-02-13 04:45 PhyllisSmith Note Added: 0000880
2019-02-13 06:22 Sam Note Added: 0000881
2019-02-13 12:20 IgorBeg Note Added: 0000882
2019-02-13 15:57 Sam Note Added: 0000884
2019-02-13 17:19 IgorBeg Note Added: 0000888
2019-02-13 17:52 Sam Note Added: 0000889
2019-02-13 18:04 Sam File Added: Keyframe-set.jpg
2019-02-13 18:04 Sam Note Added: 0000891
2019-02-13 18:16 IgorBeg Note Added: 0000892
2019-02-14 01:03 PhyllisSmith Note Added: 0000896
2019-02-14 10:46 IgorBeg Note Added: 0000899
2019-02-16 19:39 PhyllisSmith Status acknowledged => resolved
2019-02-16 19:39 PhyllisSmith Resolution open => fixed
2019-02-16 19:39 PhyllisSmith Fixed in Version => 2019-02
2019-02-16 19:39 PhyllisSmith Note Added: 0000923