View Issue Details

IDProjectCategoryView StatusLast Update
0000130Cinelerra-GG[All Projects] Featurepublic2019-03-01 03:16
ReporterSamAssigned Togoodguy 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version2019-01 
Target VersionFixed in Version2019-02 
Summary0000130: XYZ Color
DescriptionWhile editing yesterday's video I came up with a small suggestion for improvement.

Currently I have only one monitor in use and therefore little space for many windows and for this reason I can't use the "Show Overlays" window.

Please have a look at the photomontage.
It would be great if in the lower field the color of the letter takes on the color of the line. So I can see which line I am moving. With this small change I immediately see which line I am adjusting.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-03-01 03:16

manager   ~0001049

Fixed in end of month builds.
PhyllisSmith

PhyllisSmith

2019-02-26 15:11

manager   ~0001030

It looks good to me and I like the second round better too.
IgorBeg

IgorBeg

2019-02-26 10:00

reporter   ~0001025

Well done GG/Phyllis for implemented that. Thanks to Sam for the idea.
@MatN
when Sam says to you "press the "9" key", I just want to remember that it is not the nine number on KeyPad, but below the function keys. If you always know, excuse me.
PhyllisSmith

PhyllisSmith

2019-02-25 22:56

manager   ~0001020

MatN: I have added the following to the NEW preliminary manual. This has caused a few problems before and has been reported as a bug several times so it is worth making a note in the manual.

"Keep in mind that Zoombar ranges/values must be set to appropriate values when working with specific keyframe types, such as Fade or Speed. If you do not see the auto line in the visible area of the video track, try the key combination Alt-f or select the speed in the "Automation Type" drop-down menu at the bottom of the main window. To the right of this field is “Automation Range” where you can set the display ratio of these lines. Simply change the values until the lines are visible again."
Sam

Sam

2019-02-25 22:29

manager   ~0001019

Depends on which zoom you mean. There is the camera zoom and the projector zoom and also the personal workspace zoom. In the compositor you activate it with the key F5 for the camera view and with F6 for the projector view. I mainly work with the camera zoom and therefore press the F5 key in the compositor, it shows you a slider to the left of the compositor. This is the Zoom slider which has a direct effect on the rendered video result.

The percentages at the bottom of the compositor are your personal working zoom, which has no effect on the final result of the rendered video. This zoom at the bottom is only used to zoom in on certain areas of the compositor to see details better in the compositor. To display the zoom line of the camera in the main window of the timeline you have to activate it with Ctrl+Shift+Z and reset everything with ALT+F, then you should see a blue line. Changing this blue line changes the zoom of the camera view.
MatN

MatN

2019-02-25 22:14

reporter   ~0001018

Thanks Sam, that worked. ¨9¨ did not work, but alt-F brought it in view.

The ¨zoom¨ line I still don´t get, is that doing what the ¨zoom¨ in the compositor does?
Sam

Sam

2019-02-25 18:29

manager   ~0001016

With the key "9" in the main window you can display the speed line.
Sometimes these lines are not in the visible area of the video track. You can then try the key combination ALT + F or select the speed in the "Automation Type" drop-down menu at the bottom of the main window, to the right of this field you can set the display ratio of these lines. Simply change the values until the lines are visible again. At this point you have to try a bit.

The keyframes can be deleted very well. Press the "e" key to activate the "Cut & Paste" mode. Mark the area where these keyframes are located, then press the SHIFT + DEL key to delete them.
MatN

MatN

2019-02-25 18:14

reporter   ~0001015

Issue 128 is set as fixed, so I have some questions here, the build I use is from the git 20190225T1700 UTC on Mint 18.3 XFCE 64bit.
- How do I get the ¨zoom" line like show in Sam´s picture below? I can zoom in the compositor, but that doesn´t give me a line in the tracks. Neither the feature5 not the cv manual tells me how. The same with the speed line. Selecting zoom or speed in the bottom of the main window doesn´t do anything visible.
- Normally I can delete a keyframe which I manually created. But keyframes created by the new functions like shift-F11 I cannot delete. Are they permanent, is it a bug or how should I do it? I had expanded the timeline so I can see the individual frames, and the keyframes are at the beginning of a frame.
Sam

Sam

2019-02-25 00:06

manager   ~0001012

Thanks for the improvement. It works perfectly!
PhyllisSmith

PhyllisSmith

2019-02-25 00:01

manager   ~0001011

Changed to a color box only so now there are only white letters as requested.

TIP: (you probably already know about this); if you are in drag and drop mode and you make a point of selecting an edit and then you start modifying the Speed Auto, the surrounding box moves and shows you what its resulting length will be. See:
    https://streamable.com/a8mkz

color.png (81,395 bytes)
color.png (81,395 bytes)
PhyllisSmith

PhyllisSmith

2019-02-24 16:18

manager   ~0001006

I will have him look at this and see what he can or can not do.
Sam

Sam

2019-02-24 15:45

manager   ~0001005

This is what it would look like if it were implemented.

Color-XYZ-03.jpg (18,043 bytes)
Color-XYZ-03.jpg (18,043 bytes)
Sam

Sam

2019-02-24 15:33

manager   ~0001003

@PhyllisSmith

Would it be possible to implement these changes? This would improve readability and we would still have our visual feedback about the XYT line.

Here's the summary:

Any text would remain in the original white color, so you have a uniformly readable text. In addition to the status text and in the dropdown menu at the bottom, the extended ascii character 220 or 223 or 254 is displayed as a rectangle in the respective color of the line. This makes the text easy to read and you have the visual color information as a rectangle. If the extended ascii code can be used, GG does not have to reprogram much, but only insert this character and change the color of this symbol.
IgorBeg

IgorBeg

2019-02-24 14:58

reporter   ~0001001

My wrong, I missed to upload the png file in the note.
It is better more ideas than only one. From more ideas the good ones come out, I think. =)
Sam

Sam

2019-02-24 14:49

manager   ~0001000

Unfortunately I didn't find an Ascci character that represents a big circle. I think GG would have to change a lot about a circle symbol. But if he could include extended Ascii characters as a square, then it would be a small thing for him to program, because he doesn't have to change the dropdown menu and the status text very much.
Sam

Sam

2019-02-24 14:43

manager   ~0000999

Oops, sorry, your picture wasn't hung as a note, then I made a photomontage in the meantime. But now I have seen that you made one yourself. Anyway now we have two examples. ;-)
Sam

Sam

2019-02-24 14:38

manager   ~0000998

I've created this. I have no idea if GG can represent the extended Ascii character. It looks better and would have solved all problems with readability.

color-XYZ.jpg (24,007 bytes)
color-XYZ.jpg (24,007 bytes)
IgorBeg

IgorBeg

2019-02-24 14:27

reporter  

DropDownMenu.png (60,716 bytes)
DropDownMenu.png (60,716 bytes)
IgorBeg

IgorBeg

2019-02-24 14:26

reporter   ~0000997

Sam, mixing your last solution, photomontage "color-xyz-example.jpg", with your first "XYZ-color.jpg",...
What do you think about this solution, if great-GG ca do it? See the photomontage added, please.
Then the texts are always with white colour, and the colour information is there. Also as visual design, you know, could be good, I think. It recall the Overlay's design.

(oops it was... time to lunch)
Sam

Sam

2019-02-24 13:29

manager   ~0000996

I wrote in the ticket that if the "Overlay Window" is not open due to lack of space on the desktop of the computer it would be nice if I could see which XYZ letters are assigned which color, in other words a visual confirmation. The highlighting should not only be done by the value XYZ but also visually by the color.
This small change should make my life with Cinelerra easier and the handling more intuitive. If you get along better with your approach, then it is your decision. The idea with the status text didn't come from me, this idea was implemented by GG. Which I personally think is good, but as I said with the small changes to ensure readability at all times.

I just wanted to create a color connection between the line and the drop down menu in the bottom area to have the visual confirmation "Yes, X is red". Which is good with the current solution because you still have your white text and I get the visual color feedback as soon as I change one of the three lines.
IgorBeg

IgorBeg

2019-02-24 12:00

reporter   ~0000995

Sorry Sam, I really don't understand your request. There is the information: Iit is always there in Overlays window.
When I drag a keyframe I have to know before dragging which type of keyframe it is. Then I open Overlay window and I can see the colours. More with the Shift+LMB (Left Mouse Button) I can isolate the specific function (Projector X, Y, Z, Camera X, Y, Z) to see better that line. In your case you have touch and verify if it is right or not, or am I wrong? Also in your last photomontage "color-xyz-example.jpg" it don't need, for me, because when you are just dragging you always know what you are dragging.
I added a screencast to show my Layout and how we always have the info you have request.
https://streamable.com/07c95

I hope you understand my good intention towards you. Sorry for boring.
Mmh, time to dinner.
Sam

Sam

2019-02-24 00:33

manager   ~0000992

I understand what you mean, it could indeed be difficult to see certain colors if the color is poorly visible. White certainly has an advantage, but a combination would be better. You could also display the letter ascii code 254 (a small square) http://www.asciitable.com/
in the color of the line in the front of the status line and then display the rest of the text in white. With this solution you would see that the red X line has been changed and the rest of the information comes in white by default. As an example:
(red square) smooth 0:00:11:25, -62.50
The keyframes of each XYZ axis are small squares in the timeline. Therefore it would be a good idea to show small squares before the status message.
I have no idea if this would be technically possible and if the extended Ascii Code 254 is supported.
The new solution is quite nice, but I have to admit that it's hard to read with the dark red color (in my example). If everything is too difficult to set, then I tend to switch to white due to readability.

color-xyz-example.jpg (11,828 bytes)
color-xyz-example.jpg (11,828 bytes)
IgorBeg

IgorBeg

2019-02-23 23:59

reporter   ~0000991

Sam, what do you think if only the topDown menu changes the text colour, as it works now, except the status message on the left bottom of the Main window that don't changes its colours, and return as it was before (a kind of white colour)? And if GG/Phyllis can/want, of course.
Thanks.
(The status message may be poorly readable with some colours)
Sam

Sam

2019-02-23 21:02

manager   ~0000990

At traffic lights I could also tell from the position of the lights whether it means stop or drive. Up is stop and down is drive, but still a traffic light has colors. As a designer I am a very strong visual person. I can capture things with color much faster than when I have to be aware of what is really meant. The new improvement is a help for me to make working with Cinelerra more intuitive, if you get along with your workflow better, then it's fine. You don't have to apologize to me, we can have different opinions without being upset. Even if we sometimes have different opinions, I still appreciate your honest opinion.
IgorBeg

IgorBeg

2019-02-23 18:32

reporter   ~0000984

Sam, I saw your video. You could have done that even before, for me: you can touch the little square over the line and you can see the topDown menu, on the bottom of the Main window, to change to X, Y, Zoom and so on.
My Notebook' screen resolution is 1280x800 pixels and sometimes I have to enlarge the Main window (timeline), then I use the very useful "Load Layout" features where I saved with or without Overlays window. Or with "Ctrl+0" shortcut I can see the Overlays window, look at the assigned colour of Projector/Camera and to close the Overlays window with its shortcut. Very fast and useful, for me.
When two line are exactly one over each other I have to use "Show tool info (F9)" window and to change the values there.
Sorry, you always know.
I know everyone of us has their own workflow, then sorry again if I insisted.
Sam

Sam

2019-02-23 15:05

manager   ~0000980

In the following video you can see it better.

https://streamable.com/ksreh

Thanks @PhyllisSmith & gg :-)
Sam

Sam

2019-02-23 14:58

manager   ~0000979

@IgorBeg

GG really solved it cleverly! The color is only shown when I click on the respective line, otherwise it remains in the default colors. Geniously solved, as if GG could read our thoughts in advance.
Sam

Sam

2019-02-23 13:41

manager   ~0000975

The problem is that I see three lines in the timeline, but I don't know which line is what. Often two lines are displayed directly above each other in the default settings. To get the lines apart again, I have to change one of the XYZ axes in the lower bar, so I need the colors to know which one to change. A uniform color like it was before would certainly be better from a design point of view, but I don't know how it could be represented differently. At most maybe with a round colorful dot in front of it. Just leaving it that way without improving it is not an option for me, if you have a better idea then I am open for other solutions.
IgorBeg

IgorBeg

2019-02-23 10:45

reporter   ~0000974

IMHO, the colours was better as before (white).
I don't know your workflow, Sam; In this case I don't think the colour can help.
When I drag, move the Projector/Camera the "Show tool info (F9)" is always showed or I enable it.
In timeline if I drag the keyframes of the X/Y/Z's Projector/Camera I can see what I move; if X coordinate, for example, is too close to the others I have to use the "Show tool info (F9)".
Now, if I set the colour of the lines with a "soft" colour, the new mod can't help.
Sorry if I think so.
(thanks to ask me a feedback)
PhyllisSmith

PhyllisSmith

2019-02-22 23:20

manager   ~0000970

The zoombar "Automation Type" adopts the color of the line. Also, the message displayed color is changed and will remain changed until another message writes over it.
Sam

Sam

2019-02-08 00:30

manager  

XYZ-color.jpg (71,325 bytes)
XYZ-color.jpg (71,325 bytes)

Issue History

Date Modified Username Field Change
2019-02-08 00:30 Sam New Issue
2019-02-08 00:30 Sam File Added: XYZ-color.jpg
2019-02-21 23:13 PhyllisSmith Assigned To => goodguy
2019-02-21 23:13 PhyllisSmith Status new => assigned
2019-02-22 23:20 PhyllisSmith Status assigned => feedback
2019-02-22 23:20 PhyllisSmith Note Added: 0000970
2019-02-23 10:45 IgorBeg Note Added: 0000974
2019-02-23 13:41 Sam Note Added: 0000975
2019-02-23 13:41 Sam Status feedback => assigned
2019-02-23 14:58 Sam Note Added: 0000979
2019-02-23 15:05 Sam Note Added: 0000980
2019-02-23 18:32 IgorBeg Note Added: 0000984
2019-02-23 21:02 Sam Note Added: 0000990
2019-02-23 23:59 IgorBeg Note Added: 0000991
2019-02-24 00:33 Sam File Added: color-xyz-example.jpg
2019-02-24 00:33 Sam Note Added: 0000992
2019-02-24 12:00 IgorBeg Note Added: 0000995
2019-02-24 13:29 Sam Note Added: 0000996
2019-02-24 14:26 IgorBeg Note Added: 0000997
2019-02-24 14:27 IgorBeg File Added: DropDownMenu.png
2019-02-24 14:38 Sam File Added: color-XYZ.jpg
2019-02-24 14:38 Sam Note Added: 0000998
2019-02-24 14:43 Sam Note Added: 0000999
2019-02-24 14:49 Sam Note Added: 0001000
2019-02-24 14:58 IgorBeg Note Added: 0001001
2019-02-24 15:33 Sam Note Added: 0001003
2019-02-24 15:43 Sam File Added: Color-XYZ-02.jpg
2019-02-24 15:45 Sam File Deleted: Color-XYZ-02.jpg
2019-02-24 15:45 Sam File Added: Color-XYZ-03.jpg
2019-02-24 15:45 Sam Note Added: 0001005
2019-02-24 16:18 PhyllisSmith Note Added: 0001006
2019-02-25 00:01 PhyllisSmith File Added: color.png
2019-02-25 00:01 PhyllisSmith Note Added: 0001011
2019-02-25 00:06 Sam Note Added: 0001012
2019-02-25 18:14 MatN Note Added: 0001015
2019-02-25 18:29 Sam Note Added: 0001016
2019-02-25 22:14 MatN Note Added: 0001018
2019-02-25 22:29 Sam Note Added: 0001019
2019-02-25 22:56 PhyllisSmith Note Added: 0001020
2019-02-26 10:00 IgorBeg Note Added: 0001025
2019-02-26 15:11 PhyllisSmith Status assigned => resolved
2019-02-26 15:11 PhyllisSmith Resolution open => fixed
2019-02-26 15:11 PhyllisSmith Fixed in Version => 2019-02
2019-02-26 15:11 PhyllisSmith Note Added: 0001030
2019-03-01 03:16 PhyllisSmith Status resolved => closed
2019-03-01 03:16 PhyllisSmith Note Added: 0001049