View Issue Details

IDProjectCategoryView StatusLast Update
0000154Cinelerra-GG[All Projects] Bugpublic2019-04-14 16:49
ReporterLukasAssigned Togoodguy 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019-02 
Target VersionFixed in Version2019-04 
Summary0000154: The video fader doesn't update
DescriptionWhen I play a video track between two fade keyframes, the fader on the left panel doesn't move during playing (or moving the time cursor manually). Audio faders move correctly. I've attached a screenshot.
Steps To ReproduceInsert two fade keyframes with different values in a video track, play the video track between them and watch the video fader on the left of the track. The fader doesn't move.
TagsNo tags attached.

Activities

IgorBeg

IgorBeg

2019-04-14 14:49

reporter   ~0001374

@PhyllisSmith
Thanks for the explain about "time consuming...". I always have to use proxy then, maybe that, in this case, I don' see the different fps achieved.

For the Linear vs Bezier, thanks to you. At the beginning I thought that it was to save cpu. I don't know if different icons/pngs consumes more cpu/memory, for video refreshing.

PS:
And Thanks for all the test build you do for me (...and Ubuntu16 users). I think that I always waste your time.
PhyllisSmith

PhyllisSmith

2019-04-14 13:26

manager   ~0001373

IgorB: "how is it time consuming and slows the playback down?: -- the reason it slows down the playback is because it has to calculate the location of the patchbay slider bar every frame of the video to see if it has to move and be redrawn. Before it was just doing the calculation and redraw when the insertion pointer was moved. This does not slow down the playback for audio because audio is so much faster than video.

IgorB: thanks for the linear versus bezier png-s. GG found the problem -- it had gotten mistakenly dropped in March 2016 when the cv mods were merged in. He has created a fix but it will be a few days before that is checked in.
IgorBeg

IgorBeg

2019-04-13 10:15

reporter   ~0001365

Together to Lukas, Thank you.
For you, how many is it time consuming and slowed the playback down?

About "Also the keyframe symbol (about Autos) should be different if Linear or Bezier, I think."
The keyframes symbol in Autos should be a little square when the keyframe is Linear, and a little diamond when the keyframe is Bezier. So, you can see on the fly the type of keyframe: Linear or Bezier. (In Cinelerra-7 it was/is so)
Now they are always little square.
In /CinPath/doc/cinelerra.html -> 13.2_Changing_Bezier_&_Linear_Mode you can see what I mean.
I added the two pictures I found there. Thanks.

In add, I think, that in "Settings-> Typeless keyframes" was used to change the view and show all little square shape.

linear.png (2,978 bytes)
linear.png (2,978 bytes)
bezier.png (3,465 bytes)
bezier.png (3,465 bytes)
Lukas

Lukas

2019-04-13 07:12

reporter   ~0001364

Thank you! I'm looking forward to test it.
PhyllisSmith

PhyllisSmith

2019-04-13 00:55

manager   ~0001361

Last edited: 2019-04-13 04:10

View 2 revisions

This is now fixed and will be in the end of April builds.

@IgorB: I do not understand your comment in your last note of "Also the keyframe symbol (about Autos) should be different if Linear or Bezier, I think. " Plus a new ubuntu16 static tar will be at the usual:

https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

PhyllisSmith

PhyllisSmith

2019-04-01 21:09

manager   ~0001288

Last edited: 2019-04-01 21:11

View 2 revisions

Oops! I forgot to have gg fix this before the end of March monthly builds. I will get it on this month's early list.
We did discuss it and he said that the update was removed because it was time consuming and slowed the playback down.

IgorBeg

IgorBeg

2019-03-06 10:44

reporter   ~0001098

Lukas, I agree with you. It is strange because Audio faders works fine.

PS:
Also the keyframe symbol (about Autos) should be different if Linear or Bezier, I think.
Lukas

Lukas

2019-03-06 08:41

reporter   ~0001096

I just want to add that I looked at a Cinelerra version from the last year, and it was OK there, so probably something went wrong between several last versions.
Lukas

Lukas

2019-03-04 11:50

reporter  

cinelerra1.png (30,479 bytes)
cinelerra1.png (30,479 bytes)

Issue History

Date Modified Username Field Change
2019-03-04 11:50 Lukas New Issue
2019-03-04 11:50 Lukas File Added: cinelerra1.png
2019-03-04 16:28 PhyllisSmith Assigned To => PhyllisSmith
2019-03-04 16:28 PhyllisSmith Status new => assigned
2019-03-06 08:41 Lukas Note Added: 0001096
2019-03-06 10:44 IgorBeg Note Added: 0001098
2019-04-01 21:09 PhyllisSmith Note Added: 0001288
2019-04-01 21:11 PhyllisSmith Note Edited: 0001288 View Revisions
2019-04-13 00:55 PhyllisSmith Note Added: 0001361
2019-04-13 04:10 PhyllisSmith Note Edited: 0001361 View Revisions
2019-04-13 07:12 Lukas Note Added: 0001364
2019-04-13 10:15 IgorBeg File Added: linear.png
2019-04-13 10:15 IgorBeg File Added: bezier.png
2019-04-13 10:15 IgorBeg Note Added: 0001365
2019-04-14 13:26 PhyllisSmith Note Added: 0001373
2019-04-14 14:49 IgorBeg Note Added: 0001374
2019-04-14 16:49 PhyllisSmith Assigned To PhyllisSmith => goodguy
2019-04-14 16:49 PhyllisSmith Status assigned => resolved
2019-04-14 16:49 PhyllisSmith Resolution open => fixed
2019-04-14 16:49 PhyllisSmith Fixed in Version => 2019-04