View Issue Details

IDProjectCategoryView StatusLast Update
0000155Cinelerra-GG[All Projects] Bugpublic2019-04-01 21:07
ReporterIgorBegAssigned ToPhyllisSmith 
PriorityhighSeverityminorReproducibilityunable to reproduce
Status closedResolutionfixed 
Platformx64OSLinux-UbuntuStudioOS Version16.04
Product Version 
Target VersionFixed in Version2019-03 
Summary0000155: Labels do not showed in Timeline
DescriptionI started a new project with the Cinelerra-GG 20190228 release.
I added a few of labels, added text to two labels, saved the project.
Reopen the same project but the labels on Timeline are not showed.
In the XML file they are there. If I open the project with CInelerra-GG 20181231 release, I can see them. It is really strange.
I tried (quickly) to reproduce again the issue but it not occur to me.
I added a JPG file to show what I see, and the XML file.
Thanks.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-04-01 21:07

manager   ~0001287

But I do not know from where ECHELON comes from - maybe that was a movie I missed or some science fiction book.
IgorBeg

IgorBeg

2019-03-14 10:22

reporter   ~0001203

Thanks GG/Phyllis. Now It is OKAY, for me. I can see the labels. Thanks.
Thanks about Segmentation fault information, I am really ignorant in Linux (and other things).

Phyllis: "Too many things going on."
Really, take your time, please. I don't know how you can do all these fix in so short time.

PS:
"When you turn on your computer in the morning"
Are you ECHELON (Big Brother)? Mmh...
;-)
PhyllisSmith

PhyllisSmith

2019-03-13 16:34

manager   ~0001199

The whole reason gg was working on the labels... follow edits was because of this bug but by the time he got the mods done yesterday with some rework, we could not remember the "bad bug". Too many things going on.

https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz
https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-mint18-x86_64-static.txz

IgorB - if you have more segmentation faults, please send the dumps. Since you probably do not want to run as root, could you use the ptrace method instead? When you turn on your computer in the morning, use this:
     Temporarily login as root and keyin: echo 0 > /proc/sys/kernel/yama/ptrace_scope
This opens up ptrace, used by gdb (make sure you have gdb installed too). Then when you turn the computer off:
     reverse the previous setting while logged in as root by keying in: echo 1 > /proc/sys/kernel/yama/ptrace_scope
IgorBeg

IgorBeg

2019-03-06 09:25

reporter   ~0001097

Thanks.
PhyllisSmith

PhyllisSmith

2019-03-05 18:06

manager   ~0001092

GG is working on this now after all of the confirmation help. Bad bug.
IgorBeg

IgorBeg

2019-03-05 11:22

reporter   ~0001091

EUREKA! (I hope)
I can reproduce the issue "always".
If you save the project when "Lock labels from moving with edits" icon is enabled (highlight) then, next time you open that project, the labels are no longer shown. And they will never be shown even after disable "Lock labels..." icon and save again.
Maybe you, GG and Phyllis, had already discovered it (while I was sleeping). ;-)

PS:
thanks Andrea_Paz for your confirm.
Andrea_Paz

Andrea_Paz

2019-03-05 07:25

updater   ~0001090

I confirm the issue.
In a 20-minute video I had put dozens of labels to mark the zones for the titles. When it reopened, I didn't see any labels on the timeline. I had "lock label" and "perpetual session" active, which I usually keep disabled. But I don't think they're important.
PhyllisSmith

PhyllisSmith

2019-03-04 22:52

manager   ~0001089

That is indeed strange. GG can look at the code and the xml file to see if there are possibly any anomalies that could cause this under some condition.
IgorBeg

IgorBeg

2019-03-04 22:17

reporter  

labels-issue.jpg (188,240 bytes)
labels-issue.jpg (188,240 bytes)
WhatTimeIsIt.xml.tar.gz (3,850 bytes)

Issue History

Date Modified Username Field Change
2019-03-04 22:17 IgorBeg New Issue
2019-03-04 22:17 IgorBeg File Added: labels-issue.jpg
2019-03-04 22:17 IgorBeg File Added: WhatTimeIsIt.xml.tar.gz
2019-03-04 22:52 PhyllisSmith Note Added: 0001089
2019-03-05 07:25 Andrea_Paz Note Added: 0001090
2019-03-05 11:22 IgorBeg Note Added: 0001091
2019-03-05 18:06 PhyllisSmith Assigned To => PhyllisSmith
2019-03-05 18:06 PhyllisSmith Status new => confirmed
2019-03-05 18:06 PhyllisSmith Note Added: 0001092
2019-03-06 09:25 IgorBeg Note Added: 0001097
2019-03-13 16:34 PhyllisSmith Note Added: 0001199
2019-03-14 10:22 IgorBeg Note Added: 0001203
2019-03-14 14:25 PhyllisSmith Status confirmed => resolved
2019-03-14 14:25 PhyllisSmith Resolution open => fixed
2019-03-14 14:25 PhyllisSmith Fixed in Version => 2019-03
2019-04-01 21:07 PhyllisSmith Status resolved => closed
2019-04-01 21:07 PhyllisSmith Note Added: 0001287