View Issue Details

IDProjectCategoryView StatusLast Update
0000159Cinelerra-GG[All Projects] Bugpublic2019-03-10 18:18
ReportertengisuAssigned ToPhyllisSmith 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019-02 
Target VersionFixed in Version2019-03 
Summary0000159: Fails to launch with libvpx.so.5 error
Descriptioncin: error while loading shared libraries: libvpx.so.5: cannot open shared object file: No such file or directory
Additional InformationTried libvpx (1.8.0-1) from extra, libvpx-git, libvpx-full-git. All of them fails to launch cin.
TagsNo tags attached.

Activities

tengisu

tengisu

2019-03-10 15:50

reporter   ~0001160

Just installed cin-5.1-arch-20190309-x86_64.pkg.tar.xz and it's running without any errors.
I've been a longtime kdenlive user but now it's time to try something new.
Thank you.
PhyllisSmith

PhyllisSmith

2019-03-10 01:29

manager   ~0001146

Last edited: 2019-03-10 01:30

View 2 revisions

Andrea: you do your own builds so you should not have this problem because libvpx in configure.ac is set to "auto" which means probe and use the system version if the build operation is not static. So when you build cinelerra and have libvpx 1.8.1-0 it will use that and not expect libvpx.so.5, so no error. It would have been better if I had explicitly stated that it was for users who downloaded Arch builds from cinelerra-gg.org.

The reason I added your name to this issue was because of the Linux kernel upgrade to 5.0 -- this is kind of a big deal. This could potentially have some small impact on Cinelerra and I knew you would keep us informed if you found any problem and we always need that kind of help from you.

Andrea_Paz

Andrea_Paz

2019-03-09 21:49

updater   ~0001141

I don't really understand what tests I have to take. I have compiled the latest version. Isn't that okay? Do I have to install with pacman -U one of the three builds produced by GG?
My Arch is updated every day; I didn't have the problem reported by Tengisu. I tested IgorBeg's project (Issue 137) [not stupid at all ;-)]
PhyllisSmith

PhyllisSmith

2019-03-09 21:04

manager   ~0001140

For Arch users who have recently updated their ARCH systems, in order to run cinelerra, you will have to use a newer build tar/pkg. Here are the download builds for you, in this order 1=static tar, 2=dynamic tar, 3= package and you WILL HAVE TO CHANGE package path:

     https://cinelerra-gg.org/download/tars/cinelerra-5.1-arch-20190309.x86_64-static.txz
     https://cinelerra-gg.org/download/tars/cinelerra-5.1-arch-20190309.x86_64.txz

https://cinelerra-gg.org/download/testing/cin-5.1-arch-20190309-x86_64.pkg.tar.xz

Please pass along any other issues. We tested the new build (I think the static tar) on Arch and it came up and loaded/played a file.
PhyllisSmith

PhyllisSmith

2019-03-09 17:41

manager   ~0001134

@tengisu:
Arch is different and often ahead of other distros. We had just upgraded our Arch build system here on February 21 and it was still using libvpx 1.7.0-1 (so.5) so that is what the tar and package builds are based on. When gg looked at Arch today it is now on libvpx 1.8.0-1(so.6).
So you are getting the libvpx.s0.5 error because you have libvpx.s0.6 now instead and Cin expects libvpx.s0.5 and it is missing.

Anyway, GG just upgraded his Arch and is creating new builds and will pass along the new location when available in a few hours.

@Every Arch user: this will affect other Arch users as well.
The latest Arch is at the NEW LINUX KERNEL of 5.0. There will probably be some impacts using Cin until we get it straightened out.
PLEASE REPORT all issues so we can get this resolved.

We will probably carry 2 Arch builds for a couple of months until all users get upgraded to the latest Arch.
tengisu

tengisu

2019-03-09 12:07

reporter   ~0001128

Forgot to mention I'm on Arch linux.
Sam

Sam

2019-03-09 08:09

manager   ~0001126

Thank you for reporting this problem. What operating system do you use?

Issue History

Date Modified Username Field Change
2019-03-09 06:49 tengisu New Issue
2019-03-09 08:09 Sam Note Added: 0001126
2019-03-09 12:07 tengisu Note Added: 0001128
2019-03-09 17:41 PhyllisSmith Assigned To => PhyllisSmith
2019-03-09 17:41 PhyllisSmith Status new => confirmed
2019-03-09 17:41 PhyllisSmith Note Added: 0001134
2019-03-09 21:04 PhyllisSmith Status confirmed => feedback
2019-03-09 21:04 PhyllisSmith Note Added: 0001140
2019-03-09 21:49 Andrea_Paz Note Added: 0001141
2019-03-10 01:29 PhyllisSmith Note Added: 0001146
2019-03-10 01:30 PhyllisSmith Note Edited: 0001146 View Revisions
2019-03-10 15:50 tengisu Note Added: 0001160
2019-03-10 15:50 tengisu Status feedback => assigned
2019-03-10 18:18 PhyllisSmith Status assigned => resolved
2019-03-10 18:18 PhyllisSmith Resolution open => fixed
2019-03-10 18:18 PhyllisSmith Fixed in Version => 2019-03