View Issue Details

IDProjectCategoryView StatusLast Update
0000184Cinelerra-GG[All Projects] Featurepublic2019-05-03 16:30
ReporterSamAssigned Togoodguy 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2019-03 
Target VersionFixed in Version2019-04 
Summary0000184: Add an apply- button in "Attacht effect" window
DescriptionI was about to add several effects via the "Attach effect" window when I noticed that there was no Apply button at all. I have to open this window again every time. It would be better if I could stay in this window and insert several effects. It was similar with the load window until a apply button was added.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-04-14 16:52

manager   ~0001377

This seems to be working just fine. Will open a new issue for "Aging" plugin as gg thinks he deduced what is causing the error.
IgorBeg

IgorBeg

2019-04-14 15:33

reporter   ~0001376

GG/Phyllis, You are completely right.
I was using AgingTV plugin with "Attach single standalone and share others" and it is occurred dragging the cursor on timeline very quickly. It happened sometime: 4 on 6 times. But I was not able to isolate the issue.

Using Brightness/Contrast plugin instead of AgingTV plugin it works fine.

When I will have more info I will open a new issue. Maybe it is better, I think. Thanks.
PhyllisSmith

PhyllisSmith

2019-04-14 14:57

manager   ~0001375

IgorB: thanks for the dump -- ALWAYS send a dump, even if it can not be reproduced. GG looked at it but can not find the root cause -- it looks like the Aging plugin was "attached" but the problem is not with that -- something happened to the frame buffer and it is gone. Sometimes there is just no way to get the problem to happen again as it depends on the sequence of prior events and sometimes there are so many.
IgorBeg

IgorBeg

2019-04-14 09:22

reporter   ~0001372

I am testing the "Attach single standalone and share others" from Menu-> Video-> Attach effect... window, and Camera/Projector with last Cin-Ub16 (20190413 - built: Apr 13 2019 11:24:22) and a crash is occur.
I added a dump file, but without my steps I don't know if it help (this steps are a bit complicated to explain).
Let me know if you need more info, please.

PS:
I am writing here because maybe it is connected at the "Attach Effect".

cinelerra_6060.dmp.tar.gz (25,759 bytes)
Sam

Sam

2019-04-13 17:35

manager   ~0001367

Thx, it works fine :-)

May be it in conflict with Menu-> Video-> Attack effect... window ?
There, there is the option "Attach single standalone and share others". It works on Armed tracks.
I confirm.
IgorBeg

IgorBeg

2019-04-13 10:25

reporter   ~0001366

Seems to me very good. I will wait Sam (the father of the idea). Thanks.

May be it in conflict with Menu-> Video-> Attack effect... window ?
There, there is the option "Attach single standalone and share others". It works on Armed tracks.
PhyllisSmith

PhyllisSmith

2019-04-13 00:56

manager   ~0001362

The fix has been checked into GIT so that once you hit Apply, the plugin is cleared so if you hit OK, it will not reload.
PhyllisSmith

PhyllisSmith

2019-04-12 17:43

manager   ~0001360

Easy solution GG came up with and will be checked into GIT later today probably. After you hit the Apply button, the highlighted effect is cleared, that way if you hit OK, it will not reload it again and you can just highlight another plugin before hitting apply again.
IgorBeg

IgorBeg

2019-04-12 17:18

reporter   ~0001359

I would do so, if possible:
If you open the Effect window and press at least one time Apply button then OK button don't add any effect and it close the window.
If you open the Effect window and after choose the effect you press OK button (without to have never pressed Apply button) then the effect is added and the Effect window is closed.

What do you think?
Sam

Sam

2019-04-12 15:28

manager   ~0001358

Last edited: 2019-04-12 15:33

View 2 revisions

I can confirm the behaviour observed by Igor. It is indeed somewhat unusual. I also made this mistake. Maybe it would be better if the OK button just closes the window and only the Apply button adds everything.

Update: So when I think about it, we don't need the OK button at all. No idea how to solve it well. Maybe you can think of something else.

IgorBeg

IgorBeg

2019-04-12 12:28

reporter   ~0001355

I tested the new feature really quickly, sorry.
However the effect is applied twice: one with Apply button and another one when I press Ok button.
Otherwise I have to know that, when I use Apply button I have exit from the Effect window with X (Cancel) button. May be, if I know (now I know). ;-)

(Cin-gg_ub16.04_20190412_DateByTestingFolder)
PhyllisSmith

PhyllisSmith

2019-04-12 01:52

manager   ~0001350

This feature has been added and checked into GIT. Until issue # 84 is implemented, at least this should make application of multiple effects easier.
PhyllisSmith

PhyllisSmith

2019-04-02 19:31

manager   ~0001297

Good idea. Because it is not time-consuming, if GG has a left over slice of time, he "might" get this in at the end of today.
Sam

Sam

2019-04-02 19:10

manager  

Issue History

Date Modified Username Field Change
2019-04-02 19:10 Sam New Issue
2019-04-02 19:10 Sam File Added: Attach_Effect_apply_button.png
2019-04-02 19:29 PhyllisSmith Assigned To => goodguy
2019-04-02 19:29 PhyllisSmith Status new => assigned
2019-04-02 19:31 PhyllisSmith Note Added: 0001297
2019-04-12 01:51 PhyllisSmith Assigned To goodguy => PhyllisSmith
2019-04-12 01:52 PhyllisSmith Status assigned => feedback
2019-04-12 01:52 PhyllisSmith Note Added: 0001350
2019-04-12 12:28 IgorBeg Note Added: 0001355
2019-04-12 15:28 Sam Note Added: 0001358
2019-04-12 15:28 Sam Status feedback => assigned
2019-04-12 15:33 Sam Note Edited: 0001358 View Revisions
2019-04-12 17:18 IgorBeg Note Added: 0001359
2019-04-12 17:43 PhyllisSmith Note Added: 0001360
2019-04-13 00:56 PhyllisSmith Note Added: 0001362
2019-04-13 10:25 IgorBeg Note Added: 0001366
2019-04-13 17:35 Sam Note Added: 0001367
2019-04-14 09:22 IgorBeg File Added: cinelerra_6060.dmp.tar.gz
2019-04-14 09:22 IgorBeg Note Added: 0001372
2019-04-14 14:57 PhyllisSmith Note Added: 0001375
2019-04-14 15:33 IgorBeg Note Added: 0001376
2019-04-14 16:52 PhyllisSmith Assigned To PhyllisSmith => goodguy
2019-04-14 16:52 PhyllisSmith Status assigned => resolved
2019-04-14 16:52 PhyllisSmith Resolution open => fixed
2019-04-14 16:52 PhyllisSmith Fixed in Version => 2019-04
2019-04-14 16:52 PhyllisSmith Note Added: 0001377
2019-05-03 16:30 PhyllisSmith Status resolved => closed