View Issue Details

IDProjectCategoryView StatusLast Update
0000187Cinelerra-GG[All Projects] Bugpublic2019-05-03 17:01
ReporterPierreAssigned ToPhyllisSmith 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platformi7-3770k, 32GB(ram), GTX-750TiOSLinux Mint MateOS Version18.3
Product Version 
Target VersionFixed in Version2019-04 
Summary0000187: "F_kemdeint" disrupted my Linux Mint
DescriptionI was testing the different deinterlacing plugins one after the other; Deinterlace-CV, Deinterlacer, F_interlace, F_kemdeint.

I was using HDV source files in .m2t

When I applied "F_kemdeint", quickly after trying to change its options, my linux Mint sent me alert windows: the "window list" then the "Workspace Selector" left unexpectedly". I had to restart my Linux Mint 18.3 to get back to normal operation.



pierre@i7-3770k ~ $ /home/stone/Cinelerra-GG_5.1/cin
Cinelerra Infinity - built: Tue 31 2019 11:13:12
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2018 Heroine Virtual Ltd. by Adam Williams
(c) 2007-2018 cin5 derivative by W.P. Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

RenderFarmClient::main_loop: client started
PluginFFilter::new_ffilter(interlace)
  err : The numerical result is outside the range
PluginFFilter::new_ffilter(interlace)
  err : The numerical result is outside the range
PluginFVClient::activate() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
PluginFVClient::process_buffer() F_interlace
  err : Transaction not allowed
Session time: 0:18:45
Cpu time: user: 0:01:32.027 sys: 0:00:09.721
pierre@i7-3770k ~ $
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-05-03 17:01

manager   ~0001481

I am somewhat hesitant to close this, but I can not reproduce and GG says he has used F_kerndeint and it has always worked really well for him. It can be reopened if it reoccurs.
PhyllisSmith

PhyllisSmith

2019-05-01 14:45

manager   ~0001458

Marking as Resolved and will close in a couple of days. Only time will tell if there is a different problem from what was fixed by disallowing F_interlace.
PhyllisSmith

PhyllisSmith

2019-04-29 23:37

manager   ~0001439

Last edited: 2019-04-29 23:38

View 2 revisions

As previously stated, it is believed from the messages shown, that F_interlace causes a lot of error messages. After GG looked at them, he found out that ffmpeg interlace and tinterlace use the same parameters but some that are legal for tinterlace are illegal for interlace. Since the tinterlace alternative exists, interlace has been removed from the legal plugin list for ffmpeg. This plugin may still show up in your Resources window until the plugins are reloaded, either automatically or manually.

We found that when this plugin was added, the UNDO stack was totally bofus and this may have caused the crash.

I will close this issue after the April builds are complete since then F_interlace plugin will be gone.

PhyllisSmith

PhyllisSmith

2019-04-23 03:16

manager   ~0001415

The F_interlace plugin may be the real cause of the crash as I have been able to get a couple of different error messages from that AND most disturbing is that it causes the UNDO to be totally wrong / not working.

I can not get F_kerndeint to create any problems even though I stressed it out with changing the threshold slider bar over and over and hit apply as quickly as possible.

First I will show GG the errors messages but most likely he will remove F_interlace from the allowed ffmpeg plugins to avoid the possible cause of the issue. I do not know why anyone in this day and age would want to add interlace to video anyway. After that will close this, assuming F_interlace is the cause.
PhyllisSmith

PhyllisSmith

2019-04-12 01:54

manager   ~0001351

I have not yet been able to duplicate this but I want to spend more time trying before giving up.

Issue History

Date Modified Username Field Change
2019-04-07 13:25 Pierre New Issue
2019-04-07 13:27 Pierre Description Updated View Revisions
2019-04-12 01:54 PhyllisSmith Note Added: 0001351
2019-04-23 03:16 PhyllisSmith Note Added: 0001415
2019-04-29 23:37 PhyllisSmith Assigned To => PhyllisSmith
2019-04-29 23:37 PhyllisSmith Status new => acknowledged
2019-04-29 23:37 PhyllisSmith Note Added: 0001439
2019-04-29 23:38 PhyllisSmith Note Edited: 0001439 View Revisions
2019-05-01 14:45 PhyllisSmith Status acknowledged => resolved
2019-05-01 14:45 PhyllisSmith Resolution open => fixed
2019-05-01 14:45 PhyllisSmith Fixed in Version => 2019-04
2019-05-01 14:45 PhyllisSmith Note Added: 0001458
2019-05-03 17:01 PhyllisSmith Status resolved => closed
2019-05-03 17:01 PhyllisSmith Note Added: 0001481