View Issue Details

IDProjectCategoryView StatusLast Update
0000206Cinelerra-GG[All Projects] Bugpublic2019-06-30 22:22
ReporterSamAssigned Togoodguy 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSOpen-SuseOS VersionLeap 15
Product Version2019-04 
Target VersionFixed in Version2019-06 
Summary0000206: m2ts videos are no longer played with vdpau
DescriptionIf hardware acceleration is activated with vdpau, m2ts videos are no longer played and only a black picture is displayed. Also the thumbnails in the Media Tab are black. I get the following error message.

Error retrieving data from GPU to CPU
  err: Unknown error occurred
Error retrieving data from GPU to CPU
  err: Unknown error occurred
Error retrieving data from GPU to CPU
  err: Unknown error occurred

Mp4 videos work fine

TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-06-30 22:22

manager   ~0001835

Workaround and tooltip updated.
Sam

Sam

2019-06-21 00:44

manager   ~0001746

Thanks for the improvement. I find the help text useful.
PhyllisSmith

PhyllisSmith

2019-06-21 00:32

manager   ~0001742

"A small improvement regarding the new option in the settings ...written the manufacturers in the yellow info text (if you move the mouse over the down arrow) or next to them, like for example:
vdpau - Nvidia, Nouveau, Amdgpu
vaapi - Broadcom, Intel HD graphics, Radeon"

A tooltip on the down arrow as suggested has been added. As well as the option of "cuda - Nvidia + Cuda SDK"
Sam

Sam

2019-05-05 21:22

manager   ~0001498

Thank you for the extensive information. I think it is well solved.

A small improvement regarding the new option in the settings. The terms vdpau and vaapi will not mean anything to any normal user. Two weeks ago I also didn't know what these terms mean. I would have written the manufacturers in the yellow info text (if you move the mouse over the down arrow) or next to them, like for example:
vdpau - Nvidia, Nouveau, Amdgpu
vaapi - Broadcom, Intel HD graphics, Radeon

Many new users will then automatically understand what it is about.
PhyllisSmith

PhyllisSmith

2019-05-05 19:49

manager   ~0001497

A couple of days ago, the GIT checkin included the ability to workaround a recalcitrant file, like the m2ts file which came out black and the error retrieving data from the GPU message. These errors are more than inconvenient because they prevent usage of the GPU by the other video files for decoding/playing potential hardware acceleration. The CIN_HW_DEV environment variable is either all or none.

With this latest mod, you can use the environment variable and it will be effective for all of the formats it is able to handle AND you can make an exception for a recalcitrant file that you want in your project. To do this you have to create a file in the same directory with the same name as the error-ing file with the different extension of .opts (along with your file.m2ts original media, you need a file called file.opts). The contents of this .opts file would just be the one line of:

cin_hw_dev=none

Conversely, if you have a bunch of files in your project, like dnxhd format, that are not hardware accelerated but you have an accompanying large file of type .mp4, you can leave the CIN_HW_DEV variable unset (i.e. do not use it) and just create an .opts file containing the line:

cin_hw_dev=vdpau

That test.mp4 with its test.opts side-kick will use the GPU for decoding/playing and the rest will not. This has some advantage because the ones that can not use the GPU, if the environment variable is enabled, there is a teeny bit of time used to check.

I have yet to update the documentation. Also, there is a Settings->Preferences, Performance tab, "Use HW device" flag with a pulldown to set up "none, vdpau, or vaapi" its current purpose is for flexibility but there is a possibility that it might eventually take the place of CIN_HW_DEV but I am resisting.

Precedence of these settings are:
   .opts is checked first so is of the highest priority
   environment variable is checked next
   preferences HW in use settings is lowest priority

Also, now when you have this issue's error message of "error retrieving data from GPU to CPU", a popup will show this right in front of you on the cinelerra window so you do not have to go to look at the startup window to see why the video is black. That way is will be easy to see the problem, and quickly create an .opts file and reload just the one file.

It is important to note that using the .opts file override the default ffmpeg/decode.opts file so you will most likely see more warnings (not really errors) in the startup window because the decode.opts file has "loglevel=fatal" and the default is "loglevel=error". You can also add the loglevel=fatal to your .opts file to avoid this.
PhyllisSmith

PhyllisSmith

2019-05-03 19:37

manager   ~0001488

@Andrea: it is going to take me some time to understand what all of the error messages are -- ticket 201 terminal.txt is puzzling with its error message and then the "black" thumbnails and data. In your last note, the ones that work, but still put out messages if probably due to the "enhanced ffmpeg messages" that went in the last builds. These messages might just be what ffmpeg is reporting and Cinelerra is getting past anyway.

@Both: the m2ts error message of "Error retrieving data from GPU to CPU" is definitely a problem, because you might have loaded 50 files successfully with VDPAU and now have only this 1 that can not be handled. GG is going to see if he can find a way that when just the 1 file does not work, an "opts" file can be created by the user and then it will load using software instead. The graphics card is what is coming back with a problem when it tries to "convert to vframe" and is can not do so. Have to find a good solution because some graphics cards might work and others not.
Andrea_Paz

Andrea_Paz

2019-05-03 09:07

updater   ~0001472

I confirm the issue but I don't understand the problem: it is varying from project to project (mp4 too).

Project 1 (see ticket 201, message 1449):
Error in terminal and error in displaying edit and thumbnails (mp4 too).

Project 2:
4 mp4, single track ==> no error

Project 3:
4 mp4 + 1 ProRes, single track ==> error for only ProRes; no error display.

Project 4:
2 DV on 2 tracks + 4 audio tracks ==> error in terminal; no error display.

terminal-error.txt (5,368 bytes)
PROGETTO 1:

[paz@archpaz cinelerra-5.1]$ LC_ALL=C CIN_HW_DEV=vdpau /home/paz/cinelerra5/cinelerra-5.1/bin/./cin
Cinelerra Infinity - built: May  3 2019 10:34:52
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2018 Heroine Virtual Ltd. by Adam Williams
(c) 2007-2018 cin5 derivative by W.P. Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

Cinelerra Infinity - built: May  3 2019 10:34:52
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2018 Heroine Virtual Ltd. by Adam Williams
(c) 2007-2018 cin5 derivative by W.P. Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

audio0 pad 2 0 (2)
Decoder prores does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/cinelerra/cin-15c/nuvole.pro
  err: Success
audio0 pad 2 -449 (451)
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/mano1.mp4
  err: Invalid data found when processing input
FFStream::decode: failed
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/cielo.3gp
  err: Invalid data found when processing input
FFStream::decode: failed
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/mano1.mp4
  err: Invalid data found when processing input
FFStream::decode: failed
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
Failed to get HW surface format.
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/mano1.mp4
  err: Invalid data found when processing input
FFStream::decode: failed
Decoder prores does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/cinelerra/cin-15c/nuvole.pro
  err: Success
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/erba01.3gp
  err: Invalid data found when processing input
FFStream::decode: failed
audio0 pad 2 0 (2)
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/erba02.3gp
  err: Invalid data found when processing input
FFStream::decode: failed
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/volto.3gp
  err: Invalid data found when processing input
FFStream::decode: failed
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/key01.mp4
  err: Invalid data found when processing input
FFStream::decode: failed
audio0 pad 16 0 (16)
audio0 pad 4 0 (4)
FFStream::decode: avcodec_send_packet failed.
file:/home/paz/video_editing/cinelerra/cin-15c/nunchaku02.mp4
  err: Invalid data found when processing input
FFStream::decode: failed
audio0 pad 2 0 (2)
audio0 pad 4 -1439 (1443)
audio0 pad 0 -415 (415)

PROGETTO 3:

Decoder prores does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/cinelerra/cin-15c/nuvole.pro
  err: Success
Decoder prores does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/cinelerra/cin-15c/nuvole.pro
  err: Success

PROGETTO 4:

OFFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/bars_100.avi
FFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/prpol-rerender2.avi
FFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/bars_100.avi
FFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/prpol-rerender2.avi
Decoder dvvideo does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/prova/prpol-rerender2.avi
  err: Success
Decoder dvvideo does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/prova/prpol-rerender2.avi
  err: Success
Decoder dvvideo does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/prova/bars_100.avi
  err: Success
FFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/bars_100.avi
FFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/bars_100.avi
Decoder dvvideo does not support device type vdpau.
HW device init failed, using SW decode.
file:/home/paz/video_editing/prova/bars_100.avi
  err: Success
FFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/prpol-rerender2.avi
FFMPEG::open_decoder: some stream times estimated: /home/paz/video_editing/prova/prpol-rerender2.avi
audio0 pad 96000 240000 (-144000)
terminal-error.txt (5,368 bytes)
PhyllisSmith

PhyllisSmith

2019-05-02 23:33

manager   ~0001469

5 tested m2ts files here will not use vdpau on my computer configuration.
5 other tested m2ts files here did load with vdpau and they were viewable and playable with this graphics board.

When I uploaded the working m2ts to streamable.com, its makes it into an mp4 file instead and datahost.com is having its usual problams. More later.

Issue History

Date Modified Username Field Change
2019-05-02 22:33 Sam New Issue
2019-05-02 23:33 PhyllisSmith Note Added: 0001469
2019-05-03 09:07 Andrea_Paz File Added: terminal-error.txt
2019-05-03 09:07 Andrea_Paz Note Added: 0001472
2019-05-03 19:37 PhyllisSmith Note Added: 0001488
2019-05-05 19:49 PhyllisSmith Note Added: 0001497
2019-05-05 21:22 Sam Note Added: 0001498
2019-05-06 19:57 PhyllisSmith Assigned To => goodguy
2019-05-06 19:57 PhyllisSmith Status new => assigned
2019-06-21 00:32 PhyllisSmith Status assigned => resolved
2019-06-21 00:32 PhyllisSmith Resolution open => fixed
2019-06-21 00:32 PhyllisSmith Fixed in Version => 2019-06
2019-06-21 00:32 PhyllisSmith Note Added: 0001742
2019-06-21 00:44 Sam Note Added: 0001746
2019-06-30 22:22 PhyllisSmith Status resolved => closed
2019-06-30 22:22 PhyllisSmith Note Added: 0001835