View Issue Details

IDProjectCategoryView StatusLast Update
0000213Cinelerra-GG[All Projects] Bugpublic2019-06-30 19:34
ReporterMatNAssigned ToPhyllisSmith 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformX86_64OSMintOS Version19.1
Product Version 
Target VersionFixed in Version 
Summary0000213: 2019-04 version does not load 4K demo file, earlier versions did.
DescriptionThe following file ¨https://4kmedia.org/lg-dolby-comparison-uhd-4k-demo/¨ for DolbyVison UHD demo used to load fine on previous cin-gg versions, but since 2019-04 it does not. You can get it into resources, but then the right mouse button´s Info->detail shows 0 audio and video tracks.
The file plays fine in VLC.

Steps To ReproduceOpen Cinerella 2019-04, no tracks. ´O´ to load a file, select the file (the unzipped download contains ¨LG Dolby Comparison 4K Demo.ts¨ of 308 MB), select ¨Create new resources only¨ or ¨Append in new tracks¨, hit the green V. It will appear in resources, but no tracks are created if that was selected.
TagsNo tags attached.

Activities

MatN

MatN

2019-06-30 19:28

reporter   ~0001830

@Phyllis,
Your analysis is correct. If I set the probe order to ¨Try FFMpeg first¨, it loads OK. This is tested with version 2019-06 .
So the issue can be closed, is is not a bug.
Thanks, Mat
PhyllisSmith

PhyllisSmith

2019-05-09 21:55

manager   ~0001519

Last edited: 2019-05-09 21:59

View 2 revisions

When I load this file with MPEG instead when I have the FF button on the timeline set to "Try FFMPEG last", it loads it as "MPEG stream" - the old way and does fail as it should.

The jellyfish does not get picket up by MPEG first, so resorts to FFMPEG and will play. In Info in the Resources window, is where I see it is loaded by FFMPEG but Dolby was not. It is also possible you have "Probe Order" set to have ffmpeg last.

MatN

MatN

2019-05-09 20:44

reporter   ~0001518

- VLC plays the file fine.
- File says "MPEG transport stream data"
- Rebuilding index does not help, a few audio message in the terminal window cin was started from.
- mpv also plays it: mpv --hwdec=vaapi --hwdec-codecs=hevc10 LG\ Dolby\ Comparison\ 4K\ Demo.ts

I also tried an slightly larger version of the same file (same title, different content), same result.

Another HEVC/UHD/10bit file from http://jell.yfish.us/ still loads fine: jellyfish-20-mbps-hd-hevc-10bit.mkv.
Sam

Sam

2019-05-09 20:10

administrator   ~0001517

Unfortunately, I can't reproduce the bug. In my case, the video and audio tracks are always displayed in the details, even in the latest version of Cin.
PhyllisSmith

PhyllisSmith

2019-05-09 19:50

manager   ~0001516

I did not do anything unusual and it plays for me on today's build. (I especially like the scene of looking out of the hillside cave.) I also went back to April 27 which should be the same as the April 30th builds and it works. I tried both the X11 and X11-OpenGL drivers.

Run the "file" command on the actual file from a window and see if the file is empty; or try "ffplay" the actual file. If that all looks correct, then in the Resources window "Rebuild index" and reload to see if the Index is corrupted. I do not have any other suggestions at this time.

Issue History

Date Modified Username Field Change
2019-05-09 19:21 MatN New Issue
2019-05-09 19:50 PhyllisSmith Note Added: 0001516
2019-05-09 20:10 Sam Note Added: 0001517
2019-05-09 20:44 MatN Note Added: 0001518
2019-05-09 21:55 PhyllisSmith Note Added: 0001519
2019-05-09 21:59 PhyllisSmith Note Edited: 0001519 View Revisions
2019-05-13 14:16 PhyllisSmith Assigned To => PhyllisSmith
2019-05-13 14:16 PhyllisSmith Status new => feedback
2019-06-30 19:28 MatN Note Added: 0001830
2019-06-30 19:28 MatN Status feedback => assigned
2019-06-30 19:34 PhyllisSmith Status assigned => closed
2019-06-30 19:34 PhyllisSmith Resolution open => no change required