View Issue Details

IDProjectCategoryView StatusLast Update
0000227Cinelerra-GG[All Projects] Bugpublic2019-06-30 22:18
ReporterOlafAssigned Togoodguy 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-06 
Summary0000227: Timeline: Please remove the green cut marks
DescriptionGreen cut marks were inserted, after complaints, the cut edges of the tracks would not be well visible. Instead of moving to another theme with more contrast. These green patches are not updated properly and are even in places where there is no material on the tracks. They cause confusion and disturb more than they help. Attached a screenshot. The problem with the "ghost images" should not only be repaired, but these triangles should be dispensed with for aesthetic reasons.
TagsGUI, Timeline

Activities

PhyllisSmith

PhyllisSmith

2019-06-30 22:18

manager   ~0001832

This is as resolved as it is going to get. With the ability to disable showing the blade cuts, the intrusiveness is gone.
Sam

Sam

2019-06-28 20:57

administrator   ~0001813

Last edited: 2019-06-28 20:58

View 2 revisions

Finally the hard edges have disappeared from the silent areas. Thanks a lot!

“Clear Select” in Edit->Clear... menu is okay. Thanks.
Maybe “Deselect” instead of “Clear Select” could be better? But you should change it also on MMB menu in Timeline, I think.
+1

IgorBeg

IgorBeg

2019-06-28 11:05

reporter   ~0001805

“Clear Select” in Edit->Clear... menu is okay. Thanks.
Maybe “Deselect” instead of “Clear Select” could be better? But you should change it also on MMB menu in Timeline, I think.

Blade cuts/hard edges in muted areas are okay. Really great you are! ;-)
PhyllisSmith

PhyllisSmith

2019-06-28 04:00

manager   ~0001801

"I see these markers in a place that is completely black and should not contain anything." A fix has been checked into GIT to no longer make any blade cuts/hard edges in silent areas.

"Would it make sense for you, to insert, in the new "Clear..." submenu, also the "Clear Select" (Ctrl+Shift+A) option that we find in Timeline window with the MMB (Middle Mouse Button)?" Clear Select has been added to the Edit->Clear submenu.

Ubuntu 16 test build is at:
https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz
Sam

Sam

2019-06-23 13:11

administrator   ~0001769

I agree with Igor, exactly what his video shows is the problem. It's inserted into areas of "hard edges" that are muted. These green markers in areas that shouldn't have any content are confusing and in no way useful.

The other changes I find useful and well solved.
IgorBeg

IgorBeg

2019-06-23 12:26

reporter   ~0001767

Waiting for the reported issue's father (Olaf), and Sam, and Andrea_paz (and all others),...
GG/Phyllis, really good solution for me!
Thanks!

Would it make sense for you, to insert, in the new "Clear..." submenu, also the "Clear Select" (Ctrl+Shift+A) option that we find in Timeline window with the MMB (Middle Mouse Button)? Thanks.
PhyllisSmith

PhyllisSmith

2019-06-23 02:52

manager   ~0001760

A "Clear Hard Edges" has been added after all because gg wanted to make a submenu out of the Edit pulldown, Clear options and old projects can easily have the green hard edges removed. At the same time, the Clear Labels option will now clear ALL labels when no selection or In/Out pointers are set.

An ubuntu16 version is at:
     https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz
PhyllisSmith

PhyllisSmith

2019-06-23 01:17

manager   ~0001758

IgorB - thanks for the video. It is different than the reported "Once the video has been split with a "hard" cut [x], the [m] key also creates "hard" cuts." I am not sure what can be done about what you are demo-ing but will try to find out.

English-> If I was/were you in this case should be If I were you .
IgorBeg

IgorBeg

2019-06-22 08:10

reporter   ~0001755

Phyllis: "can you demo it as I must not be doing it right?"
Phyllis, for the hard edge on mute area, look at the screencast, please. (I hope that Olaf, Sam and me are speaking about the same thing)
https://streamable.com/o3eas

I do not want to waste your time to add a new item "Clear Hard Edges" in the Edit pulldown.
Usually when I do a blade cut, and I do not want "optimize edit function", I delete immediately the hard edges. More, my workflow is different by Olaf and Sam, I think, because I always insert a media from the Viewer: Media-> Viewer (In-Out point)-> Timeline-> Ripple/... (I use very little the Blade cut).
Maybe Olaf, Sam and other users can add something else about.

----------------------
Thanks for the explain about English lesson. Perhaps the example I reported no work fine.
Another sentence is:
Italian-> Se io fossi te
English-> If I was/were you
(thanks and sorry for Off topic)
PhyllisSmith

PhyllisSmith

2019-06-22 00:00

manager   ~0001753

I can not reproduce a mute after a blade cut causing a hard edge to appear. See:
   https://streamable.com/lb0i7
IgorB - can you demo it as I must not be doing it right?

GG will attempt to add a "Clear hard edges" in the Edit pulldown next to "Clear labels" -- or maybe will have to be a submenu due to length. It may be confusing to load an old project and see the green triangles, but I guess that is no different if you load an old project that had the vicons full play enabled and then you turned that off for all future projects and are confused why they show up again.

IgorB: "explain to me if I have to use was or were in the sentence: like if it were before." - it should be like it was before.
Sam

Sam

2019-06-21 15:11

administrator   ~0001751

I confirm, the problem Olaf mentioned is still there.

The ability to hide the green markers is great. For me this option alone would be enough and I would appreciate it if it doesn't disappear anymore, but others might see the need to delete it afterwards and therefore an extended option would be useful.

I'm not sure myself so I prefer to leave the answer to the question about English spelling to the native speakers.
IgorBeg

IgorBeg

2019-06-21 12:47

reporter   ~0001750

The problem Olaf mentioned where a Mute is treated as a Hard Edge after having created a blade cut elsewhere is fixed.
Unfortunately, It is still there.

About Show/Hide Hard Edge with the option in Overlay window, no problem for me and I will check it (like if it were before).
But, for the users that uncheck that option: tomorrow (after 1-2 months) when they will open their old projects, will find a lot of green marker scattered around the timeline, I think. And they will ask themselves: what are these? Perhaps it is better to see the green markers and delete them immediately (if you no needed).


PS (off_ topic):
Mmmpfh! A day someone have to explain to me if I have to use was or were in the sentence: like if it were before. Thanks!
PhyllisSmith

PhyllisSmith

2019-06-21 01:30

manager   ~0001748

Last edited: 2019-06-21 02:15

View 2 revisions

A compromise solution that I think everyone can live with has been checked into GIT. It may not please everyone.
Coming up with an algorithmic set of rules that could be implemented in the code was quite difficult and time-consuming.

Although, IgorB did not especially like the idea of adding "Hard Edges" to the Show Overlays window under the Mask checkbox, this was added and anyone who just does not ever want to see them can uncheck that and it is saved in your xml files and across sessions. You are done; you do not have to read the rest of this since you will never see them again.

The problem IgorB demonstrated in his screencast where you make a blade cut with X, delete the triangles there which effectively remove the cut, and then make the same cut at that same insertion point, you will now get both triangles.

The problem Olaf mentioned where a Mute is treated as a Hard Edge after having created a blade cut elsewhere is fixed.

IgorB: "Might be useful add an option (in Edit menu?) to erase all selected Hard Edges in the armed track?" Yes, I can see the usefulness, but the Edit pulldown is getting kind of big and do we really want to add something that is very infrequently used? Why make the hard cuts in the first place if you just want to delete them? Anyway, the feature could be added if you really think it is necessary.

One last item of note, the reason that Hard Edges are not just that simple (at least for me to understand!), is because the hard edges have to be associated with a "thing" and that "thing" is the edit itself (kind of like a label). It can not be associated with the timeline position because the position is not fixed.

Test version of ubuntu16 is that same as other issue at:
https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

Olaf

Olaf

2019-06-10 11:14

reporter   ~0001714

Yeah, that's how I see it. But Phyllis wrote under point 3 that any misbehaviour of the algorithm should be checked. I didn't mention these other points, because you had already written the necessary one.

Compare your video with the quote from the manual: "Use Shift-left mouse button 1 to toggle off/on the hard edge marker on all tracks simultaneously". I seem to have misinterpreted that. Thanks for the clarification.
IgorBeg

IgorBeg

2019-06-10 10:26

reporter   ~0001713

Olaf, about the Phyllis' point 1, I think that her mean the display of the Hard Edge (green markers) like you can do with Mask, Autos, Projector, Fade in Overlay window. Then you can only show/hide the green markers but them are always there,... and if the new option "Hard Edge" in Overlay window is disabled (hide), tomorrow you can find a lot of green markers in the tracks that you did not see, I think. Only my considerations.

Olaf wrote: "... especially since the command "Shift-left mouse button 1" does not have the desired effect"
Take a look please (my Operating System is UbuntuStudio_16.04):
https://streamable.com/wnn1y
Olaf

Olaf

2019-06-10 08:41

reporter   ~0001712

If I understand this correctly, Phyllis proposes No. 1 as an addition to the procedure described on page 99 of the manual for switching the hard cutting edges on and off. I think this makes sense, especially since the command "Shift-left mouse button 1" does not have the desired effect and, what is more important for me, the handling is made much easier by visible menu items. Whether this happens now on the "Overlay window", there is enough space, or only in the menu "View" is debatable.
IgorBeg

IgorBeg

2019-06-10 07:37

reporter   ~0001711

Only my personal opinion is:
1) I think it would be better not to add "Hard Edge" item to the Overlay window or to hide them. It is better to find a definitive solution if any, at least on the paper, initially with a discussion like you are doing.
2) 3) 4) Seems to me good.

My added suggestion.
Might be useful add an option (in Edit menu?) to erase all selected Hard Edges in the armed track?
The steps to perform that:
a) armed the track(s) where you want to erase the Hard Edges
b) highlight the area in timeline
c) Menu-> Edit-> Delete Hard Edge selected
(if you think it is better another place instead of Edit, and another name instead "Delete Hard Edge selected", okay)
PhyllisSmith

PhyllisSmith

2019-06-09 22:12

manager   ~0001709

I have come up with a Plan to hopefully Implement some improvements; recommending these to gg;

1) add Hard Edge to the Show Overlays window under the Mask checkbox, with default being not to show the green triangle hard edges. This should alleviate the current annoyance while still leaving the ability to be able to delete a Hard Edge or continue to make use of them for custom purposes.
2) when drag a hard-edged clip elsewhere (in drag and drop editing mode - which is not in effect after installing CGG), instead of maintaining the hard edges as is current, delete them all instead.
3)analyze and fix if the algorithm is wrong, the problem IgorB demonstrated in his screencast where you make a blade cut with X, delete the triangles there which effectively remove the cut, and then make the same cut at that same insertion point, and get right triangle only.
4) figure out why a Mute is treated as a Hard Edge after having created a blade cut elsewhere.

I believe that I was able to reproduce all of the cases that people are interested in seeing changed.
Olaf

Olaf

2019-06-07 13:13

reporter   ~0001686

Thanks to the video, the thing can also be reproduced at any time. I wrote: These markers also lie on used tracks where there are no cuts.
The ghost marks are produced by shifting "hard" cut material. Each movement of these cut pieces creates new markers at each new position, until they lose the markers by themselves during the move. If other material is then pushed to this position, the markers are placed on top. Wasn't that hard, was it?
Olaf

Olaf

2019-06-07 12:21

reporter   ~0001685

Your video illustrates the thing and explains the feature, IgorBeg. So only the ghost marks remain. (I don't expect a menu item on the right mouse button with highlighted area to merge. But a description, which you can find under "green triangles" or "green flags" or "green markers", already.)
Olaf

Olaf

2019-06-07 11:53

reporter   ~0001684

Thank you for your explanatory addition, Sam.
> "For this reason, I would generally remove these markers in such empty places."
These markers also lie on used tracks where there are no cuts. I just wanted to mention that again.
IgorBeg

IgorBeg

2019-06-07 11:53

reporter   ~0001682

In add to Phyllis wrote, take a look the screencast please.
https://streamable.com/v0x00
Sam

Sam

2019-06-07 10:26

administrator   ~0001681

It is indeed annoying and for this reason I have to agree with Olaf that these cutting marks are actually inserted at a place where there is nothing. Internally, because of optimization, it may make sense, but from the user's point of view, the markers are misleading. I see these markers in a place that is completely black and should not contain anything.

The problem is that the internal function logic is made visible to the user, but it doesn't give the user any added value at all, and that's why the user feels that these markers are annoying. For this reason, I would generally remove these markers in such empty places.
Olaf

Olaf

2019-06-07 09:24

reporter   ~0001680

1-4: Ok

5-6: Once the video has been split with a "hard" cut [x], the [m] key also creates "hard" cuts. (I assumed the principle difference between [x] and [m] to be known.) If an area is highlighted, the [x] key creates cuts, sometimes "hard" sometimes "soft", often only at one cutting edge. For me this is not comprehensible.

I don't care if internal optimizations run, as long as my timeline doesn't change. Does it? I don't understand why markers have to be displayed for a piece that has already been cut away (with reservation, it could also be ghosts.)

I added an exemplary screenshot, I add another one. This time I marked the ghosts of the "hard" cuts, which multiply with changing the duration of the timeline, with labels. So everywhere where a label can be seen "hard" cuts appear depending on the visibility.

> "What are the exact steps to create the "ghosts"? If I can reproducably create this problem, it can be repaired."

Install CGG, place videos on the timeline, cut and position, keyframes for fading and camera. My PC is based on Intel Xeon with a GeForce graphics card.

Marked_ghosts.png (109,172 bytes)
Marked_ghosts.png (109,172 bytes)
PhyllisSmith

PhyllisSmith

2019-06-07 04:01

manager   ~0001679

Last edited: 2019-06-07 04:15

View 3 revisions

The green cut marks are not "deco" items; they are checkbox flags in the program indicating a hard cut that is not to be optimized. So ... Cinelerra has built in optimization on the timeline which means whenever two parts on the timeline are sequential frames, it automatically optimizes by making them into 1 item. Thus if you are cutting, dragging, editing, or whatever and somehow frame # 40 ends up right next to frame # 41, it optimizes them together the next time an edit occurs. This optimization is sprinkled all over the code. These green checkbox flags prevent the optimization from occurring so that your blade cut does not disappear.

When you mouse over a green cut mark, a diagonal arrow appears and if you click on that, the green triangle disappears which means the flag is no longer set, optimization can occur if both the right and left triangles are gone, and you no longer have a blade cut as the 2 pieces are now back together. You can see this:

1) move the insertion pointer where you want a blade cut
2) key in x to do the cut
3) mouse over the left and right green triangles and left mouse click to delete each
4) YES, you still see that the video is in 2 pieces now, but...
5) move the insertion pointer to another place on the video
6) highlight that area, and key in "m" for mute
7) WITHOUT the green flags set, you just lost your blade cut due to optimization

There has to be something to indicate there is a blade cut. What do you suggest to use instead? would substituting a broken vertical line be an acceptable alternative? and even then, how would you turn off the blade cut if you do want optimization? We currently have not been able to come up with a good solution. There has to be SOMETHING to click on, in order to delete a blade cut, like what you do to delete a keyframe or an auto.

What are the exact steps to create the "ghosts"? If I can reproducably create this problem, it can be repaired.

Sam

Sam

2019-06-03 09:15

administrator   ~0001639

I agree, it doesn't look aesthetic. +1
Olaf

Olaf

2019-06-03 08:43

reporter  

Issue History

Date Modified Username Field Change
2019-06-03 08:43 Olaf New Issue
2019-06-03 08:43 Olaf Tag Attached: GUI
2019-06-03 08:43 Olaf Tag Attached: Timeline
2019-06-03 08:43 Olaf File Added: green_cut_marks_everywhere.png
2019-06-03 09:15 Sam Note Added: 0001639
2019-06-07 04:01 PhyllisSmith Note Added: 0001679
2019-06-07 04:08 PhyllisSmith Note Edited: 0001679 View Revisions
2019-06-07 04:15 PhyllisSmith Note Edited: 0001679 View Revisions
2019-06-07 09:24 Olaf File Added: Marked_ghosts.png
2019-06-07 09:24 Olaf Note Added: 0001680
2019-06-07 10:26 Sam Note Added: 0001681
2019-06-07 11:53 IgorBeg Note Added: 0001682
2019-06-07 11:53 Olaf Note Added: 0001684
2019-06-07 12:21 Olaf Note Added: 0001685
2019-06-07 13:13 Olaf Note Added: 0001686
2019-06-09 22:12 PhyllisSmith Note Added: 0001709
2019-06-10 07:37 IgorBeg Note Added: 0001711
2019-06-10 08:41 Olaf Note Added: 0001712
2019-06-10 10:26 IgorBeg Note Added: 0001713
2019-06-10 11:14 Olaf Note Added: 0001714
2019-06-21 00:44 PhyllisSmith Assigned To => goodguy
2019-06-21 00:44 PhyllisSmith Status new => assigned
2019-06-21 01:30 PhyllisSmith Status assigned => feedback
2019-06-21 01:30 PhyllisSmith Note Added: 0001748
2019-06-21 02:15 PhyllisSmith Note Edited: 0001748 View Revisions
2019-06-21 12:47 IgorBeg Note Added: 0001750
2019-06-21 15:11 Sam Note Added: 0001751
2019-06-22 00:00 PhyllisSmith Note Added: 0001753
2019-06-22 08:10 IgorBeg Note Added: 0001755
2019-06-23 01:17 PhyllisSmith Note Added: 0001758
2019-06-23 02:52 PhyllisSmith Note Added: 0001760
2019-06-23 12:26 IgorBeg Note Added: 0001767
2019-06-23 13:11 Sam Note Added: 0001769
2019-06-28 04:00 PhyllisSmith Note Added: 0001801
2019-06-28 11:05 IgorBeg Note Added: 0001805
2019-06-28 20:57 Sam Note Added: 0001813
2019-06-28 20:58 Sam Note Edited: 0001813 View Revisions
2019-06-30 22:18 PhyllisSmith Status feedback => closed
2019-06-30 22:18 PhyllisSmith Resolution open => fixed
2019-06-30 22:18 PhyllisSmith Fixed in Version => 2019-06
2019-06-30 22:18 PhyllisSmith Note Added: 0001832