View Issue Details

IDProjectCategoryView StatusLast Update
0000241Cinelerra-GG[All Projects] Bugpublic2019-10-06 18:15
ReporterIgorBeg Assigned Togoodguy  
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Platformx64OSLinux-UbuntuStudioOS Version16.04
Product Version 
Target VersionFixed in Version2019-07 
Summary0000241: Color window in Gradient plugin
Description

The Color window opened with “Inner color” or “Outer color” buttons has not the OK and Cancel buttons on the bottom corners.
Other plugins like Titler and Sketcher have it; then, <b>only for consistency</b>, would be good to have. Thanks.

Additional Information

Cinelerra-GG version: ub16-20181231 ... ub16-20190607

TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-10-06 18:15

manager   ~0002215

Forgot to close a couple of months ago!

PhyllisSmith

PhyllisSmith

2019-07-06 20:50

manager   ~0001867

"Is 3.610s (and 0.810s) the time that cpu is busy to run that specific routine?" Yes

IgorBeg

IgorBeg

2019-07-06 10:40

reporter   ~0001862

Thanks Phyllis for your explanation. And I think that “prof2” is very good tool (mostly in the hands of GG and Phyllis) to understand where the problem may be.

<i>3.610s versus .810s</i>
Is 3.610s (and 0.810s) the time that cpu is busy to run that specific routine?

<i>OK, I think this can be marked resolved soon.</i>
By my point of view, user, and my tests, for me it is okay. And if it has also been confirmed by “prof2” and GG/Phyllis’ analysis, you can resolve/close the issue.
Thanks!

PhyllisSmith

PhyllisSmith

2019-07-05 21:00

manager   ~0001860

OK, I think this can be marked resolved soon.
Thanks for the profile output -- you can see before and after results in Igor's profile output as follows:

Hesitancy:
3.610s 7.3% ColorButtonPicker::update_gui() 1.0 /home/charlie/...
3.620s 7.3% ColorButton::update_gui(int, int) 1.0 /home/charlie/A...
3.630s 7.4% ColorButtonThread::run() 1.0 /home/charlie/AppImage...
After Fix:
0.770s 3.0% ColorButtonPicker::handle_new_color(int, int) 1.0 /home/charlie/...
0.810s 3.1% ColorButton::update_gui(int, int) 1.0 /home/charlie/AppImage/cin...

3.610s versus .810s

Also, gg added a USR1 interrupt to the profiler and I updated the document (prof2.pdf) so that plugins can be better measured to avoid including the load time which can be misleading.

IgorBeg

IgorBeg

2019-07-05 11:45

reporter   ~0001853

Yeah! The last build Ub16-20190705 (built: Jul 4 2019 18:18:45) works fine. No more hesitancy.
Tested in Gradient, Titler and Sketcher. Thanks a lot, GGG (Great GG)!

Thanks Phyllis for the new instruction for the “prof” program.
If can be useful to demonstrate before/after the hesitancy I added the files create by “prof” using the Gradient plugin (the two screencasts to sync, if it has sense, with the “prof” info):

prof-cin201907-03-05_withGradient.tar.gz



prof-cin201907-03-05_withGradient.tar.gz (21,790 bytes)
PhyllisSmith

PhyllisSmith

2019-07-04 22:58

manager   ~0001850

IgorB: gg made a mod to colorpicker and just checked it in. We are not sure if this fixes it for you but are hoping so. A new build is at:

https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

If it does not, try running the profiler again with a -p parameter for the path, like:

prof -p /usr/lib/libprofile.so /mypath/cin

IgorBeg

IgorBeg

2019-07-04 19:15

reporter   ~0001849

Phyllis, thanks for the new build and the info/steps to use prof2.
Unfortunately, when I run <b>prof /mypath/cin</b>, "cant find libprofile.so" message came out.
I checked in /usr/lib/, and that file is there.

Consider I moved the files like explained in your steps except for the administrator privilege:
sudo mv libprofile.so /usr/lib/
sudo mv prof smap /usr/bin/

What I wrong? Thanks.

PhyllisSmith

PhyllisSmith

2019-07-04 14:34

manager   ~0001848

Andrea, thank you for testing as it is good to know that the documentation could be followed. GG found no glaring problems in looking at the output (as expected!) Also, you gave him a idea for another small improvement.

Andrea_Paz

Andrea_Paz

2019-07-04 09:20

updater   ~0001847

I did a quick test playing with masks, gradient filter and histogram. I attached the file prof.



prof_list.tar.gz (9,865 bytes)
PhyllisSmith

PhyllisSmith

2019-07-03 17:44

manager   ~0001846

IgorB: OK, when and if you have time, please run the prof2 profiler with the latest Ubuntu 16 build. These are at:

https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz
https://www.cinelerra-gg.org/download/testing/prof2_ub16.tgz
https://www.cinelerra-gg.org/download/prof2.pdf

Usage of prof2 is documented in the pdf file BUT you will not have to build it because the tar ball (.tgz) has it already built for ubuntu 16. Instructions for getting it setup are as follows:

The prof2_ub16.tgz file contains:
libprofile.so prof smap
so... create a tmp directory, cd to it and
tar -xzf /path/prof2_ub16.tgz
mv libprofile.so /usr/lib/.
mv prof smap /usr/bin/.
this will install the prof2 profiler on your system.

Then you just run it: prof /path/cin

GG is going to inspect the colorpicker code to see if there is anything strange. We can not reproduce here. Also, the Ubuntu16 build includes the keyframable Mask Rotate and Scale fix.

IgorBeg

IgorBeg

2019-07-02 07:15

reporter   ~0001843

Other info:
(referred to cinelerra-5.1-ub16.04-20190630.x86_64-static -built: Jun 30 2019 08:19:07)

The Color picker (the color wheel) works fine in plugins:

  • Chroma key
  • Chroma key (HSV)
  • Color3way.

The hesitancy, there is always in plugins:

  • Gradient
  • Titler
  • Sketcher

Settings:
Preferences-> Playback_A-> VideoOut-> VideoDriver: X11 (use direct x11 render if possible)
Preferences-> Performance-> Use HW Device = none

PhyllisSmith

PhyllisSmith

2019-06-30 22:16

manager   ~0001831

Changes to colorpicker.C, which is used by both Gradient and the Title plugins, were indeed made on June 27th in order to get the Gradient plugin interface to look the same as other colorpickers. GG is going to create a Ubuntu16 profiler binary for IgorB to use to try and determine where the code is spending so much time, thus causing the weird hesitancy. We can not reproduce the problem here still.

IgorBeg

IgorBeg

2019-06-30 12:07

reporter   ~0001827

The hesitancy, always occur in the Gradient’s Color window and in the Titler’s Color .
In the Color3way plugin, the color wheel works fine.
I tested on three Cin version, always for UbuntuStudio16.04:
a) cinelerra-5.1-ub16.04-20190531.x86_64-static
b) cinelerra-5.1-ub16.04-20190627.x86_64-static_testing (built: Jun 26 2019 18:34:39)
c) cinelerra-5.1-ub16.04-20190629.x86_64-static_testing (built: Jun 29 2019 13:47:53)

In a) e b) point they are okay.
After Cin20190627 version there is always this hesitancy.

I think that it depends by Color window not by Titler or Gradient. But I am guessing.

@Andrea_paz: thanks. My PC is really old, but this behaviour is strange because in the previous releases (before 20190627) didn’t occur.

PhyllisSmith

PhyllisSmith

2019-06-30 00:12

manager   ~0001826

Last edited: 2019-06-30 00:39

View 3 revisions

GG is working on the Sketcher hang up. Thanks to Igor for reporting and Andrea for confirming.
The Gradient color is different because a lot of work was done on it in June (around June 6) as it was not working correctly in OpenGL. The effort was made to have the OpenGL and the X11 driver versions look the same. In May the 2 versions looked quite different.

A fix will be checked into GIT before tomorrow's builds.

OK, gg has analyzed Color3Way and said it does not use the same code as the Gradient and Title plugins.
Question for IgorB -- when you say that the Titler also has the hesitancy, do you mean that it also is a new behavior between now and last month's release? Work was done on Gradient the the behavior is explainable BUT no work was done this month on the Titler, so if there is new behavior, we need to investigate further.

Andrea_Paz

Andrea_Paz

2019-06-29 15:39

updater   ~0001822

1- I have no hesitation moving the cursor of the Color Picker (hardware more powerful?). In any case, if you didn't do it before, there's something going on.
2- I only have one CinGG installed and I can't verify it.
3- I also get a freeze trying to move the cursor of the Color Picker in the Sketcher plugin.

IgorBeg

IgorBeg

2019-06-29 10:17

reporter   ~0001821

That symptom (hesitancy), always occur in the Color window, also in Titler.
In the Color3way plugin the color wheel works fine.
In the Cin-GG-20190531 it is okay. I don’t know if it can help.

I have noticed that the Gradient colour is different by Cin releases: Cin20190531 vs Cin20190628a.
I only opened the same project with the two Cin releases and the effect is different.
I added a gif animated; yes, it is not full colour because it is a gif, but it is good. You can see that the shape’s colour (blu?) on the left side changes.

GradientPlugin_20190531-vs-20190628a.gif

More (and I should open a new ticket), to see if it occured also in the Sketcher plugins, when I open the Color window, Cinelerra freezes. And I have to use Ctrl+C in terminal to escape.
I added the compressed dump.

cinelerra_6195.dmp.tar.gz



cinelerra_6195.dmp.tar.gz (21,170 bytes)
PhyllisSmith

PhyllisSmith

2019-06-29 00:57

manager   ~0001818

IgorB: "When I move the mouse pointer, holding down LMB, there is a kind of doubtful (uncertainty)."
I see this in your demo but I do not see this on my laptop (I will try it on a smaller laptop later). GG had recoded the color picker for Cinelerra some while back but had not updated any in the plugins -- most likely the recode is handling events differently and that is the cause of the hesitancy. I do not think there is anything we will be able to do about this but I will have GG at least inspect the code to check.

IgorBeg

IgorBeg

2019-06-28 11:05

reporter   ~0001804

When I move the mouse pointer, holding down LMB, there is a kind of doubtful (uncertainty).
Look at the screencast, please.

link to GradientPlugin-color-doubtful.ogv
https://streamable.com/w3wvq
In the previous testing release (and monthly) there isn’t.

Also I saw that now you have to click on the colour rectangle, and the buttons on the left side have been replaced by the text. Good. Thanks.

PhyllisSmith

PhyllisSmith

2019-06-28 03:34

manager   ~0001800

This has been checked into GIT. A ubuntu16 build is at:
https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

PhyllisSmith

PhyllisSmith

2019-06-08 13:16

manager   ~0001692

I confirm. Should be easy to fix.

Issue History

Date Modified Username Field Change
2019-06-08 07:54 IgorBeg New Issue
2019-06-08 13:16 PhyllisSmith Assigned To => PhyllisSmith
2019-06-08 13:16 PhyllisSmith Status new => confirmed
2019-06-08 13:16 PhyllisSmith Note Added: 0001692
2019-06-28 03:33 PhyllisSmith Assigned To PhyllisSmith => goodguy
2019-06-28 03:34 PhyllisSmith Note Added: 0001800
2019-06-28 11:05 IgorBeg Note Added: 0001804
2019-06-29 00:57 PhyllisSmith Note Added: 0001818
2019-06-29 10:17 IgorBeg File Added: GradientPlugin_20190531-vs-20190628a.gif
2019-06-29 10:17 IgorBeg File Added: cinelerra_6195.dmp.tar.gz
2019-06-29 10:17 IgorBeg Note Added: 0001821
2019-06-29 15:39 Andrea_Paz Note Added: 0001822
2019-06-30 00:12 PhyllisSmith Note Added: 0001826
2019-06-30 00:16 PhyllisSmith Note Edited: 0001826 View Revisions
2019-06-30 00:39 PhyllisSmith Note Edited: 0001826 View Revisions
2019-06-30 12:07 IgorBeg Note Added: 0001827
2019-06-30 22:16 PhyllisSmith Note Added: 0001831
2019-07-02 07:15 IgorBeg Note Added: 0001843
2019-07-03 17:44 PhyllisSmith Note Added: 0001846
2019-07-04 09:20 Andrea_Paz File Added: prof_list.tar.gz
2019-07-04 09:20 Andrea_Paz Note Added: 0001847
2019-07-04 14:34 PhyllisSmith Note Added: 0001848
2019-07-04 19:15 IgorBeg Note Added: 0001849
2019-07-04 22:58 PhyllisSmith Note Added: 0001850
2019-07-04 22:59 PhyllisSmith Status confirmed => feedback
2019-07-05 11:45 IgorBeg File Added: prof-cin201907-03-05_withGradient.tar.gz
2019-07-05 11:45 IgorBeg Note Added: 0001853
2019-07-05 11:45 IgorBeg Status feedback => assigned
2019-07-05 21:00 PhyllisSmith Note Added: 0001860
2019-07-06 10:40 IgorBeg Note Added: 0001862
2019-07-06 20:50 PhyllisSmith Status assigned => resolved
2019-07-06 20:50 PhyllisSmith Resolution open => fixed
2019-07-06 20:50 PhyllisSmith Fixed in Version => 2019-07
2019-07-06 20:50 PhyllisSmith Note Added: 0001867
2019-10-06 18:15 PhyllisSmith Status resolved => closed
2019-10-06 18:15 PhyllisSmith Note Added: 0002215