View Issue Details

IDProjectCategoryView StatusLast Update
0000244Cinelerra-GG[All Projects] Bugpublic2019-06-21 21:38
ReporterOlafAssigned ToPhyllisSmith 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000244: Cinelerra freezes when clicking on menu item
DescriptionHelp, help! Cinelerra freezes as soon as I click on Main Menu Shell Commands RenderMux!
Steps To ReproduceClick on Main Menu Shell Commands RenderMux
Additional InformationRe: 0000240 "users should learn what it is meant for before using it."
Sorry, not possible in this case.

stopgap:
--- cinelerra-5.1/doc/RenderMux.sh
+++ /usr/share/cin/doc/RenderMux.sh
@@ -1,3 +1,4 @@
        #!/bin/bash
+ exit 0
        exec >& /tmp/render_mux.log
        echo == $0 $@
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-06-21 00:43

manager   ~0001745

Every one has a different style - that includes users as well as programmers!. We have learned from the script and resolved "Cinelerra freezes when clicking on menu item". Preventing hangs is a good goal no matter how you get there. I will mark this closed in a couple of days in case anyone wants to comment still.
Olaf

Olaf

2019-06-18 08:37

reporter   ~0001740

The important part from my script, the checking of the variables, you have taken over. The rest is completely under the table, true to the motto: The user, the disturbing creature. Of course, this also has advantages, you can create screencasts that show how the user opens a console and checks the result in the log using a pager.
Olaf

Olaf

2019-06-11 17:31

reporter   ~0001719

Hm ...
Added "&" to the settings: "$CIN_DAT/doc/RenderMux.sh &" but it didn't do much on its own. So I extended the script. Seems to work, is now a bit foolproof and gives a feedback.

RenderMux-lokal.sh (827 bytes)
PhyllisSmith

PhyllisSmith

2019-06-10 22:32

manager   ~0001716

Works for me. Can not reproduce any error. Demo shows logged on as ordinary user where first I show playing, then execute render mux script, then play again to show it did not hang, execute render mux script again, then play again with no problem. Next I add labels, bring up the render menu, render using labels to create 4 files, execute render mux script and it still plays so no hangs. Leave Cinelerra, display the render_mux.log which shows it worked to concatenate them together, then show the resulting file from that of demo.mp4, then show the other 4 partial files and the date. See demo.

https://streamable.com/yc80q

Perhaps it is an Operating System or type of Unix shell being used. Even when ffmpeg had no link, it still worked but displayed the command error message. Can not fix an error that can not be reproduced here.

Issue History

Date Modified Username Field Change
2019-06-10 07:32 Olaf New Issue
2019-06-10 22:22 PhyllisSmith Assigned To => PhyllisSmith
2019-06-10 22:22 PhyllisSmith Status new => assigned
2019-06-10 22:32 PhyllisSmith Note Added: 0001716
2019-06-11 17:31 Olaf File Added: RenderMux-lokal.sh
2019-06-11 17:31 Olaf Note Added: 0001719
2019-06-18 08:37 Olaf Note Added: 0001740
2019-06-21 00:43 PhyllisSmith Note Added: 0001745
2019-06-21 21:38 PhyllisSmith Status assigned => closed
2019-06-21 21:38 PhyllisSmith Resolution open => fixed