View Issue Details

IDProjectCategoryView StatusLast Update
0000248Cinelerra-GG[All Projects] Bugpublic2019-06-30 22:19
ReporterOlafAssigned Togoodguy 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-06 
Summary0000248: Asset Info: Fix interlacing
DescriptionFor some time now I have been restoring music videos from the 80s from a DVD. These videos are all interlaced. The "Asset Info window" contains three lines about interlacing (manual page 53). The default setting is "automatically fix interlacing".

I seem to remember that someone on the CV mailing list wrote that these settings didn't do anything.

The problem is, the user doesn't know if this feature works or not. If it grabs, how far does it affect the material? Does it work with the deinterlacing plugins or does it interfere with clean deinterlacing? In my case it's 48 videos, so I'd have to open this dialog for each video and turn it off. But if it doesn't work, it should be removed. Because such a thing obviously only causes confusion.
TagsAsset Info, Assetedit, GUI, Interlace correction, Interlacing

Activities

PhyllisSmith

PhyllisSmith

2019-06-30 22:19

manager   ~0001833

The Fix Interlacing fields that provided no capability have been deleted.
PhyllisSmith

PhyllisSmith

2019-06-28 03:21

manager   ~0001799

Last edited: 2019-06-28 03:21

View 2 revisions

The lines in the Resource window, Media Info that read "Fix Interlacing" and "Interlacing correction" have been deleted from the code base. It was quite a few lines but it should not lead to any problems. The line "Asset's interlacing" is retained as this field is used for creating DVDs. This has been checked into GIT and will be marked resolved soon.

Olaf

Olaf

2019-06-17 08:08

reporter   ~0001736

Maybe the files interlacemodes.h and interlacemodes.C contain further information for developers? I also see a refer to mjpegtools/yuv4mpeg.h there.
PhyllisSmith

PhyllisSmith

2019-06-16 21:46

manager   ~0001734

I tried to find this in old CV pipermail but was unable to. But from an email by Igor Ubuntu on May 8, 2016, is:

 "In each media file properties it is possible to define the "Asset's interlacing". Asset's interlacing => "The type of interlacing the asset has" (In asset-> you set the interlacing mode of the source material.)... For each asset, if cinelerra can detect the interlacing for the source, (currently only for quicktime-DV at the moment) it will set the interlacing as appropriate, otherwise it will default to "unknown"..."

So it looks like it is just for: CURRENTLY ONLY FOR QUICKTIME-DV. So it does not seem at all worthwhile but I do not have a file to test it on anyway.
Olaf

Olaf

2019-06-16 17:39

reporter   ~0001733

Re By the way, I've determined it's the material that matters. CGG has a handful of these plugins with them, there is something for everyone. A combination of the deinterlacing filters leads to better results: yadif=1:-1:0,mcdeint=2:1:10. If you feel like it, try the following combination: yadif=0:-1:0,nlmeans. And if your computer has enough power then: yadif=1:-1:0,mcdeint=2:1:10,nlmeans.
PhyllisSmith

PhyllisSmith

2019-06-16 16:49

manager   ~0001732

It should probably be removed but I will have gg look closely at the code to see if it has some unknown and undocumented purpose that might be useful and then document it correctly. BTW - F_kerndeint seems to provide the best deinterlace tool.

Issue History

Date Modified Username Field Change
2019-06-16 08:25 Olaf New Issue
2019-06-16 08:28 Olaf Tag Attached: Assetedit
2019-06-16 08:28 Olaf Tag Attached: Interlacing
2019-06-16 08:30 Olaf Tag Attached: Asset Info
2019-06-16 08:30 Olaf Tag Attached: Interlace correction
2019-06-16 08:32 Olaf Tag Attached: GUI
2019-06-16 16:49 PhyllisSmith Note Added: 0001732
2019-06-16 17:39 Olaf Note Added: 0001733
2019-06-16 21:46 PhyllisSmith Note Added: 0001734
2019-06-17 08:08 Olaf Note Added: 0001736
2019-06-28 03:06 PhyllisSmith Assigned To => goodguy
2019-06-28 03:06 PhyllisSmith Status new => assigned
2019-06-28 03:21 PhyllisSmith Status assigned => acknowledged
2019-06-28 03:21 PhyllisSmith Note Added: 0001799
2019-06-28 03:21 PhyllisSmith Note Edited: 0001799 View Revisions
2019-06-30 22:19 PhyllisSmith Status acknowledged => closed
2019-06-30 22:19 PhyllisSmith Resolution open => fixed
2019-06-30 22:19 PhyllisSmith Fixed in Version => 2019-06
2019-06-30 22:19 PhyllisSmith Note Added: 0001833