View Issue Details

IDProjectCategoryView StatusLast Update
0000281Cinelerra-GG[All Projects] Featurepublic2019-10-02 00:41
ReporterOlaf Assigned ToPhyllisSmith  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-09 
Summary0000281: Resources: Preview for nest sequences
Description

The imported nest sequences lack any preview. (Calling the "Info" results in a segv on my computer, but that's not the point here.)

Additional Information

I noticed this some time ago when the preview function was revised, and when I read about the implementation of nested timelines in Magix Vegas Pro 17 I remembered it again.

Here's an excerpt for information on what the "competition" is up to: "For collaborative work Magix emphasizes the new Nested Timeline functions. With this feature, timelines can not only be nested - as with the competition - but also saved as individual subprojects and edited separately. This allows several editors to work separately on subtimelines, which can then be semiautomatically merged into a master timeline."

Does anyone still consider a preview for nest sequences useful or are there reasons against it?

TagsResources window

Activities

PhyllisSmith

PhyllisSmith

2019-09-16 15:32

manager   ~0002155

For now, this is as resolved as it can get.
Hopefully, in the future, another better idea for implementation will be thought of.

IgorBeg

IgorBeg

2019-09-15 10:24

reporter   ~0002143

GG/Phyllis, I can understand. Thank you.

PhyllisSmith

PhyllisSmith

2019-09-14 21:51

manager   ~0002142

"about the first black frame. If it were possible to find a solution"
Unfortunately, a number of alternative methods were tested by actually programming them in but results were bad, spotty, or jumpy. One such test was to go to the first keyframe - well going to the first keyframe was just the same as the first image - and going to the next keyframe often would end up being no next keyframe at all. Other options tested ended up with fading in or just another bad image. The nested sequences can be quite complicated renderings and possibly a user could have a few in their project - no one wants to wait around for these thumbnails to play instead of being able to do real work.

If another idea comes up, it can be tried and if there are good results, then implemented. Or quantum computers arrive.

IgorBeg

IgorBeg

2019-09-14 09:10

reporter   ~0002140

I just saw this new feature (Preview for nest sequences).
Very good, however I agree with Olaf about the first black frame. If it were possible to find a solution, it would be good, I think. Thanks!

Olaf

Olaf

2019-09-13 18:01

reporter   ~0002134

@PhyllisSmith,
the first single frame is always such a thing, often it is monochrome black. Isn't it possible to fast-forward a little, to 3 or 5 percent? Just like the desktop thumbnailers do. In the other modes except "Full Play" this would also be appropriate, because the preview jumps back again to the first image (mouse over) or stays with "Src Target" in the color of the first frame.

PhyllisSmith

PhyllisSmith

2019-09-13 04:03

manager   ~0002125

Preview in the Media folder will now show the first single frame for nested imported sequences. Because we do not yet have Quantum Computers, only a single frame is pre-viewable That is because playing 5 seconds of the video requires seeking and for nested sequences, it would be intolerably slow.

An ubuntu16 build is available for download in the usual place. If anyone sees a specific case that does not display the Preview, please provide a test case with instructions of how to create it.

Also the Info segv has been fixed.

PhyllisSmith

PhyllisSmith

2019-09-10 22:36

manager   ~0002109

I at least can confirm that "info" gives a SEGV and will find out about preview.

v4t

v4t

2019-09-10 11:37

reporter   ~0002103

For me, there are no reasons against it.

Issue History

Date Modified Username Field Change
2019-08-09 10:48 Olaf New Issue
2019-08-09 10:58 Olaf Tag Attached: Resources window
2019-09-10 11:37 v4t Note Added: 0002103
2019-09-10 22:36 PhyllisSmith Assigned To => PhyllisSmith
2019-09-10 22:36 PhyllisSmith Status new => confirmed
2019-09-10 22:36 PhyllisSmith Note Added: 0002109
2019-09-13 04:03 PhyllisSmith Note Added: 0002125
2019-09-13 18:01 Olaf Note Added: 0002134
2019-09-14 09:10 IgorBeg Note Added: 0002140
2019-09-14 21:51 PhyllisSmith Note Added: 0002142
2019-09-15 10:24 IgorBeg Note Added: 0002143
2019-09-16 15:32 PhyllisSmith Status confirmed => resolved
2019-09-16 15:32 PhyllisSmith Resolution open => fixed
2019-09-16 15:32 PhyllisSmith Fixed in Version => 2019-09
2019-09-16 15:32 PhyllisSmith Note Added: 0002155
2019-10-02 00:41 PhyllisSmith Status resolved => closed