View Issue Details

IDProjectCategoryView StatusLast Update
0000307Cinelerra-GG[All Projects] Bugpublic2019-10-14 19:46
ReporterPhyllisSmith Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2019-08 
Target VersionFixed in Version 
Summary0000307: Mint 19 repository problem
Description

This is a spin-off from issue 293 (I decided to log a new BT so that the original author, whose problem has been fixed, does not get email that would be irrelevant to him).

Quote from MatN: Your comment: "These messages indicate that "trusted=yes" is probably just missing on the one machine. " I don know how to verify. On the failing machine, the /etc/apt/sources.list.d has 3 files in it:
-rw-r--r-- 1 root root 528 Aug 19 22:14 official-package-repositories.list
-rw-r--r-- 1 root root 158 Aug 19 22:38 thierry-f-fork-michael-gruz-bionic.list
-rw-r--r-- 1 root root 62 Sep 23 20:35 additional-repositories.list
...
The "additional repositories" has only cin-gg in it, but looks the same format as the above:
deb https://cinelerra-gg.org/download/pkgs/mint19 bionic main

This was added using "sudo apt-add-repository 'deb https://cinelerra-gg.org/download/pkgs/mint19 bionic main' ". If I included the [trusted=yes] is complains about invalid parameters. Yet doing a "sudo apt update" after this gives the previously reported error. When I use the line including the "[trusted=yes]" in the GUI to add repositories, it says "malformed input" .

TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-10-14 19:46

manager   ~0002281

I agree, it does not make any sense.

MatN

MatN

2019-10-14 18:27

reporter   ~0002278

Yep, manually adding [trusted=yes] fixed the update problem. Thanks.

When I started today this test on the machine, there was no file "additional-repositories.list" in /etc/apt/sources.list.d . Trying to add the repository via the GUI UpdateManager did not work, an error. Manually doing "sudo add-apt-repository deb [trusted=yes] https://cinelerra-gg.org/download/pkgs/mint19 bionic main " gave no error but did not create the file. /var/log/apt did not show any related errors either. When I dropped the [trusted=yes] the file appeared. Then I edited the file to included [trusted=yes] and then the "apt update" when OK without error.

I don't know why it doesn't work on the system using the UpdateManager's GUI, it worked on all other systems I tried . So for me this can be clised, unless someone alse can reproduce the UpdateManager problem.

PhyllisSmith

PhyllisSmith

2019-10-07 16:46

manager   ~0002224

Mat was unable to update here so I am passing along with his information.
"the 2019-09 release installed on all my systems with no problems. The system where it failed on I will be able to visit this Wednesday 9 October evening; I expect with your instructions it to be fixed."

Will close later.

PhyllisSmith

PhyllisSmith

2019-10-06 18:07

manager   ~0002213

Waiting to hear from MatN to make sure with the notes, that he has had a chance to resolve this.

PhyllisSmith

PhyllisSmith

2019-10-01 01:03

manager   ~0002195

@MatN
GG tested the Mint 19 package install procedure with the new builds of 09-30-2019. He was able to get the same error messages that you quoted when [trusted=yes] was missing. After he corrected the additional-repositories.list file, the install went fine and he brought up Cinelerra and successfully did a load and a render.

Hopefully, this will work for you also.

PhyllisSmith

PhyllisSmith

2019-09-27 20:11

manager   ~0002187

@MatN
I was not clear in my instructions. The message of invalid parameter for "sudo apt-add-repository ..." is correct.

You have to manually edit the file:
/etc/apt/sources.list.d/additional-repositories.list
to change the line that you stated looks like the following:
deb https://cinelerra-gg.org/download/pkgs/mint19 bionic main
to instead look like:
deb [trusted=yes] https://cinelerra-gg.org/download/pkgs/mint19 bionic main

In testing on Mint 19 this morning here, I verified that CinGG needs libva.so.2. This version of libva was installed on our Mint 19 computer and this is Mint 19 WITH updates rather than 19.1 or 19.2.

I hope when you have a chance to test again, this clears everything up. But if not, just let us know.

Issue History

Date Modified Username Field Change
2019-09-27 19:58 PhyllisSmith New Issue
2019-09-27 19:58 PhyllisSmith Status new => assigned
2019-09-27 19:58 PhyllisSmith Assigned To => PhyllisSmith
2019-09-27 20:00 PhyllisSmith Description Updated View Revisions
2019-09-27 20:11 PhyllisSmith Note Added: 0002187
2019-10-01 01:03 PhyllisSmith Note Added: 0002195
2019-10-06 18:07 PhyllisSmith Status assigned => feedback
2019-10-06 18:07 PhyllisSmith Note Added: 0002213
2019-10-07 16:46 PhyllisSmith Note Added: 0002224
2019-10-14 18:27 MatN Note Added: 0002278
2019-10-14 19:46 PhyllisSmith Status feedback => closed
2019-10-14 19:46 PhyllisSmith Resolution open => no change required
2019-10-14 19:46 PhyllisSmith Note Added: 0002281