View Issue Details

IDProjectCategoryView StatusLast Update
0000335Cinelerra-GG[All Projects] Bugpublic2019-11-04 23:21
ReporterAndrew-R Assigned Togoodguy  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSSlackwareOS Version
Product Version2019-09 
Target VersionFixed in Version2019-11 
Summary0000335: Moving another effect above/below 'histogram normalization' crashes Cin
DescriptionTry to play project and at the same time manipulate order of effects on video stack around 'histogram normalization' plugin, with histogram drawing enabled, and other controls for other plugins also visible.
Steps To Reproduce1. open any video file supported by CinGG (preferably with just one video and one audio stream)
2. Add to whole track 'histogram normalization' plugin
3. Add on top of this second effect, say 'brightness/contrast'
4. Set playback cursor to very beginning of project
5 Hit play.

while project playing
6. Open controls for both plugin effects.
7. Enable drawing of realtime histogram in histogram effect control window
8. try to change order of effects while project still palying via effect's context menu -> up/down entries.

After some (second?) attempts at effect stack manipulation Cin will crash

OS - 32-bit Slackware.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-11-04 23:21

manager   ~0002393

Thanks for finding! in the first place and for testing.
Andrew-R

Andrew-R

2019-11-04 22:19

reporter   ~0002392

I think at least black histogram window on first show AND crash from this bug are fixed as of

commit 53f919f88484c8611457fbcd552f6931218cc219 (HEAD -> master, origin/master, origin/HEAD)
Author: Good Guy <[email protected]>
Date: Mon Nov 4 14:38:40 2019 -0700

    plugin gui ref by id fixes, plugin gui opengl update fixes, prores opts files

Thanks!
PhyllisSmith

PhyllisSmith

2019-11-03 16:53

manager   ~0002385

Andrew, thanks for testing and feedback. There are 3 problems still that have been discovered - the 1) you just found, 2) an opengl problem in gamma, deinterlace, threshold, and histogram that returns before executing a set of code, and 3) splitting a video when there is an effect on the whole track. GG is working on it now but it is not going all that well yet.
Andrew-R

Andrew-R

2019-11-03 14:33

reporter   ~0002384

with git commit 83cdf330ba14342487a08d72e25ef29736d41100 it doesn't crash anymore, but then you must move histogram equalization effect up or down for making histogram visible :} (sometimes changing project's format also helps)
PhyllisSmith

PhyllisSmith

2019-11-02 16:38

manager   ~0002374

Just an update of information as GG has been working on this crash. Great find by Andrew after all of these years! It turns out that if you have a compiled/running version of Cinelera-HV (Heroine Virtual) this bug has been there from way back - very likely forever. You will get the same type of crash with Brightness/Contrast and Gamma plugins. Analysis - basically what is happening is that playing is going on, the 2 plugins are moved but the EDL still has the 1 plugin in the same place and an update of the plugin is updating the wrong one.

The fix is going to take awhile as it is quite involved but today gg is working on Plan B and will resort to Plan A if that does not work. I can only speculate that the reason this crash laid dormant for so many years is that either most users stop before moving plugins or do not have both control menus up or do not have a specific type of plugin (like histeq or gamma), or did not know for sure what it took to create the crash. Andrew "nailed it exactly" right so we could finally reproduce it here.
PhyllisSmith

PhyllisSmith

2019-11-01 22:50

manager   ~0002370

Finally, we got the crash! We were using the Histogram plugin instead of HistEq. Once I saw the attached xml, I realized what we were doing wrong and yes, now BAM, it crashes. GG is looking at it right now.
Andrew-R

Andrew-R

2019-11-01 15:17

reporter   ~0002369

backup.xml from .bcast5 directory

backup.xml (5,572 bytes)
Andrew-R

Andrew-R

2019-11-01 15:16

reporter   ~0002368

dump as recorded from root account, after moving .bcast5 directory, so clean profile was created.

cinelerra_638.dmp (140,626 bytes)

Issue History

Date Modified Username Field Change
2019-11-01 15:14 Andrew-R New Issue
2019-11-01 15:16 Andrew-R File Added: cinelerra_638.dmp
2019-11-01 15:16 Andrew-R Note Added: 0002368
2019-11-01 15:17 Andrew-R File Added: backup.xml
2019-11-01 15:17 Andrew-R Note Added: 0002369
2019-11-01 22:46 PhyllisSmith Assigned To => goodguy
2019-11-01 22:46 PhyllisSmith Status new => assigned
2019-11-01 22:50 PhyllisSmith Status assigned => confirmed
2019-11-01 22:50 PhyllisSmith Note Added: 0002370
2019-11-02 16:38 PhyllisSmith Note Added: 0002374
2019-11-03 14:33 Andrew-R Note Added: 0002384
2019-11-03 16:53 PhyllisSmith Note Added: 0002385
2019-11-04 22:19 Andrew-R Note Added: 0002392
2019-11-04 23:21 PhyllisSmith Status confirmed => resolved
2019-11-04 23:21 PhyllisSmith Resolution open => fixed
2019-11-04 23:21 PhyllisSmith Fixed in Version => 2019-11
2019-11-04 23:21 PhyllisSmith Note Added: 0002393