View Issue Details

IDProjectCategoryView StatusLast Update
0000336Cinelerra-GG[All Projects] Featurepublic2019-11-10 23:00
ReporterOlaf Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-11 
Summary0000336: Supplementary request for the video profiles for ProRes.
DescriptionSave as: prores-proxy.prores
matroska prores
# ProRes: For fast creation of proxies. Container Matroska (.mkv).
profile=0

Move and add: ks.pro -> prores_ks.prores
mov prores_ks
# ProRes, encoder prores_ks. Container Apple QuickTime movie (.mov).
# The encoder delivers a higher quality but is very slow in comparison.
profile=4444
# The possible video profile values for the ProRes codec are:
# 5 = 4444xq
# 4 = 4444
# 3 = HQ (high quality)
# 2 = Standard
# 1 = LT (light)
# 0 = Proxy

Move and add: med422p10.pro -> prores.prores
mov prores
# ProRes, encoder prores_aw. Container Apple QuickTime movie (.mov).
profile=2
# The possible video profile values for the ProRes codec are:
# 5 = 4444xq
# 4 = 4444
# 3 = HQ (high quality)
# 2 = Standard
# 1 = LT (light)
# 0 = Proxy
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-11-10 23:00

manager   ~0002454

The 3 ProRes opts files have been added and no more improvements have been suggested. Can open a new request if something comes up with needed variations.
PhyllisSmith

PhyllisSmith

2019-11-04 23:25

manager   ~0002394

After reading the notes again, I think there is no perfect answer but the 3 pro opts were checked into GIT as improved over the previous state of things. I also added an audio of pcm_s24.pro (but the audio still has to be unchecked for prores_proxy.pro).
Andrew-R

Andrew-R

2019-11-04 09:48

reporter   ~0002387

..I left most of my copy/pasta post untranslated because I think most of numbers in it actually self-explainable, for anyone who even minimally stepped into this wonderfully messy world of computer video :} I think you can guess most of those parameters correctly even if page was in undisplayable characters from China or Japan .....
Olaf

Olaf

2019-11-04 09:18

reporter   ~0002386

In addition to the file format MXF for ProRes, I reject it for myself. The effort is too high and the results are unsatisfactory.

MXF has considerable disadvantages: There is no consistent standard, every manufacturer has its own soup. Audio is stored as mono tracks, without the arrangement being regulated in any way. With FFMpeg you never know which codecs are supported, while CGG can write ProRes in MXF the same call on the command line with the FFMpeg of the system does not work. Whether CGG (or another free editing system) considers the timecodes and other extras of MXF is not yet clear. However, it is clear that MXF created with CGG cannot be played with other media players (MPV, VLC), a fast control is therefore not possible.

I am not in the situation to have to produce professionally, whereas professional means for me to earn a living with this activity. Who has the requirement to be a "Pro" can pursue this gladly further.

The file formats (container) MOV and Matroska are well supported by the OSS community and fulfill their purpose in my opinion.

--
@Andrew-R https://www.deepl.com/translator
Andrew-R

Andrew-R

2019-11-03 13:55

reporter   ~0002383

Quick google search showed those requirements for one of Russian channels:

http://www.tv-stream.ru/operators#techspecs


ТЕХНИЧЕСКИЕ УСЛОВИЯ
Видео для размещения в эфире
Телеканалы «Детский», «Еврокино», «Русский Иллюзион», «Иллюзион+», «Zоопарк», «Охота и рыбалка», «Усадьба», «Домашние животные», «Драйв», «АВТО24» и «Точка отрыва» вещают в формате PAL 16:9. Все видеоматериалы, предназначенные для размещения в эфире данных телеканалв, должны соответствовать следующим требованиям:
Контейнер: MOV, MXF, MP4
Кодек: XDCAM HD50, XDCAM EX35, Prores422 или H.264 (битрейт не ниже 20Мбит)
Разрешение: 1920x1080
Соотношение сторон: 16:9
Частота кадров: 25

Телеканалы «Психология21», «Вопросы и ответы», «Ретро» и «Здоровое ТВ» вещают в формате PAL 4:3. Все видеоматериалы, предназначенные для размещения в эфире данных телеканалов, должны соответствовать следующим требованиям:

Контейнер: AVI, DV, MOV, MP4
Кодек: DV-PAL, MPEG-2 (битрейт не ниже 15Мбит), H.264 (битрейт не ниже 6Мбит)
Разрешение: 720x576
Соотношение сторон: 4:3
Частота кадров: 25


so, HD can be in MOV or MP4, with suitable high-bitrate codecs .....
SD can be even in AVI :}

I'll try to ask one of my friends who might have some details

also, apparently ffmpeg has support for prores muxing in MXF since last year?

https://trac.ffmpeg.org/ticket/7383
http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=5e0d54a031e313abda0204bb95d88deaebba97a0
Olaf

Olaf

2019-11-03 10:46

reporter   ~0002382

Errata: "ProRes, 4:2:2, I-Frame, around 184 Mbit/s (ProRes HQ) with 10 Bit and around 122 Mbit/s (ProRes) with 10 Bit (Final Cut Pro implementation)"
Olaf

Olaf

2019-11-03 10:44

reporter   ~0002381

Before the profiles are used, we should think again about the file formats.

According to the technical guidelines of the German public broadcasting company, for example, the delivery and provision is fixed to the MXF file format. Whereby the time code should be embedded in the file format MXF according to EBU R122.[fn:1]

As a compression format ProRes is named: "ProRes, 4:2:2, I-Frame, 0000056:0000184 Mbit/s (ProRes HQ) with 10 Bit and 0000032:0000122 Mbit/s (ProRes) with 10 Bit (Final Cut Pro implementation)" (Bitrate related to 1080i/25). However, there is no SMPTE mapping standard for ProRes in MXF.[fn:1]

Audio data can be assumed to be PCM, 48kHz, 24-bit.[fn:2]

Now, however, German broadcasting does not set any international standards and an internationally compatible solution has to be found. Someone who is familiar with this should speak here.

--
[fn:1] Technische Richtlinien - HDTV zur Herstellung von Fernsehproduktionen für ARD, ZDF und ORF, Oktober 2011. (Engl.: Technical guidelines - HDTV for the production of television productions for ARD, ZDF and ORF, October 2011. (updates are not free of charge)

[fn:2] Allgemeine technische Richtlinien ARTE G.E.I.E., Oktober 2018. (Engl.: General technical guidelines ARTE G.E.I.E., October 2018)
Andrew-R

Andrew-R

2019-11-02 21:45

reporter   ~0002378

yeah, I just was fooled by formatting...

I tried mpv (on some live cd, I think), but for some reason was not very impressed... may be I'll install it as second player.

If those profiles will be committed into main git repo - I agree with your naming. I just tested them quickly (on 1 min clip).

** rendered 1637 frames in 27.100 secs, 60.406 fps
** rendered 1637 frames in 108.531 secs, 15.083 fps
** rendered 1637 frames in 31.944 secs, 51.246 fps

for machine set to 1.4Ghz/4 cores, and 720x400 video track (film)

So yeah, Kostya's (from https://codecs.multimedia.cx/ - if I understand this scene correctly :} ) encoder actually quite slow. But works, as far as my eyes saying to me ....
PhyllisSmith

PhyllisSmith

2019-11-02 21:38

manager   ~0002377

Last edited: 2019-11-02 21:39

View 2 revisions

I also tested these 3. I would like to name them as follows if there are no objections:

prores.pro
prores_ks.pro
prores_proxy.pro

The reason for the extension of "pro" instead of "prores" is to avoid the ghosted out Audio render. However if this change is objectionable, I will just add to the audio directory, an acc256k.prores.

I will also then delete med422p10.pro and ks.pro since they are duplicates of the first 2. If I do not hear back, I will assume this is OK.

Olaf

Olaf

2019-11-02 21:05

reporter   ~0002376

(And if you wonder why the extension is "prores" and not "mov" or "mkv" - I differentiate between codecs for the final export into a consumer format and intermediate formats.)
Olaf

Olaf

2019-11-02 20:53

reporter   ~0002375

Hi Andrew-R, I suppose your question (profile=0) was answered by itself when creating the profile files?

Although the profile for proxy contains the container Matroska, I would like to argue with the file name from the user's point of view. The name "prores-proxy.prores" matches the other two profiles and they should be self-explanatory. Matroska is not a codec but a container, in the form you choose, it doesn't seem self-explanatory to me.

Maybe I can get you thrilled by MPV as a media player? MPV actually plays everything FFMpeg makes and supports. https://mpv.io/ (MPV also supports icc-profile)
Andrew-R

Andrew-R

2019-11-02 14:40

reporter   ~0002373

Now should be attached, I tested all three of them.

Thanks, Olaf!

(for mplayer's playback you may need to add 422P12 as out format in codecs.conf for "videocodec ffprores" section)

propres_ks.prores (322 bytes)
prores.prores (244 bytes)
matroska_proxy.prores (92 bytes)
Andrew-R

Andrew-R

2019-11-02 14:22

reporter   ~0002372

I think you can just attach files here ....

But isn't profile=0 actually more useful in proxies, or this profile simply not implemented yet in ffmpeg?
Olaf

Olaf

2019-11-02 11:02

reporter   ~0002371

For clarification, the text formatting was done by the software. The text itself was changed by the formartierung and cannot be used.

Issue History

Date Modified Username Field Change
2019-11-02 10:35 Olaf New Issue
2019-11-02 11:02 Olaf Note Added: 0002371
2019-11-02 14:22 Andrew-R Note Added: 0002372
2019-11-02 14:40 Andrew-R File Added: matroska_proxy.prores
2019-11-02 14:40 Andrew-R File Added: propres_ks.prores
2019-11-02 14:40 Andrew-R File Added: prores.prores
2019-11-02 14:40 Andrew-R Note Added: 0002373
2019-11-02 20:53 Olaf Note Added: 0002375
2019-11-02 21:05 Olaf Note Added: 0002376
2019-11-02 21:38 PhyllisSmith Note Added: 0002377
2019-11-02 21:38 PhyllisSmith Assigned To => PhyllisSmith
2019-11-02 21:38 PhyllisSmith Status new => feedback
2019-11-02 21:39 PhyllisSmith Note Edited: 0002377 View Revisions
2019-11-02 21:45 Andrew-R Note Added: 0002378
2019-11-03 10:44 Olaf Note Added: 0002381
2019-11-03 10:44 Olaf Status feedback => assigned
2019-11-03 10:46 Olaf Note Added: 0002382
2019-11-03 13:55 Andrew-R Note Added: 0002383
2019-11-04 09:18 Olaf Note Added: 0002386
2019-11-04 09:48 Andrew-R Note Added: 0002387
2019-11-04 23:25 PhyllisSmith Status assigned => acknowledged
2019-11-04 23:25 PhyllisSmith Note Added: 0002394
2019-11-10 23:00 PhyllisSmith Status acknowledged => resolved
2019-11-10 23:00 PhyllisSmith Resolution open => fixed
2019-11-10 23:00 PhyllisSmith Fixed in Version => 2019-11
2019-11-10 23:00 PhyllisSmith Note Added: 0002454