View Issue Details

IDProjectCategoryView StatusLast Update
0000346Cinelerra-GG[All Projects] Bugpublic2019-12-09 19:35
ReporterPierre Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionreopened 
Platformi7-3770k, 32GB(ram), GTX-750TiOSLinux Mint MateOS Version18.3
Product Version 
Target VersionFixed in Version 
Summary0000346: The image disappears when a project including a trancoded source is reopened.
DescriptionThe transcode test project I did with the problematic source provided by Andrew https://yadi.sk/i/ivzmAc2UGq-Wwg works well when creating the project, but:

If I order the transcoded version of the file, without removing the original of the project, but only use the transcoded version.

I place the transcoded version in the Viewer, it is easy to view. I drag the source directly onto the timeline, it behaves well there and I can view all the parts I want in the composer.

If you save this test project and then re-open it, only the first frame is visible in the viewer and the composer, most of the timeline images are no longer displayed, only the sound still plays normally.

If I put the transcoded version back into the viewer, it now displays correctly and the composer plays again the selection I make in the timeline, but the missing images are still missing from the timeline.

If I delete the contents of the timeline and re-drag the transcoded source, everything comes back in order. But even if I save these changes to the project, the next time I reopen... the same problems are back.
TagsNo tags attached.

Activities

Pierre

Pierre

2019-12-09 19:35

updater   ~0002558

vdpau is the culprit!

After removing.bcast5 folder, I only added the:

layout1_...rc
layout2_...rc
layout3_...rc
layout4_...rc

To the new.bcast5 folder created, otherwise basic

At that time the problem of missing images from the transcode test with Andrew's problematic file https://yadi.sk/i/ivzmAc2UGq-Wwg was gone.

I then undertook to change the preferences one by one, checking each time after a CinGG restart that the problem described regarding Andrew's file did not return.

I first chose the X11-OpenGL video driver, then I increased the cache size to 1024.

I restarted CinGG and there was still no problem with Andrew's file.

Then I chose the HW Device vdpau.

Then I relaunched CinGG....

 The same problems with Andrew's file are back....

But, if I remove vdpau, the problem disappears.

vdpau is the culprit!
PhyllisSmith

PhyllisSmith

2019-12-08 03:52

manager   ~0002555

palette.dat is for choosing colors like in the Title plugin for your characters and outline colors. It is not that important but if you had a certain color of red you like to use, it will still be in the color wheel choice in the lower left hand corner.

I am surprised that Cinelerra_rc had to be deleted also and do not have a clue as to why that would cause a problem.
Pierre

Pierre

2019-12-08 01:30

updater   ~0002554

Thank you Phyllis for the information on the strings to keep.

I did it but I couldn't keep "Cinelerra_rc"; if I keep it, the problem described remains.

If I only keep it:
pallet.dat
layout1_...rc
layout2_...rc
layout3_...rc
layout4_...rc

I have to readjust CinGG, but the problem described is fixed and I get my Layouts back which is very appreciated.

Question: What is "palette.dat" used for?
PhyllisSmith

PhyllisSmith

2019-12-07 18:15

manager   ~0002552

@Pierre, thanks for testing in the first place and for the final followup.
Maybe before making the drastic step of throwing away the .bcast5 folder, you could delete all of the files there, EXCEPT:

Cinelerra_rc
palette.dat
layout1_...rc
layout2_...rc
layout3_...rc
layout4_...rc
That way you would not lose so much of your configuration. If that does not solve the problem then you can still delete those too. However, this does not mean that there is still not some kind of bug in the first place -- some file must have been corrupt.

I will close this issue in a day or 2 in case anyone wants to add anything.
Pierre

Pierre

2019-12-07 15:35

updater   ~0002551

Problem solved.

I did what I don't like to do (because I then have to reconfigure CinGG to my liking in the preferences), I threw away the".bcast5" folder.

Then the problem of missing images from the transcode test with Andrew's problematic file https://yadi.sk/i/ivzmAc2UGq-Wwg is gone, everything works fine now.
PhyllisSmith

PhyllisSmith

2019-12-06 00:37

manager   ~0002549

Last edited: 2019-12-06 00:43

View 2 revisions

@Olaf -- "I don't see anything problematic about Andrew's video, it's an ordinary DV/PCM in an AVI container."
If you play from the beginning it works fine as is. If you move the cursor to further down and try to play, the audio no longer plays correctly. I think this is described in BT 0000330. A patch was created for these types of files for Andrew to use if he wanted to BUT this patch is not going to be checked into GIT because the philosophy is that it is better to fix files that have problems rather than have Cinelerra compensate for every thing that can go wrong!

Olaf

Olaf

2019-12-05 10:40

reporter   ~0002544

I don't see anything problematic about Andrew's video, it's an ordinary DV/PCM in an AVI container. The transcoding went smoothly and even after repeated opening I can't see any misbehaviour. And even if it's exotic material, the transcoding is meant to turn problematic raw material into editable material. This should not be confused with the use of proxies. Lossless or optically lossless codecs are usually used for this purpose. What do you use?

By the way, the attached MediaInfo excerpts show that the scan type is written from Interlaced to Progressive, although the project was set to Interlaced before transcoding and the material is not DeInterlaced after transcoding. Any tips?

LD_160909_2.avi.mi.txt (2,522 bytes)
General
Complete name                            : LD_160909_2.avi
Format                                   : AVI
Format/Info                              : Audio Video Interleave
Commercial name                          : DVCPRO
Format profile                           : OpenDML
File size                                : 2.29 GiB
Duration                                 : 11 min 21 s
Overall bit rate mode                    : Constant
Overall bit rate                         : 28.9 Mb/s
Recorded date                            : 2009-09-15 14:23:13.000

Video
ID                                       : 0
Format                                   : DV
Commercial name                          : DVCPRO
Duration                                 : 11 min 21 s
Bit rate mode                            : Constant
Bit rate                                 : 24.4 Mb/s
Encoded bit rate                         : 28.8 Mb/s
Width                                    : 720 pixels
Height                                   : 576 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Standard                                 : PAL
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Interlaced
Scan order                               : Bottom Field First
Compression mode                         : Lossy
Bits/(Pixel*Frame)                       : 2.357
Time code of first frame                 : 00:00:07:24
Time code source                         : Subcode time code
Stream size                              : 2.28 GiB (100%)
Encoding settings                        : ae mode=manual / wb mode=automatic / white balance= / fcm=manual focus

Audio
ID                                       : 0-0
Format                                   : PCM
Muxing mode                              : DV
Muxing mode, more info                   : Muxed in Video #1
Duration                                 : 11 min 21 s
Bit rate mode                            : Constant
Bit rate                                 : 1 536 kb/s
Encoded bit rate                         : 0 b/s
Channel(s)                               : 2 channels
Sampling rate                            : 48.0 kHz
Bit depth                                : 16 bits
Stream size                              : 125 MiB (5%)
Encoded stream size                      : 0.00 Byte (0%)


LD_160909_2.avi.mi.txt (2,522 bytes)
LD_160909_2.convert-avi.pro.mi.txt (2,451 bytes)
General
Complete name                            : LD_160909_2.convert-avi.pro
Format                                   : MPEG-4
Format profile                           : QuickTime
Codec ID                                 : qt   0000.02 (qt  )
File size                                : 2.77 GiB
Duration                                 : 11 min 21 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 34.9 Mb/s
Writing application                      : Lavf58.29.100
FileExtension_Invalid                    : mov mp4 m4v m4a m4b m4p m4r 3ga 3gpa 3gpp 3gp 3gpp2 3g2 k3g jpm jpx mqv ismv isma ismt f4a f4b f4v

Video
ID                                       : 1
Format                                   : ProRes
Format version                           : Version 0
Format profile                           : 422
Codec ID                                 : apcn
Duration                                 : 11 min 21 s
Bit rate mode                            : Variable
Bit rate                                 : 32.6 Mb/s
Width                                    : 720 pixels
Height                                   : 576 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Standard                                 : PAL
Color space                              : YUV
Chroma subsampling                       : 4:2:2
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 3.148
Stream size                              : 2.59 GiB (93%)
Writing library                          : fmpg

Audio
ID                                       : 2
Format                                   : PCM
Format settings                          : Little / Signed
Codec ID                                 : in24
Duration                                 : 11 min 21 s
Bit rate mode                            : Constant
Bit rate                                 : 2 304 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Bit depth                                : 24 bits
Stream size                              : 187 MiB (7%)
Language                                 : German
Default                                  : Yes
Alternate group                          : 1


PhyllisSmith

PhyllisSmith

2019-12-05 05:11

manager   ~0002542

@Pierre - I still am not able to create the problem that you see. The reason the source file has a default tag of "convert" is because when the menu comes up, the Tag suffix box has ".convert" in it from before the change to transcode was made. That Tag suffix was saved in your preferences when you tested the original version. So you have to manually change the Tag suffix testbox to get it changed from now on to .transcode or whatever you want instead. We wanted to make the Tag suffix settable by the user in case there was a name conflict or language issue.
Pierre

Pierre

2019-12-04 22:47

updater   ~0002541

Yes, if I use files of my own that do not have any problems running in CinGG, the problem of maintaining images when reopening is not present; everything is normal.

The problem described (loss of image on reopening) only seems to occur with Andrew's problematic file https://yadi.sk/i/ivzmAc2UGq-Wwg. Isn't this the very reason Transcode exists, to facilitate the use of such problematic sources?

Another thing I noticed now that I have In the preferences deleted all existing indexes and thumbnails, every time previous projects open, it re-indexes the sources... each time. This, even though I increased the size of the index files to 163840 KB (about 10x bigger) instead of 16384 KB.
IgorBeg

IgorBeg

2019-12-04 17:30

reporter   ~0002532

I have tried too but with my “.mov” videos source and transcoded in XviD on UbuntuStudio16.04, and like Phyllis and Olaf, it works.

May be that it depends from the type of the transcode format?
Are you (Pierre) tested with your own files, before?
Pierre

Pierre

2019-12-04 14:19

updater   ~0002530

The same problem occurs if I reconstruct index (by lmb) from the convert source

I also rebuilt the test from the beginning from the file by Andrew https://yadi.sk/i/ivzmAc2UGq-Wwg

I checked in the preferences menu that the size of the index files is 16384 KB

In the preferences I deleted all existing indexes and thumbnails.

Same problems....

I noticed that even if the function is now called "transcode", the source file created always has by default a Tag".convert" instead of .transcoded, is that correct?
Olaf

Olaf

2019-12-04 10:04

reporter   ~0002529

I have tried to recreate this with my own footage (mp4/mts to ffvhuff/mkv), unfortunately unsuccessfully. In this relationship everything behaves as it should. Will the index possibly be lost? Maybe increasing the size of the index files will help? I use 16384 KB on an own SSD. But I can't say from a distance if this is the reason.
PhyllisSmith

PhyllisSmith

2019-12-03 18:13

manager   ~0002523

I have not been able to reproduce when I transcoded to ffmpeg / mp4 following your steps. Most likely the problem is that a "rebuild index" may be required. Try lmb (left mouse click) in the Resources window / Media folder on the LD...transcode... file and select the 4th option of "Rebuild index". Then save project with the transcoded file and try to re-open and check to see if you still have the same problem. Rebuild index often solves problems.

Meanwhile I will continue to try to reproduce the error and see what can be done.

Issue History

Date Modified Username Field Change
2019-12-02 16:57 Pierre New Issue
2019-12-03 18:13 PhyllisSmith Assigned To => PhyllisSmith
2019-12-03 18:13 PhyllisSmith Status new => acknowledged
2019-12-03 18:13 PhyllisSmith Note Added: 0002523
2019-12-04 10:04 Olaf Note Added: 0002529
2019-12-04 14:19 Pierre Note Added: 0002530
2019-12-04 17:30 IgorBeg Note Added: 0002532
2019-12-04 22:47 Pierre Note Added: 0002541
2019-12-05 05:11 PhyllisSmith Note Added: 0002542
2019-12-05 10:40 Olaf File Added: LD_160909_2.avi.mi.txt
2019-12-05 10:40 Olaf File Added: LD_160909_2.convert-avi.pro.mi.txt
2019-12-05 10:40 Olaf Note Added: 0002544
2019-12-06 00:37 PhyllisSmith Note Added: 0002549
2019-12-06 00:43 PhyllisSmith Note Edited: 0002549 View Revisions
2019-12-07 15:35 Pierre Note Added: 0002551
2019-12-07 18:15 PhyllisSmith Note Added: 0002552
2019-12-08 01:30 Pierre Note Added: 0002554
2019-12-08 03:52 PhyllisSmith Note Added: 0002555
2019-12-09 00:32 PhyllisSmith Status acknowledged => closed
2019-12-09 00:32 PhyllisSmith Resolution open => fixed
2019-12-09 19:35 Pierre Status closed => feedback
2019-12-09 19:35 Pierre Resolution fixed => reopened
2019-12-09 19:35 Pierre Note Added: 0002558