View Issue Details

IDProjectCategoryView StatusLast Update
0000357Cinelerra-GG[All Projects] Websitepublic2020-02-03 18:41
ReporterMatN Assigned ToSam  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformX86_64OSMintOS Version19.1
Product Version2019-11 
Target VersionFixed in Version 
Summary0000357: URL "cinelerra-gg.org " gets redirected to "cinelerra-gg.com" resulting in a timeout. Using https:// in front works OK.
DescriptionSee summary.
It is weird, I stumbled across it by accident. The Cinelerra-gg en.wikipedia.org entry had this form, and would not work. I have corrected wikipedia to use the full https:// ... URL.
Steps To ReproduceIn Firefox, enter "cinelerra-gg.org" in the address field, hit enter. At the bottom you'll see it redirected to cinelerra-gg.com, which eventually times out.
Ping shows the same redirection (see "additional information" below) .
Additional InformationUsing ping from a linux terminal window shows the same redirection:

OK: PING cinelerra-gg.org (104.27.142.18) 56(84) bytes of data
OK: PING www.cinelerra-gg.org (104.27.143.18) 56(84) bytes of data.
NOK: ping: cinelerra-gg.com: Name or service not known
OK: PING www.cinelerra-gg.com (192.64.119.254) 56(84) bytes of data.

https://cinelerra-gg.org works fine.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2020-02-03 18:41

manager   ~0002780

All seems to be working quite well to include the cv mailing list.
PhyllisSmith

PhyllisSmith

2020-01-06 17:38

manager   ~0002640

Timing feedback today. On my laptop, all is good -- sometimes gg has different results and I will check there later. I did not use a stop watch but here is what I see today after clearing my cache each time and running 2 tests:

speed to website - 11s and 8 s
speed to forum - 9s and 8s
speed to bug tracker - 4s and 3s
speed to mailing list - 1s and 1s
MatN

MatN

2020-01-06 14:12

reporter   ~0002637

It works fine now. Also the CV mailing list link at the Cinelerra en.wikipedia.org page works again.
Thanks.
Sam

Sam

2020-01-06 00:57

administrator   ~0002636

I got the data from Christian Thaeter and entered it into the Domain Name Server. The redirections and the old CV mailing list are working fine again. If you have any problems please let me know. I will close the ticket in a few days.
Sam

Sam

2020-01-04 08:08

administrator   ~0002635

The cinelerra-cv.org SSL certificates are up-to-date and the forwarding has been entered correctly. The only thing missing is the IP address of Christian Thaeter Server, where the mailing list is running. I have written to him and will link everything correctly as soon as I have his data.
PhyllisSmith

PhyllisSmith

2020-01-03 20:29

manager   ~0002634

@Sam: "I still have a problem with the Cinelerra-CV , the certificates have expired."
Just noted the following as MatN asked about the cv archived mailing list. At:
   https://www.cinelerra-gg.org/search-mail-archives/
there is a link to the old cv pipermail. It is still quite useful so hopefully that link can be changed?
Sam

Sam

2020-01-02 11:46

administrator   ~0002630

I will still do some work on the server, so it is quite possible that there may be temporary interference.
PhyllisSmith

PhyllisSmith

2020-01-02 04:43

manager   ~0002627

Sam, thank you. Bill says today it is 10 times faster.
Sam

Sam

2019-12-31 12:45

administrator   ~0002616

Thanks for the great error reporting. It is a great help for me, because I cannot test everything in detail due to lack of time.

Yesterday I corrected some errors on the Apache web server. The problem is that the Certbot of LetsEncrypt caused errors when updating the SSL certificates. The Certbot has set up the redirections wrong. Some redirects are set up correctly and some not. I could fix the errors.
The redirection from cinelerra-gg.com to the cinelerra-gg.org was not correctly set up in the DNS, the wildcard only worked for www.cinelerra-gg.com. No idea why. I added the entry manually, but it may take some time until all DNS have the update again.
I still have a problem with the Cinelerra-CV , the certificates have expired. I will be able to fix this problem in two days.

Thanks again to you all.
MatN

MatN

2019-12-31 11:44

reporter   ~0002615

The attempt to convert cinelerra-gg.org to cinelerra-gg.com is now gone, must have been a dns issue too. Tested with 4 different OSs.
The (to me then) unknown lines in /etc/resolve.conf are OK, and are not present in Mint 18.3 or Mint 17.3 .
I noticed that a ping to "cinelerra-gg.com" returns "unknown host", while "www. cinelerra-gg.com" is OK. Is this on purpose?
Andrea_Paz

Andrea_Paz

2019-12-31 09:18

updater   ~0002614

For me the results are:
  
  BT --> 5s
  Mailing List --> 1s
  website --> 3s
  Forum --> 5s (until yesterday it was no less than 10s; in the morning - in Italy - it seemed more reactive than in the evening).
MatN

MatN

2019-12-31 09:03

reporter   ~0002613

Thanks Sam, the redirection issue is solved for me. I thought it had something to do with the name resolving, I use mostly 9.9.9.9 as DNS .
What I still don't understand, is that when I typed "cinelerra-gg.org" in Firefox (version 71.0), it got to try "cinelera-gg.com" . It still does it (hitting enter after typing the address while looking at the bottom you can see it flashing by). The ping showed that "cinelerra-gg.org" resolved all by itself, so there should have been no need to try the .com . It must be a local issue, IT here is somewhat complicated (for a home system).
There is nothing suspicious in my /etc/hosts file, but I see strange entries in /etc/resolve.conf.
nameserver 127.0.0.53
options edns0

The nameserver IP is unknown to me, but it does answer pings. I'll have to debug that.
Anyway, the redirection issue is solved, and the website is much faster than yesterday.
Thanks.
Sam

Sam

2019-12-31 00:06

administrator   ~0002612

I think I found the error source. It seems to be another WordPress plugin that should make the website faster, but does the opposite. With a new update of this plugin the website became slower. Let's see if I can fix this bug.
Sam

Sam

2019-12-30 23:46

administrator   ~0002611

@PhyllisSmith The problem is that unfortunately I cannot detect any difference in speed. Apparently I'm too close to the server. If the website is very slow, can you please test if there is a difference to the bug tracker and mailman mailing list? These two subpages are routed differently, so I would be interested in the speed of these pages, because that way I can better isolate the source of the error.
Sam

Sam

2019-12-30 23:36

administrator   ~0002610

Thanks for the hint. Based on the information you gave me, I was able to correct the error. For me the forwarding from .com to .org works.
But it may take some time until all DNS servers worldwide have adopted the new forwarding. If you can give me a short feedback if it works, would be very good.

Unfortunately the problems with the speed of the server are still not solved. I am still trying to find the exact cause of the problem. The server has been rebooted, so it should be much faster.
PhyllisSmith

PhyllisSmith

2019-12-30 23:09

manager   ~0002609

I do not see the same thing as "In Firefox, enter "cinelerra-gg.org" in the address field, hit enter. At the bottom you'll see it redirected to cinelerra-gg.com, which eventually times out." I only see cinelerra-gg.org BUT it is very slow.

Issue History

Date Modified Username Field Change
2019-12-30 22:07 MatN New Issue
2019-12-30 23:09 PhyllisSmith Note Added: 0002609
2019-12-30 23:36 Sam Note Added: 0002610
2019-12-30 23:36 Sam Assigned To => Sam
2019-12-30 23:36 Sam Status new => acknowledged
2019-12-30 23:46 Sam Note Added: 0002611
2019-12-31 00:06 Sam Note Added: 0002612
2019-12-31 09:03 MatN Note Added: 0002613
2019-12-31 09:18 Andrea_Paz Note Added: 0002614
2019-12-31 11:44 MatN Note Added: 0002615
2019-12-31 12:45 Sam Note Added: 0002616
2020-01-02 04:43 PhyllisSmith Note Added: 0002627
2020-01-02 11:46 Sam Note Added: 0002630
2020-01-03 20:29 PhyllisSmith Note Added: 0002634
2020-01-04 08:08 Sam Note Added: 0002635
2020-01-06 00:57 Sam Status acknowledged => feedback
2020-01-06 00:57 Sam Note Added: 0002636
2020-01-06 14:12 MatN Note Added: 0002637
2020-01-06 14:12 MatN Status feedback => assigned
2020-01-06 17:38 PhyllisSmith Note Added: 0002640
2020-02-03 18:41 PhyllisSmith Status assigned => closed
2020-02-03 18:41 PhyllisSmith Resolution open => fixed
2020-02-03 18:41 PhyllisSmith Note Added: 0002780