View Issue Details

IDProjectCategoryView StatusLast Update
0000364Cinelerra-GG[All Projects] Featurepublic2020-02-03 22:23
ReporterRafaMar Assigned Togoodguy  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2020-01 
Summary0000364: Allow to choose where to save the snapshots
DescriptionI notice that the snapshots are saved by default in /tmp, this causes that when the system is rebooted these snapshots have disappeared.
It would be nice for users who don't know much about computers if when a snapshot is taken it is saved in a folder called "Snapshots" next to the project file or if a wizard is opened so you can choose where to save the image. I know that in the options you can choose the folder where the snapshots are saved, but this one by default comes in /tmp and this is dangerous because these are lost after a reboot.
This simple feature would make editing much easier when we need to use video clip captures.
Thank you very much for your great work. I am an audiovisual technician and I have decided to write a series of tutorials and video tutorials about Cinelerra GG in Spanish and my intention is to notify the errors or issues that arise.
TagsNew Feature

Activities

PhyllisSmith

PhyllisSmith

2020-02-03 18:35

manager   ~0002778

Although I like the idea of opening an "assistant" to designate the location of where to save the snapshot, if you have to do that every time you make a snap or grab shot, it is an extra click to use the default.
RafaMar

RafaMar

2020-01-19 23:46

reporter   ~0002729

Thank you very much for the answers and explanations. It seems to me a good option that you propose, the one that is kept in the folder of images.
I am aware of the work that these things carry, but I still think that the ideal would be for the assistant to open in order to choose the location of the file. Although I have observed that the export assistant has the option to export a single frame in the desired place.
So I also consider a very good solution that you propose.
I will notify the problems and ideas that arise to help me.
PhyllisSmith

PhyllisSmith

2020-01-19 20:58

manager   ~0002727

We came up with a solution that solves the problem for a new user. The default directory instead of /tmp will be $HOME/Pictures -- this is consistent with where png's go when you hit the "Print Screen" key on the keyboard and does not get deleted on a reboot. The option to change in Settings->Preferences, Interface tab, Snapshot Path is still there and existing users will have to manually change it since it is already saved in $HOME/.bcast5/Cinelerra_rc. The change will be in the January 31 new monthly builds.
PhyllisSmith

PhyllisSmith

2020-01-19 16:54

manager   ~0002723

I will see what can be done about snapshots destination; looking into Andrea's suggestion.
    Kind of the philosophy of using /tmp is that it exists on all of the different distros to include fedora, ubuntu, slackware, ... and the other viable recently discovered common spot is $HOME/Videos. The change made by the Operating System distros to automatically delete /tmp was a bad one as it was already an option in cron to delete when the admin wanted to. The original idea of snapshot and grabshots was that they were just a quick way to get a shot without any work and because of that having the default being $HOME/Videos might be a bad idea as it will not get cleaned up.

PLEASE continue to make suggestions and present ideas as we consider them all and often pick and choose. With at least 125 open issues and currently limited programmers, it will take time to get through them all.
RafaMar

RafaMar

2020-01-19 12:06

reporter   ~0002718

I don't know if there is a forum in Spanish, I have just arrived at Cinelerra, I will do the tutorials in this language. But it will be a pleasure to share them in the forum. My intention as a professional is to notify the things that I think can be improved for a better experience for the users. But I don't know about programming and I don't know if it's easy to modify the things I will notify.
Andrea_Paz

Andrea_Paz

2020-01-19 10:51

updater   ~0002714

Interesting idea. In Resouces window you could add an new entry called "Snapshot" to the Media, Clips, etc. folders.
PS: Please, post your tutorials in the forum!

Issue History

Date Modified Username Field Change
2020-01-19 10:06 RafaMar New Issue
2020-01-19 10:06 RafaMar Tag Attached: New Feature
2020-01-19 10:51 Andrea_Paz Note Added: 0002714
2020-01-19 12:06 RafaMar Note Added: 0002718
2020-01-19 16:54 PhyllisSmith Note Added: 0002723
2020-01-19 20:48 PhyllisSmith Assigned To => goodguy
2020-01-19 20:48 PhyllisSmith Status new => assigned
2020-01-19 20:58 PhyllisSmith Status assigned => acknowledged
2020-01-19 20:58 PhyllisSmith Note Added: 0002727
2020-01-19 23:46 RafaMar Note Added: 0002729
2020-02-03 18:35 PhyllisSmith Status acknowledged => closed
2020-02-03 18:35 PhyllisSmith Resolution open => fixed
2020-02-03 18:35 PhyllisSmith Fixed in Version => 2020-01
2020-02-03 18:35 PhyllisSmith Note Added: 0002778