View Issue Details

IDProjectCategoryView StatusLast Update
0000378Cinelerra-GG[All Projects] Bugpublic2020-03-08 17:15
ReporterRafaMar Assigned ToPhyllisSmith  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformDesktop pcOSLinux MIntOS Version19.3
Product Version 
Target VersionFixed in Version2020-03 
Summary0000378: Sudden closure with a title plugin tool
DescriptionGreetings team. I just observed a serious error that causes the application to close suddenly.
This is when I use the Titles plugin, in the text box with the right button it gives me the option to open an image, the problem occurs if there is any space in the image path.
For example
/home/rafa/testProyect/one image.png
it wouldn't give problems but if the route were like that
/home/rafa/test project/one image.png
the application closes suddenly.
Perhaps it would be enough to always enclose this route in quotes automatically and thus avoid this annoying problem.
I have tried it on several systems, also with the Spanish language, and the fault always occurs.
TagsCrash

Activities

PhyllisSmith

PhyllisSmith

2020-03-08 17:15

manager   ~0002870

The fix for webp was checked into GIT and will be in the next set of builds.
PhyllisSmith

PhyllisSmith

2020-03-03 15:32

manager   ~0002864

Just a small update. When we were working on Mint 19 and Mint 19.3 on the build computers, we tested a file name longer than 128 for the Titler background png file and could never get it to fail. So we have no idea what is really wrong.

I will clost this issue AFTER the other reported issue about webp and w%00d is fixed. Which is an image2 ffmpeg problem requiring at least 1 character in the top level w%00d.webp file. Image sequences for gif and tiff work in a similar manner and have the top level working but they are used without ffmpeg.
RafaMar

RafaMar

2020-02-13 00:17

reporter   ~0002807

I haven't been able to get the .dmp report, I'm sorry. Perhaps it is an isolated problem in my configuration. Anyway, knowing that it produces it, I can circumvent it.

Turning to another topic, I just made a small video in which I report a subtle problem, do you think I should put it as a bug? Or is it not important?

this video is in: https://drive.google.com/open?id=1iJ1Z0iDfovibcJvjOwb59cq7Yt6LdNfk
PhyllisSmith

PhyllisSmith

2020-02-12 21:41

manager   ~0002806

Although it may sound like gibberish, the buffer overflow detected is helpful to gg, the programmer. I have created file names just as long and longer using similar names as yours, both as root and as a normal user. But on Fedora it still does not crash. The program code allows for 1024 characters in the total path/file name. From your Chapter 1 youtube video, I understand that you are probably using Mint 19 so we will try it on that O/S when I can get to that computer.

GG really would really like to be able to fix this, but It is very difficult to fix a problem that he can not recreate because there is no way to tell if the fix even works or not. However if you have extra time, sending an actual core dump could prove useful to gg. The most useful core dump is to install the "gdb" package on your Operating System, run as root from a window, and usually it will create a cinelerra_xxxx.dmp file on /tmp -- sometimes it does not though.
RafaMar

RafaMar

2020-02-12 11:04

reporter   ~0002804

Hi Phyllis, sorry for my delay in answering.
You are right, I have investigated the problem and it is not due to the spaces, it is due to the length of the name or path, if this is long it causes the sudden closing.
I have tried with the same image, a small capture of a desktop icon, with different names and the error has only occurred with long names or long routes.
I have attached a video so you can see what I mean.
The terminal's output is:
-----------------------------------------------------------------------------
[email protected]:~$ cin
Cinelerra Infinity - built: Jan 31 2020 11:52:19
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

*** buffer overflow detected ***: cin terminated
Aborted (core dumped)
---------------------------------------------------------------------------------------------------------
Thank you very much for your good work with cinelerra.

TitleBugCrash.mp4 (1,361,292 bytes)
PhyllisSmith

PhyllisSmith

2020-02-12 03:11

manager   ~0002802

Can not reproduce on Fedora -- it works just fine here when I use a path name that has a blank in it and a file name that has a blank in it for the image name. Which Operating System are you using? GG says that if the program is changed to put quotes around it, it will not find the file at all. And I tried this, and that is true.

Could you start Cinelerra from a command line shell in a window instead of using the icon, the log messages may be useful to understand what the problem is? That is: /usr/bin/cin

We would like to get to to bottom of this and see what the problem is.

Issue History

Date Modified Username Field Change
2020-02-11 23:44 RafaMar New Issue
2020-02-11 23:44 RafaMar Tag Attached: Crash
2020-02-12 03:11 PhyllisSmith Assigned To => PhyllisSmith
2020-02-12 03:11 PhyllisSmith Status new => acknowledged
2020-02-12 03:11 PhyllisSmith Note Added: 0002802
2020-02-12 11:04 RafaMar File Added: TitleBugCrash.mp4
2020-02-12 11:04 RafaMar Note Added: 0002804
2020-02-12 21:41 PhyllisSmith Note Added: 0002806
2020-02-13 00:17 RafaMar Note Added: 0002807
2020-03-03 15:32 PhyllisSmith Note Added: 0002864
2020-03-08 17:15 PhyllisSmith Status acknowledged => closed
2020-03-08 17:15 PhyllisSmith Resolution open => fixed
2020-03-08 17:15 PhyllisSmith Fixed in Version => 2020-03
2020-03-08 17:15 PhyllisSmith Note Added: 0002870