View Issue Details

IDProjectCategoryView StatusLast Update
0000379Cinelerra-GG[All Projects] Bugpublic2020-03-06 21:27
ReporterMatN Assigned ToPhyllisSmith  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformX86_64OSMint XFCEOS Version19.3
Product Version 
Target VersionFixed in Version2020-02 
Summary0000379: On a newly installed Mint 19.3 , Cin 2020-01 does not start, missing libIlmThread-2_2.so.12
DescriptionI have verified this on Mint 19.3 live boots of the XFCE, Cinnamon and Mate versions, in a VirtualBox VM, using a downloaded static tar. Also on a freshly installed + all updates XFCE in a VB VM, using the repository.
Steps To ReproduceSee description
Additional InformationMaybe it is possible to compile the missing lib into Cinelerra?
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2020-03-06 21:27

manager   ~0002869

Looks good so am closing.
@Andrea_Paz
I reviewed Chris's video again after noting his comment you passed along "I intended to include Cinelerra, but sadly could not get it to run." I hope he will try again and make a 5 minute video reviewing it which I asked him to do in a public comment for his youtube video.

MatN

MatN

2020-02-29 15:59

reporter   ~0002849

I saw the message in the mailing list about the library updates. I can build with all the updates fine, PulseAudio works as well as Alsa in the short tests I did.
DukeOfHuntingdon

DukeOfHuntingdon

2020-02-29 00:03

reporter   ~0002847

The latest fix also works with Ubuntu 19.10 and Ubuntu 20.04 beta.
MatN

MatN

2020-02-28 22:23

reporter   ~0002845

Fix confirmed. Using the same live Mint 19.3 boot in a VM, that static tar now runs without any obvious problems or errors in the terminal where it is started from. Well done you two!
PhyllisSmith

PhyllisSmith

2020-02-28 18:19

manager   ~0002843

There is a Mint 19.3 static tar at:
   https://cinelerra-gg.org/download/testing/cinelerra-5.1-mint19-x86_64-static.txz
WITH the latest checked in mods included. It should no longer be asking for libIlmThread/Iex. At least that is what we see here. We tested building a 19.3 Mint static tar yesterday also and were able to load and bring it up on Mint 19 (so it should work for 19, 19.2, and 19.3 if all goes well).

@DukeofHuntingdon
Thanks for the added information on Ubuntu Studio 19/20 for the package build. We believe, but have not tested, that the addition of makeshlibs and bldshlibs (spelling?) to the package build should fix the problem both on Mint (which MatN did check) and Ubuntu 19/20. And especially thanks for reporting this - it helps more than you think as some users just give up when something does not work).
MatN

MatN

2020-02-26 16:43

reporter   ~0002842

I am sorry to report that the single user packages have the same problem. Same test environment, VirtualBox VM, Mint 19.3 XFCE booted from ISO, not installed, just running the "live" Mint. That only takes a few minutes.
Downloaded both static and non-static single user build, extracted each in its own directory, and from a terminal ran ./cin in those. Always the ilmthread error.
I think I saw during ./configure time that ilmthread was set to "auto" . Isn't the only way to guarantee that it is included that it is set to "yes"?
Anyway, the static build does evidently not include all, and I though the distro packages were also static?
DukeOfHuntingdon

DukeOfHuntingdon

2020-02-26 16:37

reporter   ~0002841

I actually saw exactly the same behavior with Ubuntu Studio 19.10 and Ubuntu Studio 20.04 beta. I tested the single use tar on both (20.04 as a VM), and the tar worked fine.
Andrea_Paz

Andrea_Paz

2020-02-26 09:01

updater   ~0002840

I don't know if it's just Arch or if it'll help:

https://bugs.archlinux.org/task/65129

https://bbs.archlinux.org/viewtopic.php?id=252136
Pierre

Pierre

2020-02-26 04:26

updater   ~0002839

I don't know if I would detect a problem here. The two test machines I have running Linux Mint 19.3 are both the result of an upgrade from an original 19.1 or 19.2 installation.

From what I have read so far this problem seems to concern Linux Mint when it is directly installed in 19.3 from the start.

I would still be busy with my plumbing problems for 2 or 3 weeks but I'm starting to see the end of this dripping subject...
PhyllisSmith

PhyllisSmith

2020-02-26 02:52

manager   ~0002837

@MatN
Thanks for the feedback -- Bill says to tell you "how grateful he is for all of the work you did to find, test, verify this issue". It takes a lot of time just to install Mint, let alone work through this.

I have tried to figure out the "root cause" but have been unable to. But anyway, when building the Cinelerra package it is the job of the distro package installer (dpkg?) to determine when another file is needed for Cinelerra install. As far as we know, this was working with Mint 19 which was what we have been using to create the monthly builds up to January 31, 2020. So it seems that Mint 19.3 required more preparation than what was being used to build Cinelerra. These "rules" for packaging are in the file:
    {cinelerra_path}/blds/debian/rules
which now has 2 additional lines to fix the Mint 19.3 problem of packaging: dh_makeshlibs & dh_shlibdeps after dh_installdeb -a .

The bottom line is the reason for the missing libIlmThread (and most likely any other missing stuff) is that the Cinelerra package build reported zero missing packages. And that was the problem, but I don't know why.

The "static" tar will be fine as it automatically contains everything (so if you use the January 31, 2020 static tar on Mint 19.3, it will work). The "dynamic" tars are another matter altogether -- they are always subject to the existence or non-existence of libraries, etc. that the system administrator may or may not have installed. So I think we will be OK for the February 29 builds but I am sure Pierre will let us know if not !
MatN

MatN

2020-02-25 19:45

reporter   ~0002835

20200225 test build on VM boot from ISO: During install, it now sees ilmthread is missing, and wants to install it. If you let it, it will work afterwards. This fixes it for .deb packages.
But the tar single user packages don't have this, I think? Or is ilmthread there built into CinGG now?
PhyllisSmith

PhyllisSmith

2020-02-25 18:12

manager   ~0002834

Thanks for the feedback. One more time! A new build for testing.
   https://cinelerra-gg.org/download/testing/cin_5.1.mint19.3-20200225_amd64.deb
MatN

MatN

2020-02-25 10:33

reporter   ~0002833

@Andrea,
Regarding the Youtuber's problem, could you ask him to tell you what the problem was? Did he try to install the repository (that will only work after the latest updates, or following the Cinelerra website workaround), or did he download a tar ball. Did the install go wrong, or could he not start it, and if so, did he try from a terminal?
MatN

MatN

2020-02-25 10:29

reporter   ~0002832

I am sorry to report that the problem remains the same.
Test: VirtualBox VM, starting from Mint 19.3 ISO, in the started Mint downloaded the 20200224 file in test via the browser, installed it, started it from a terminal, error:
[email protected]:~$ cin
cin: error while loading shared libraries: libIlmThread-2_2.so.12: cannot open shared object file: No such file or directory
PhyllisSmith

PhyllisSmith

2020-02-24 23:47

manager   ~0002831

Created a "minty fresh" install of Mint 19.3. As MatN stated libIlmThread-2.2.so.12 was missing when attempting to start up Cin. Also, missing libIex-2.2.so.12. GG created a new build on Mint 19.3 so that these files no longer are reported as missing.

If anyone gets an opportunity to verify our fixes/results, that would be highly appreciated. A temporary package install is at:
   https://cinelerra-gg.org/download/testing/cin_5.1.mint19.3-20200224_amd64.deb
This month's build will be done on 19.3 so hopefully everyone out there will have upgraded to that. We have not checked to see if the 19.3 build will work on a 19 or 19.2 system but if we have to, we can at least still build tars for 19.
Andrea_Paz

Andrea_Paz

2020-02-23 08:37

updater   ~0002829

An "external" confirmation is given by a Youtuber who failed to make CinGG work in Mint 19.3. Answering to me that I had asked why not to include CinGG in a comparative of video editors, he replied:

"I intended to include Cinelerra, but sadly could not get it to run."

https://www.youtube.com/watch?v=GmHAiUcAPwk

Issue History

Date Modified Username Field Change
2020-02-14 14:59 MatN New Issue
2020-02-23 08:37 Andrea_Paz Note Added: 0002829
2020-02-24 23:47 PhyllisSmith Assigned To => PhyllisSmith
2020-02-24 23:47 PhyllisSmith Status new => feedback
2020-02-24 23:47 PhyllisSmith Note Added: 0002831
2020-02-25 10:29 MatN Note Added: 0002832
2020-02-25 10:29 MatN Status feedback => assigned
2020-02-25 10:33 MatN Note Added: 0002833
2020-02-25 18:12 PhyllisSmith Note Added: 0002834
2020-02-25 19:45 MatN Note Added: 0002835
2020-02-26 02:52 PhyllisSmith Note Added: 0002837
2020-02-26 04:26 Pierre Note Added: 0002839
2020-02-26 09:01 Andrea_Paz Note Added: 0002840
2020-02-26 16:37 DukeOfHuntingdon Note Added: 0002841
2020-02-26 16:43 MatN Note Added: 0002842
2020-02-28 18:19 PhyllisSmith Note Added: 0002843
2020-02-28 22:23 MatN Note Added: 0002845
2020-02-29 00:03 DukeOfHuntingdon Note Added: 0002847
2020-02-29 15:59 MatN Note Added: 0002849
2020-03-06 21:27 PhyllisSmith Status assigned => closed
2020-03-06 21:27 PhyllisSmith Resolution open => fixed
2020-03-06 21:27 PhyllisSmith Fixed in Version => 2020-02
2020-03-06 21:27 PhyllisSmith Note Added: 0002869