View Issue Details

IDProjectCategoryView StatusLast Update
0000435Cinelerra-GG[All Projects] Bugpublic2020-07-08 21:51
ReporterArchBug Assigned ToPhyllisSmith  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2020-04 
Target VersionFixed in Version2020-05 
Summary0000435: Error with libIlmImf-2_4.so.24 Library on ArchLinux
DescriptionDear cinelerra-community,
I highly appreciate your work and efforts you do for this great project.

I'd like to report the following bug:

Operating System: Arch Linux, up to date on May 18th

When executing "$ cin" in the terminal it throws back
>> cin: error while loading shared libraries: libIlmImf-2_4.so.24: cannot open shared object file: No such file or directory

According to my research this library seems to be part of the openexr-Package.

$sudo pacman -Qs openexr
gives me
>> local/openexr 2.5.1-1
    An high dynamic-range image file format library

according to the ArchLinux-Website the openexr-Package indeed contains a file called "usr/lib/libIlmImf-2_5.so" which seems to be the file cinelerra demands, but in a newer version.

I hope this helps you!
Steps To ReproduceOpen a terminal in ArchLinux with cinelerra installed and execute $ cin
Tagsbug, libIlmImf, library-error

Activities

PhyllisSmith

PhyllisSmith

2020-07-08 21:51

manager   ~0003772

Forgot to close earlier, but better late than never.
PhyllisSmith

PhyllisSmith

2020-05-26 12:56

manager   ~0003474

Will close this after May 31 when monthly builds are done. (Thanks for testing to make sure all will be good).
ArchBug

ArchBug

2020-05-26 07:06

reporter   ~0003472

I've tested the package for the local installation and luckily it's running well :)
ArchBug

ArchBug

2020-05-20 10:54

reporter   ~0003454

@PhyllisSmith
thank you for your efforts! I will test the test package build these days and post whether this package is doing fine.
PhyllisSmith

PhyllisSmith

2020-05-19 15:34

manager   ~0003448

@Andrea_Paz
It builds from 2.4 because that build uses the thirdparty directory libraries which we have not updated to 2.5 yet.
Andrea_Paz

Andrea_Paz

2020-05-19 07:11

updater   ~0003447

Curiosity: since I compile from source (in Arch), I didn't have any library problems. Does this mean that when I compile CinGG, the newest library in the system is used?
PhyllisSmith

PhyllisSmith

2020-05-18 18:55

manager   ~0003446

Arch was updated on our build computer and a new package was created. We did note that as you stated it now uses: usr/lib/libIlmImf-2_5.so
A test package build is at:
       https://cinelerra-gg.org/download/testing/cin-5.1-20200518-arch-x86_64.pkg.tar.xz
If you want to check it out. We did not actually try it due to time constraints here and you will have to do a local package install to install it after un-tarring the downloaded file.

Let us know if any further problems. We use Fedora so are not as Arch-savvy as you probably are.
PhyllisSmith

PhyllisSmith

2020-05-18 13:29

manager   ~0003443

@ArchBug
Yes, this helps us! As you well know, Arch is continuously updating. But we only create an Arch build once a month based on the Arch O/S as it exists around the 29th or 30th of the month. So when arch updates a library that is being used by cinelerra, we are out of sync and end up with exactly the type of scenario you found.

So when we hear of this, gg will update Arch and create a static tar so that is a user does not want to wait until the next Arch build, they can use that temporarily.

Issue History

Date Modified Username Field Change
2020-05-18 12:48 ArchBug New Issue
2020-05-18 12:48 ArchBug Tag Attached: bug
2020-05-18 12:48 ArchBug Tag Attached: libIlmImf
2020-05-18 12:48 ArchBug Tag Attached: library-error
2020-05-18 13:29 PhyllisSmith Assigned To => PhyllisSmith
2020-05-18 13:29 PhyllisSmith Status new => acknowledged
2020-05-18 13:29 PhyllisSmith Note Added: 0003443
2020-05-18 18:55 PhyllisSmith Note Added: 0003446
2020-05-19 07:11 Andrea_Paz Note Added: 0003447
2020-05-19 15:34 PhyllisSmith Note Added: 0003448
2020-05-20 10:54 ArchBug Note Added: 0003454
2020-05-26 07:06 ArchBug Note Added: 0003472
2020-05-26 12:56 PhyllisSmith Status acknowledged => resolved
2020-05-26 12:56 PhyllisSmith Resolution open => fixed
2020-05-26 12:56 PhyllisSmith Fixed in Version => 2020-05
2020-05-26 12:56 PhyllisSmith Note Added: 0003474
2020-07-08 21:51 PhyllisSmith Status resolved => closed
2020-07-08 21:51 PhyllisSmith Note Added: 0003772