View Issue Details

IDProjectCategoryView StatusLast Update
0000441Cinelerra-GG[All Projects] Bugpublic2020-06-30 23:17
ReporterRafaMar Assigned Togoodguy  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSGnu/LinuxOS VersionMint 19.3
Product Version2020-04 
Target VersionFixed in Version2020-06 
Summary0000441: The sketcher effect causes the application to close
DescriptionI want to write a tutorial on paths with the sketcher effects, and I wanted to check if I could change the stroke color in one step using the wizard for it. I have seen that this did not work, so far everything normal.
The reason for this notification is because when performing this test when trying to preview the result Cinelerra has been closed suddenly.
This has always been the case, in all attempts. Perhaps I am doing things that are not correct to do, but I wanted to notify you in case you think that the closure of the sudden should be fixed. The color change, with which it is known that it does not work is already solved, with one undo it is fixed, the problem I see in the sudden closure.
I have added a video with the problem.
https://streamable.com/b5maae
Steps To Reproducehttps://streamable.com/b5maae
Tagsbug, Crash

Activities

PhyllisSmith

PhyllisSmith

2020-06-30 23:17

manager   ~0003712

Thanks to RafaMar for verifying the fix. Can close any time.
RafaMar

RafaMar

2020-06-10 20:32

reporter   ~0003582

Wonder of wonders, my sincere congratulations Phyllis, now not only does it not close, but you can change the color of the stroke to all the frames without losing the animation. This is much more than I could imagine.
When I reported the error it was because I worry about the closure, but now the effect has gained many points, in the next tutorial I will make about it I will mention this improvement. A user already asked me how I made the traces from the beginning of the video on the map trace.
Thank you very much Phyllis.
RafaMar

RafaMar

2020-06-10 19:19

reporter   ~0003580

Thank you very much Phyllis, as soon as I can I will try this version that you send me and I will tell you things, if you close the ticket I will send you an email to your personal email.
Regards.
PhyllisSmith

PhyllisSmith

2020-06-10 01:48

manager   ~0003577

@RafaMar
It took quite some time to get a fix implemented. A test Mint 19.3 static tar is at:
     https://cinelerra-gg.org/download/testing/cinelerra-5.1-mint19-x86_64-static.txz
The fix is to "change the stroke color in one step using the wizard for it." Other bug fixes were applied but since I was not able to reproduce the crash for sure, I have not been able to verify that the crash is also fixed. However, with the fixes in it never crashed for us.

The applied fixes were to correct "keyframe spanning" for Sketcher, Tracer, and Crikey plugins which all have a unique usage requiring a different method to accomplish this. The one thing that may not be obvious is that the keyframe spanning is applicable to the previous keyframe as well as the selected keyframe as it needs that to do the processing.
RafaMar

RafaMar

2020-05-29 05:30

reporter   ~0003507

It is admirable how well you work. Thank you very much, Cinelerra does not stop improving.
PhyllisSmith

PhyllisSmith

2020-05-28 23:17

manager   ~0003505

For others who may be reading this. The problem was found and a plan to implement a spanning keyframe change for the Sketcher and possibly other plugins, will be delayed until next month. This is because it is a pervasive change and now there is insufficient time to make a fix and test it well enough before 05/31 builds are to be done.
RafaMar

RafaMar

2020-05-28 15:48

reporter   ~0003498

Ok, thank you very much, the next time I find an error I will look at this line and send this file too.
PhyllisSmith

PhyllisSmith

2020-05-28 13:17

manager   ~0003494

If you look at your sketcher_error demo, you see at time 01:53:541 the window where you started cinelerra from, the line:
    writing debug data to /tmp/cinelerra_14291.dmp
since you make such thorough demos it is not needed at all but it never hurts for GG to see it. The 14291 number changes depending on the clock time.
RafaMar

RafaMar

2020-05-28 05:20

reporter   ~0003487

Thank you. How do you create this /tmp/cinelerra_14291.dmp file?
Regards.
PhyllisSmith

PhyllisSmith

2020-05-28 00:41

manager   ~0003481

Confirmed by GG reproducing this and he will try to look at it tomorrow. Thank you for the demo as it made it possible to create. It is also helpful if in the future it creates a /tmp/cinelerra_14291.dmp to include that also.

Issue History

Date Modified Username Field Change
2020-05-27 20:22 RafaMar New Issue
2020-05-27 20:22 RafaMar Tag Attached: bug
2020-05-27 20:22 RafaMar Tag Attached: Crash
2020-05-28 00:41 PhyllisSmith Note Added: 0003481
2020-05-28 00:41 PhyllisSmith Assigned To => PhyllisSmith
2020-05-28 00:41 PhyllisSmith Status new => confirmed
2020-05-28 00:45 PhyllisSmith Assigned To PhyllisSmith => goodguy
2020-05-28 05:20 RafaMar Note Added: 0003487
2020-05-28 13:17 PhyllisSmith Note Added: 0003494
2020-05-28 15:48 RafaMar Note Added: 0003498
2020-05-28 23:17 PhyllisSmith Note Added: 0003505
2020-05-29 05:30 RafaMar Note Added: 0003507
2020-06-10 01:48 PhyllisSmith Note Added: 0003577
2020-06-10 19:19 RafaMar Note Added: 0003580
2020-06-10 20:32 RafaMar Note Added: 0003582
2020-06-30 23:17 PhyllisSmith Status confirmed => resolved
2020-06-30 23:17 PhyllisSmith Resolution open => fixed
2020-06-30 23:17 PhyllisSmith Fixed in Version => 2020-06
2020-06-30 23:17 PhyllisSmith Note Added: 0003712