View Issue Details

IDProjectCategoryView StatusLast Update
0000455Cinelerra-GG[All Projects] Bugpublic2020-07-01 00:36
ReporterMatN Assigned ToPhyllisSmith  
PrioritynormalSeveritymajorReproducibilityalways
Status acknowledgedResolutionunable to reproduce 
PlatformX86_64OSMint XFCEOS Version19.3
Product Version 
Target VersionFixed in Version 
Summary0000455: Consistent CinGG UI freeze after a certain operation, version 2020-05
DescriptionI am creating a tutorial video for an audio program, and when editing it CinGG's UI froze. Very repeatable.
CinGG loaded from terminal, no errors when loading project or video, no errors when the freeze appeared.
In the resource window mouse fly-over text still worked until I clicked on an item, then it froze also. Compositor frozen too.
No crash, CinGG kept running. No error in terminal.

Video input file was a transcoded file (into mp4 format), because the original file created with SimpleScreenRecorder 0.4.2 had seeking errors, and errors in the terminal on loading. The transcoded file has no such problems.
Steps To ReproduceEDL file loaded in Cin, delete the empty first video and two audio tracks. 1 video and 2 audio tracks left. Cut and paste mode, time format with frames.
Move to position 0:00:01:37:00 (I went too far, and use single frame backwards and forwards to get it to there), select to about 4 seconds later, hit del key.
Then from 1:37:01 onwards video track became grey (see screenshot), audio tracks disappeared, CinGG all user interfaces dead.
Additional InformationIf you want the video and EDL file to reproduce this, it's 150M so I can must it via wetransfer. Let me know.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2020-07-01 00:36

manager   ~0003715

GG looked at this dump today and says it is a very unusual dump because it appears to be hung in libz, which is not used by Cinelerra. I attempted to set up the same scenario several times but can not get a hang. Send any more dumps if it occurs again.
MatN

MatN

2020-06-29 11:57

reporter   ~0003704

I had another similar freeze. This time no video was loaded, I was reviewing Appearance tab layout for various languages.
The UI froze, this time I saw the CPU stuck at 100% in CinGG (according to top). This might have happened other times, I just noted it now.
It froze when I closed the appearance tab using Enter, the Preferences window disappeared leaving only the CinGG main window. This I have done umpteen times today, only now it went wrong.
I created a dump using ctrl-C in terminal CinGG was started from (attached).
System Mint 19.3 XFCE in recovery mode (ati,vesa graphics driver)

Possible related error in ~/.xsession-errors:
(xed:5259): Gtk-WARNING **: 13:43:26.127: Calling org.xfce.Session.Manager.Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such method 'Inhibit'

cinelerra_1012.dmp (82,254 bytes)
PhyllisSmith

PhyllisSmith

2020-06-28 19:58

manager   ~0003687

Re-opening for more analysis.
PhyllisSmith

PhyllisSmith

2020-06-24 21:36

manager   ~0003649

Per MatN, can not reproduce. I will still look at the SimpleScreenRecorder output (as MatN provided me) to see if there is some reason, other than being mkv, that Cinelerra has problems with this format.
MatN

MatN

2020-06-24 20:07

reporter   ~0003645

@Phyllis,
I propose to close this issue. I tried for days now to reproduce it and no go. I am fairly sure it was related to either a timed screen lock (requires login), or suspend. But I have tried everything I could think of and it does not re-appear. It must be a local graphics driver issue, unrelated to CinGG code.
MatN

MatN

2020-06-20 19:28

reporter   ~0003637

Duh.
Before I posted the note below, I tried it (note 2) at least 5 times, loading cin each time again, with and without va-api. The problem was completely repeatable. Just for the heck of it, I rebooted the system to recovery mode, and the problem (from note 2) is gone! I went back to normal mode, and it was gone too. There were no system updates or any other changes to the system. Normally I run kernel 5.4.0.37 generic, I tried it's recovery mode, and also kernel 4.15.0.106 in normal mode. After the first time I cannot reproduce that problem anymore. This might also explain why I did not have it on the test machine which normally runs in recovery mode.

Sigh. It looks like this is a local problem, but I don't see how it can influence looping. I should note that this looping occurred on multiple places in the timeline, It might well have been each time after 1 second+10 frames, I remember it always flipping between frame 10 and 11 no matter where it looped. I only reported the simplest case. 1 second frame 10 would be frame 40/41 because the video is exactly 30 fps. I don't see anything weird in the .xsession-error log but of course the original one has been overwritten already after multiple reboots.
MatN

MatN

2020-06-20 19:03

reporter   ~0003636

@Phyllis,
1. I sent you a small file, 6M, created by SSR for the interlace test. I noticed that in the detailed info it shows "video1 h264 1280x1024 30.00 pix yuv420p" so the "non-interlace" info is there.
2. I sent you the original file which showed the problem per wetransfer, about 49M. I found a easier problem with the file, maybe that helps pin it down.
If I start cin (which is set to "use hw device: none") and load the file as "replace current project", it loads with some "stream times estimated" msgs. I go to the beginning, hit space bar to play, then it starts looping around 1 second frame 10 . I'm fairly sure I deleted that part in the very beginning before I got the original problem. This is on the machine I found the problem first.
On my test machine yesterday it did not exhibit the original problem, but I'll go back and test again. I need to reproduce it there before testing a new git version, obviously.
3. Maybe we need to find the best settings for SSR if the video is to be edited later bij CinGG.
PhyllisSmith

PhyllisSmith

2020-06-19 18:24

manager   ~0003634

@MatN
I am not sure the "interlace flag" is always correct. GG wanted to delete this because of this. Could you send a small sample file so he can look at it?
MatN

MatN

2020-06-19 17:44

reporter   ~0003633

The SimpleScreenRecorder author already replied, and SSR does set the non-interlace flag. Indeed, ffprobe shows "yuv420p(tv, bt709, progressive)" on the .mkv file created.
When I use this file in Cinelerra (replace current project), the info from the file in resources->media shows Asset's interlacing "unknown" , and the Settings->Format has adapted all settings to this file except interlace mode, which remained as it was before the file was opened. Is interlace mode an exception in CinGG taking over format settings during "replace current project"?
I presume that the YUV color settings in Settings->Preferences->Appearance are not influenced by any file loaded, else they would be in the Settings->Format screen.
MatN

MatN

2020-06-19 06:45

reporter   ~0003632

@Andrea_Paz,
Interesting, SimpleScreenRecorder recommends to use mkv, and specifically not use .mp4 . I just found out that it's custom options allow setting the keyframe interval, see https://www.maartenbaert.be/simplescreenrecorder/custom-codec-options/ . I´ll try this next time, maybe then I don't need to transcode first.
Also, CinGG reports that SimpleScreenRecorder does not set the interlace flag, I filed an issue for it on its github page.

I'll do a CinGG build from the current git, see if that fixes the freezes already, although resources were set to text list mode.
PhyllisSmith

PhyllisSmith

2020-06-19 01:31

manager   ~0003631

@MatN
These freezes are bad news, but I do think that what you are seeing is the bug discovered/analyzed by Andrew that is related to the Vicons in the Resources window. If you have time, try setting the preview mode to "No Play" instead of "mouse over/full play" and see if you still get the freezes. If that works, then it probably is the Vicon bug checked into GIT.
Andrea_Paz

Andrea_Paz

2020-06-18 20:57

updater   ~0003630

I get freeze sometimes, too. I always compile from git.
SimpleScreenRecorder by default uses mkv, I suggest you to use another container because it gives you a lot of problems and slowdowns in CinGG. And it's the mkv container's fault and not the codec it contains.
MatN

MatN

2020-06-18 18:44

reporter   ~0003628

Release 2020-05. If I have some time, I'll build from git and check.
Andrew-R

Andrew-R

2020-06-18 15:09

reporter   ~0003627

Does this bug occur with released version, or with version from git? (I think I had similar freeze/hang bug, but it was fixed in git ...hopefully)
MatN

MatN

2020-06-18 14:08

reporter   ~0003624

The freeze occurs later if after loading CinGG, I _first_ delete all tracks and _then_ load the XML project file. Then I get the problem when deleting somewhere around 4 minutes into the video. After that, I used a workaround by rendering the project before the action that caused the problem, and then started anew with the rendered file. The project involved mainly adding lots of short titles and deleting unwanted pieces of video. This in-between rendering causes some quality loss but not a problem for this video.
MatN

MatN

2020-06-18 11:55

reporter  

Cin_freeze_2020-05.png (69,263 bytes)
Cin_freeze_2020-05.png (69,263 bytes)

Issue History

Date Modified Username Field Change
2020-06-18 11:55 MatN New Issue
2020-06-18 11:55 MatN File Added: Cin_freeze_2020-05.png
2020-06-18 14:08 MatN Note Added: 0003624
2020-06-18 15:09 Andrew-R Note Added: 0003627
2020-06-18 18:44 MatN Note Added: 0003628
2020-06-18 20:57 Andrea_Paz Note Added: 0003630
2020-06-19 01:31 PhyllisSmith Note Added: 0003631
2020-06-19 06:45 MatN Note Added: 0003632
2020-06-19 17:44 MatN Note Added: 0003633
2020-06-19 18:24 PhyllisSmith Assigned To => PhyllisSmith
2020-06-19 18:24 PhyllisSmith Status new => acknowledged
2020-06-19 18:24 PhyllisSmith Note Added: 0003634
2020-06-20 19:03 MatN Note Added: 0003636
2020-06-20 19:28 MatN Note Added: 0003637
2020-06-24 20:07 MatN Note Added: 0003645
2020-06-24 21:36 PhyllisSmith Status acknowledged => closed
2020-06-24 21:36 PhyllisSmith Resolution open => unable to reproduce
2020-06-24 21:36 PhyllisSmith Note Added: 0003649
2020-06-28 19:58 PhyllisSmith Status closed => acknowledged
2020-06-28 19:58 PhyllisSmith Note Added: 0003687
2020-06-29 11:57 MatN File Added: cinelerra_1012.dmp
2020-06-29 11:57 MatN Note Added: 0003704
2020-07-01 00:36 PhyllisSmith Note Added: 0003715