View Issue Details

IDProjectCategoryView StatusLast Update
0000457Cinelerra-GG[All Projects] Bugpublic2020-07-20 19:25
Reporterhouku Assigned ToPhyllisSmith  
PriorityhighSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
PlatformLinuxOSendeavourOOS Version
Product Version2020-04 
Target VersionFixed in Version 
Summary0000457: cinelerra doesnt launch, and i really wanted to try it :(
Descriptionso i was scrolling around youtube for the heck of it, and i saw a comment on a random linux video suggesting cinelerra GG, and it said that it aims to be linux only alternative for premere and (if i remember correctly) as good as davinci resolve, now, i was using davinci on windows since i couldnt get rid of it, unfortunatly for me, after i learned so much about davinci resolve, i couldnt get out of using it, but when i heard cinelerra was as good, i thought i could finally get out of using windows, i followed the steps for arch, since i was using endeavourO in which is based on arch, and when added and updated, i installed it, and it installed quite fast, but i got this error:" cin: error while loading shared libraries: libaom.so.0: cannot open shared object file: No such file or directory "
so i did what a programmer does when having as issue and googled an answer, which led to this: https://forum.manjaro.org/t/cin-gg-dont-launch-itself-any-more-solved/79843 "
so i added the the new edit stuff with nano, and updated + install, copied, and it still didnt launch, i removed it and installed the git version from AUR, and i got this: Cinelerra Infinity - built: Jun 16 2020 19:36:26
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
"2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

BC_WindowBase::init_im: Could not open input method.
unjoined tids / owner 1
  00007f3bf148e700 / 00007f3bfe4b5c80 12BC_Clipboard

at that point i was confused, i dont want to go insane so im just gonna ask for help from the bug report, and if i find a solution with help or alone, i would edit it and add the solution, thanks in advance"

update: thank you all for trying to help, i tested the fixes yet i still get errors, thats the error i have:

Cinelerra Infinity - built: May 31 2020 17:18:21
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

BC_WindowBase::init_im: Could not open input method.
unjoined tids / owner 1
  00007f8de485f700 / 00007f8df186c800 12BC_Clipboard


i dont want to get too deep into this, mainly because it seems like a lot of effort by now for just a video editor, tho if it works (and yes i will try to get it working), then i will be more then glad to try it out for a run and use it
Steps To Reproducegoogled and added
[cingg]
SigLevel = Optional TrustAll
Server = https://cinelerra-gg.org/download/pkgs/arch
# end of cingg
Additional Informationit doesnt open
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2020-07-13 21:36

manager   ~0003802

Closing, because it sounds like the software is now working.
And the effects issue is in BT 0000477 too and I am trying Resample myself for that. It is not clear if jbigkit is required for Arch or not, but without confirmation, I am not adding it to README.arch yet.
houku

houku

2020-07-13 11:41

reporter   ~0003795

okay, so... today, i just decided to try again to open cinelerra, idk how, i assume it was this forum and some restarts, and cinelerra launched fine, no issuses, HOWEVER, most of the effects dont seem to work for me, i.e resample didnt speed up the audio, or maybe its updated and then idk how to use it properly, i know that theres a dedicated youtube channel called "cinelerra GG" for cinelerra GG, but its isnt english and i find it hard to understand from subtitles, aside of that, its probably the most feature rich of a video editor i even encountered on linux, and if you could just fix some of the effects like previously mentioned, or atleast make an english channel so i can know what all the effects do and such, it would be amazing,

thanks for helping me get the software to work
Andrea_Paz

Andrea_Paz

2020-07-09 06:02

updater   ~0003778

Try installing "jbigkit" and see if it works. If it has become a necessary dependency we can put it in README.arch.
PhyllisSmith

PhyllisSmith

2020-07-09 04:14

manager   ~0003777

Possibly 1 of these may be the problem:
1) you do not have libjpeg installed (pacman -S libjpeg-turbo) OR
2) the libjpeg version on Arch has been upgraded since June 29 when GG built the Arch package
houku

houku

2020-07-09 01:12

reporter   ~0003773

okay, so i googled LC_CTYPE=en_GB.utf8 thing, and i figured (not sure if that what i was suposed to do) to /etc/locale.conf LC_CTYPE=en_GB.utf8 and tried to run cin, and got now THIS error:
./cin: error while loading shared libraries: libjbig.so.0: cannot open shared object file: No such file or directory

any ideas?
PhyllisSmith

PhyllisSmith

2020-07-08 19:57

manager   ~0003769

@houku
Thanks for the feedback -- you made it possible for others to work around the problem. Which is the LC_CTYPE setting (and may be other Locale settings too). When I set this to what you have, I clearly get the same error as shown here:

LC_CTYPE="en_IL" /mnt0/build5/cinelerra-5.1/bin/cin # set LC_CTYPE and start Cinelerra
   ...
BC_WindowBase::init_im: Could not open input method.
unjoined tids / owner 1
  00007fca417fa700 / 00007fca90487840 12BC_Clipboard

The above is an O/S error. It might be as simple as just setting "LC_CTYPE=en_GB.utf8" and exporting it before starting Cinelerra. Or you can even put this in your bash startup file or run from the command line like I did above.
houku

houku

2020-07-08 15:35

reporter   ~0003768

what happens if i use locale:
LANG=en_IL
LANGUAGE=en_IL:en
LC_CTYPE="en_IL"
LC_NUMERIC="en_IL"
LC_TIME="en_IL"
LC_COLLATE="en_IL"
LC_MONETARY="en_IL"
LC_MESSAGES="en_IL"
LC_PAPER="en_IL"
LC_NAME="en_IL"
LC_ADDRESS="en_IL"
LC_TELEPHONE="en_IL"
LC_MEASUREMENT="en_IL"
LC_IDENTIFICATION="en_IL"
LC_ALL=


side note, i got it working on a school based computer on zorin
PhyllisSmith

PhyllisSmith

2020-07-07 23:46

manager   ~0003756

Last edited: 2020-07-07 23:47

View 2 revisions

@houku

"BC_WindowBase::init_im: Could not open input method.
unjoined tids / owner 1
  00007f3bf148e700 / 00007f3bfe4b5c80 12BC_Clipboard"

Another person had this error reported today and GG "thinks" it is do to the Locale you are using. Please type in "locale" in a window and send us the output to see if it is the same problem. This was in BT # 472.

One workaround suggested on the internet is to use:
LC_CTYPE=en_GB.utf8

MatN

MatN

2020-06-26 19:16

reporter   ~0003660

@houku,
Please update your earlier bugtrack entry (BT454) instead of creating a new one.
I have found a solution for EndeavourOS, see https://www.cinelerra-gg.org/bugtracker/view.php?id=454#c3641 .

Issue History

Date Modified Username Field Change
2020-06-25 21:53 houku New Issue
2020-06-25 21:53 houku Issue generated from: 0000454
2020-06-26 19:16 MatN Note Added: 0003660
2020-07-07 23:46 PhyllisSmith Note Added: 0003756
2020-07-07 23:47 PhyllisSmith Note Edited: 0003756 View Revisions
2020-07-08 15:35 houku Note Added: 0003768
2020-07-08 19:57 PhyllisSmith Note Added: 0003769
2020-07-08 19:57 PhyllisSmith Assigned To => PhyllisSmith
2020-07-08 19:57 PhyllisSmith Status new => confirmed
2020-07-09 01:12 houku Note Added: 0003773
2020-07-09 04:14 PhyllisSmith Note Added: 0003777
2020-07-09 06:02 Andrea_Paz Note Added: 0003778
2020-07-13 11:41 houku Note Added: 0003795
2020-07-13 21:36 PhyllisSmith Note Added: 0003802
2020-07-20 19:25 PhyllisSmith Status confirmed => closed
2020-07-20 19:25 PhyllisSmith Resolution open => fixed