View Issue Details

IDProjectCategoryView StatusLast Update
0000472Cinelerra-GG[All Projects] Bugpublic2020-07-08 19:59
ReporterAskar Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionopen 
Product Version2020-04 
Target VersionFixed in Version 
Summary0000472: no launch
Descriptionso basically, im a distro hopper to some extend, i love using arch a lot, but i couldnt get resolve working there, so i moved to a more studio based distro, "ununtu studio", and resolve worked, but crap, so i tried to find an alternative, flowblade was nice, but became laggy fast, shotcut is my current alternative, but im not that happy with it, i wanna give cinelerra a good try, but when i followed the instructions on the web i got an error, when i tried to run the single user use thingy, i got the same error, (i ran from terminal), heres the output:

Cinelerra Infinity - built: Jun 30 2020 07:01:27
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

BC_WindowBase::init_im: Could not open input method.
unjoined tids / owner 1
  00007f2511f84700 / 00007f251f511f80 12BC_Clipboard
Steps To Reproducerun cinelerra
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2020-07-08 19:59

manager   ~0003770

 @Askar
Thank you for reporting this error as it gave us incentive to look into it. Which is the LC_CTYPE setting (and may be other Locale settings too). When I set this to what you have, I clearly get the same error as shown here:

LC_CTYPE="en_IL" /mnt0/build5/cinelerra-5.1/bin/cin # set LC_CTYPE and start Cinelerra
   ...
BC_WindowBase::init_im: Could not open input method.
unjoined tids / owner 1
  00007fca417fa700 / 00007fca90487840 12BC_Clipboard

The above is an O/S error. It might be as simple as just setting "LC_CTYPE=en_GB.utf8" and exporting it before starting Cinelerra. Or you can even put this in your bash startup file or run from the command line like I did above.
PhyllisSmith

PhyllisSmith

2020-07-07 23:13

manager   ~0003755

Last edited: 2020-07-07 23:15

View 2 revisions

@Askar
This message means that the function "XOpenIM" (X Open Input Method) failed.
The call is XOpenIM(display,0,0,0). ie open any input method on the display.
If it fails, it means that X did not associate an input device (usually a keyboard)
to the display. I googled "XOpenIM failed" and it seems that sometimes the locale
can cause a failure. What is your "locale"?

A suggestion on the internet was to use "LC_CTYPE-en_GB.utf8" on the command line.

Please reply with what your locale is and which desktop you are using so we can help. To get this information type "locale" in a window and send the output.

Issue History

Date Modified Username Field Change
2020-07-07 22:15 Askar New Issue
2020-07-07 23:13 PhyllisSmith Note Added: 0003755
2020-07-07 23:15 PhyllisSmith Note Edited: 0003755 View Revisions
2020-07-08 19:59 PhyllisSmith Assigned To => PhyllisSmith
2020-07-08 19:59 PhyllisSmith Status new => feedback
2020-07-08 19:59 PhyllisSmith Note Added: 0003770