View Issue Details

IDProjectCategoryView StatusLast Update
0000482Cinelerra-GG[All Projects] Bugpublic2020-08-14 01:58
ReporterRafaMar Assigned ToPhyllisSmith  
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSLinux MintOS Version19.3
Product Version 
Target VersionFixed in Version2020-07 
Summary0000482: Problem in a project with sketcher
DescriptionYesterday watching some videos of Olive and his newly incorporated node system, it occurred to me to make a showy header only using Cinelerra's resources, but things ended badly ...
It turns out that I made a sketch, very basic, with a sketcher, and today when I went to open this project to continue seeing the possibilities of doing something that draws attention using only Cinelerra's resources, I was saddened when I tried to open the file with an animation, very basic, that I made yesterday with sketcher, Cinelerra crashes and from there I do not pass. So the desire to do the header has passed me, because I need to do it at times and in several sessions, but if every time I close the application I can no longer load the project ... given this better throw in the towel than lose the time. I report it because I think it is important for it to be known, but I do not think that many people venture to do these things in Cinelerra, because there are applications like Blender or Natron. So I also don't think it's worth wasting time on this. The problem is that I like to squeeze the applications and I am a perfectionist, which is sometimes a serious defect.
Tagsbug, Crash

Activities

PhyllisSmith

PhyllisSmith

2020-08-14 01:58

manager   ~0003917

This was checked quite well by us and Andrea's valgrind so will close in a couple of days.
RafaMar

RafaMar

2020-07-28 08:14

reporter   ~0003852

Thank you very much, these days I am a little busy, but as soon as I have time I will try it.
Andrea_Paz

Andrea_Paz

2020-07-27 15:42

updater   ~0003850

Here is the valgrind with Sketcher plugin: I put 2 plugins on 2 edits and alternated their work through Draw. No problem for me.

val.tar.gz (14,879 bytes)
PhyllisSmith

PhyllisSmith

2020-07-26 22:44

manager   ~0003842

This has been fixed and checked into GIT. A test version for Mint 19 is at:

   https://cinelerra-gg.org/download/testing/cinelerra-5.1-mint19-x86_64-static.txz

but be aware that there are more than just this fix in this build. This was a major fix and impacted several plugins; the problem was "drag" checked when 2 sketcher windows were active. At least 2 other bugs were found by the programmer when working this code (so this time we found them before Rafa did, wink wink).

The other plugins affected are those that also have a "drag" checkbox which includes: Title, Sketcher, Tracer, Crikey, and Boxblur.
@Andrea_Paz
If you have any spare time, could you run a Valgrind with Sketcher?
RafaMar

RafaMar

2020-07-24 10:52

reporter   ~0003836

Thank you. I know it is not very common to do these things in Cinelerra but I want to make the Cinfinity logo that appears with the sketcher lines. I have it in my head and it will be cool, but I need to be able to close Cinelerra and reload the project. :-)
PhyllisSmith

PhyllisSmith

2020-07-24 01:54

manager   ~0003834

Thanks for the XML file. We have reproduced the problem and a temporary kluge allowed us to see your sketch of the red and green colored ribbon like moving things (pretty cool looking already).

Sketcher was a plugin designed to just do some basics to be useful. Natron and Blender are for serious work. But we can hopefully find a fix.
RafaMar

RafaMar

2020-07-23 21:48

reporter  

BasicProve.xml (8,851 bytes)

Issue History

Date Modified Username Field Change
2020-07-23 21:48 RafaMar New Issue
2020-07-23 21:48 RafaMar Tag Attached: bug
2020-07-23 21:48 RafaMar Tag Attached: Crash
2020-07-23 21:48 RafaMar File Added: BasicProve.xml
2020-07-24 01:54 PhyllisSmith Assigned To => PhyllisSmith
2020-07-24 01:54 PhyllisSmith Status new => confirmed
2020-07-24 01:54 PhyllisSmith Note Added: 0003834
2020-07-24 10:52 RafaMar Note Added: 0003836
2020-07-26 22:44 PhyllisSmith Note Added: 0003842
2020-07-27 15:42 Andrea_Paz File Added: val.tar.gz
2020-07-27 15:42 Andrea_Paz Note Added: 0003850
2020-07-28 08:14 RafaMar Note Added: 0003852
2020-08-14 01:58 PhyllisSmith Status confirmed => resolved
2020-08-14 01:58 PhyllisSmith Resolution open => fixed
2020-08-14 01:58 PhyllisSmith Fixed in Version => 2020-07
2020-08-14 01:58 PhyllisSmith Note Added: 0003917