View Issue Details

IDProjectCategoryView StatusLast Update
0000499Cinelerra-GG[All Projects] Websitepublic2020-09-06 16:52
ReporterAndrew-R Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000499: Provide links to sources of older releases?
DescriptionUser requested this feature in comments at Linux.org.ru

I think links to git snapshots for each version should be enough? They don't take server space and generated on-demand ...
For example 2020-04 = https://git.cinelerra-gg.org/git/?p=goodguy/cinelerra.git;a=snapshot;h=255d67d0fcabfbcd208f2587a9a75697a15d6349;sf=tbz2
Steps To ReproduceLook at https://cinelerra-gg.org/download/pkgs/src/ and you will see only sources for two latest versions there.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2020-09-06 16:52

manager   ~0003999

Will close in a couple of days.
Andrew-R

Andrew-R

2020-09-06 02:19

reporter   ~0003998

Thanks a ton (a gigaton!) - it works!
PhyllisSmith

PhyllisSmith

2020-09-06 01:28

manager   ~0003997

Last edited: 2020-09-06 01:29

View 2 revisions

@Andrew-R
Now if you follow the link on the cinelerra-gg.org website under Downloads to
    https://cinelerra-gg.org/download/pkgs/src/
you should see January through August of the source files.
There is a link that Sam had already set up called "Source code".

PhyllisSmith

PhyllisSmith

2020-09-04 16:08

manager   ~0003985

Andrew-R
We have a plan to put the Src tarballs out there and use the current link. It will only take a few minutes to implement but have to actually find time to do it -- hopefully later today.
Andrew-R

Andrew-R

2020-09-04 03:13

reporter   ~0003982

Also, I lifted content of https://storage.googleapis.com/google-code-archive-source/v2/code.google.com/cinelerra/source-archive.zip to my (external) hdd, basically just early (2015) development of CinGG. Currently https://git.cinelerra-gg.org/git/?p=goodguy/history.git;a=shortlog;pg=5 goes down to 2015-06-17 Good Guy initial commit , but this version from google sources list

commit 3987f8db43a203a34932e418be364844aba2de99
Author: Good1.2Guy <[email protected]>
Date: Thu Jan 22 14:47:34 2015 -0700

    initial commit

as a start. Just few months of work, not sure if anyone want to have those 685135K on server, due to 1) Google source still working and 2) not very high historical demand ....
Found via https://linuxvideoediting.blogspot.com/2018/11/istoriya-razvitiya-cinelerra.html
Andrew-R

Andrew-R

2020-09-03 02:39

reporter   ~0003974

> but how many months worth would you think is sufficient?

Bigger projects tend to keep all their historical tarballs, but they have bigger infrastructure, too.
What about six months (four more than current two)?
PhyllisSmith

PhyllisSmith

2020-09-03 01:47

manager   ~0003973

@Andrew-R
Well, GG has 56 of the last src tarballs since 2016 for a total of 6.5 GB on the computer. He thinks it would be OK to put some of them on the website, but how many months worth would you think is sufficient?
Andrew-R

Andrew-R

2020-09-01 23:45

reporter   ~0003964

is there way to utilize Github releases page ? May be in this case releases will be downloaded from them and not from you. But I'm not sure if you can make releases-from-tags there ....
PhyllisSmith

PhyllisSmith

2020-09-01 23:33

manager   ~0003963

Maybe Sam has a good idea, but we do not keep all of the Source tarballs on the Cinelerra website -- only the last 2 of which each is about 137MB. That amount has to be downloaded and with a slow network takes time. But

If the user has a git repo that they created via:
     git clone git://git.cinelerra-gg.org/goodguy/cinelerra.git my_cin_repo_area
where gg is a subdirectory in their current directory than all they have to do is:
       cd my_cin_repo_area/
       git checkout 2020-04

This saves waiting for the network. We have not been able to come up with a solution that appeals to us.
Andrew-R

Andrew-R

2020-09-01 19:50

reporter   ~0003958

Yes, you can (easily, for me) follow those tags and get tar.gz/bz2 , but user was confused by wget behavior over those links, and they give you exactly snapshot-named tarball, not like officially named ones (cin_5.1.YYYYMMDD-src.tgz).

Lets see if Sam can script something server-side?
PhyllisSmith

PhyllisSmith

2020-09-01 18:10

manager   ~0003955

We started adding a "tag" to all of the releases a year ago to mark the releases per a user request (I think it was for a Sun computer). This provides easy access to the corresponding monthly release. You can see this at:
   https://git.cinelerra-gg.org/git/?p=goodguy/cinelerra.git;a=summary
if you scroll down to under tags as in:

18 hours ago 2020-08 version update tag | commit | shortlog | log
4 weeks ago 2020-07 version update tag | commit | shortlog | log
2 months ago 2020-06 version update tag | commit | shortlog | log
3 months ago 2020-05 version update tag | commit | shortlog | log
4 months ago 2020-04 version update tag | commit | shortlog | log
5 months ago 2020-03 version update tag | commit | shortlog | log
6 months ago 2020-02 version update tag | commit | shortlog | log
7 months ago 2020-01 version update tag | commit | shortlog | log
8 months ago 2019-12 Version update tag | commit | shortlog | log
9 months ago 2019-11 version update tag | commit | shortlog | log
10 months ago 2019-10 version update tag | commit | shortlog | log
11 months ago 2019-09 version update tag | commit | shortlog | log
12 months ago 2019-08 version update tag | commit | shortlog | log

Please let me know if this is sufficient as I think it fulfills the requirements?

Issue History

Date Modified Username Field Change
2020-09-01 12:24 Andrew-R New Issue
2020-09-01 18:04 PhyllisSmith Assigned To => PhyllisSmith
2020-09-01 18:04 PhyllisSmith Status new => assigned
2020-09-01 18:10 PhyllisSmith Note Added: 0003955
2020-09-01 18:10 PhyllisSmith Status assigned => feedback
2020-09-01 19:50 Andrew-R Note Added: 0003958
2020-09-01 19:50 Andrew-R Status feedback => assigned
2020-09-01 23:33 PhyllisSmith Note Added: 0003963
2020-09-01 23:45 Andrew-R Note Added: 0003964
2020-09-03 01:47 PhyllisSmith Note Added: 0003973
2020-09-03 02:39 Andrew-R Note Added: 0003974
2020-09-04 03:13 Andrew-R Note Added: 0003982
2020-09-04 16:08 PhyllisSmith Note Added: 0003985
2020-09-06 01:28 PhyllisSmith Status assigned => confirmed
2020-09-06 01:28 PhyllisSmith Note Added: 0003997
2020-09-06 01:29 PhyllisSmith Note Edited: 0003997 View Revisions
2020-09-06 02:19 Andrew-R Note Added: 0003998
2020-09-06 16:52 PhyllisSmith Status confirmed => resolved
2020-09-06 16:52 PhyllisSmith Resolution open => fixed
2020-09-06 16:52 PhyllisSmith Note Added: 0003999