View Issue Details

IDProjectCategoryView StatusLast Update
0000524Cinelerra-GG[All Projects] Bugpublic2020-11-18 00:26
ReporterPierre Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi7-3770k, 32GB(ram), GTX-750TiOSLinux Mint MateOS Version18.3
Product Version 
Target VersionFixed in Version2020-10 
Summary0000524: Clicking with the middle button on a source file makes CinGG crash.
DescriptionI've had two crashes.


[email protected] ~ $ cin
Cinelerra Infinity - built: Sep 30 2020 12:35:08
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

** segv at 0xc5fcdf in pid 7131, tid 7160
writing debug data to /tmp/cinelerra_7131.dmp
lock_items: 35
lock_frees: 8
** dump complete
Erreur de segmentation (core dumped)
[email protected] ~ $
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2020-11-01 20:23

manager   ~0004340

Marking resolved and will close in a couple of days.
PhyllisSmith

PhyllisSmith

2020-10-09 01:30

manager   ~0004224

Fortunately, the additional 3 dumps were due to the same bug. A fix has been generated and checked into GIT. These 2 fixes will be in the October 31 builds.
Pierre

Pierre

2020-10-08 04:03

updater   ~0004219

@Phyllis

It is not Dump 7160 that I had sent as second Dump, but rather Dump 7131

Here are 3 other dumps if it can be useful.

cinelerra_5264.dmp (151,048 bytes)
cinelerra_7635.dmp (145,761 bytes)
cinelerra_7924.dmp (140,929 bytes)
PhyllisSmith

PhyllisSmith

2020-10-08 03:44

manager   ~0004218

@Pierre
Thanks so much for testing and providing the dumps. It is very much appreciated.
Dump 6819 - crash due to killing Cin while a Transcode was running. GG will add a guard to prevent this problem.
Dump 7160 - crash due to bad vframe (middle mouse button click in Resources window on Media source). This is a a bug and tomorrow gg will add code to check all viewing frame calls.
PhyllisSmith

PhyllisSmith

2020-10-08 00:58

manager   ~0004216

GG will be looking at this yet today -- I moved the dumps to his computer just now.
Pierre

Pierre

2020-10-08 00:39

updater  

cinelerra_6819.dmp (118,985 bytes)
cinelerra_7131.dmp (143,276 bytes)

Issue History

Date Modified Username Field Change
2020-10-08 00:39 Pierre New Issue
2020-10-08 00:39 Pierre File Added: cinelerra_6819.dmp
2020-10-08 00:39 Pierre File Added: cinelerra_7131.dmp
2020-10-08 00:58 PhyllisSmith Assigned To => PhyllisSmith
2020-10-08 00:58 PhyllisSmith Status new => acknowledged
2020-10-08 00:58 PhyllisSmith Note Added: 0004216
2020-10-08 03:44 PhyllisSmith Note Added: 0004218
2020-10-08 04:03 Pierre File Added: cinelerra_5264.dmp
2020-10-08 04:03 Pierre File Added: cinelerra_7635.dmp
2020-10-08 04:03 Pierre File Added: cinelerra_7924.dmp
2020-10-08 04:03 Pierre Note Added: 0004219
2020-10-09 01:30 PhyllisSmith Note Added: 0004224
2020-11-01 20:23 PhyllisSmith Status acknowledged => resolved
2020-11-01 20:23 PhyllisSmith Resolution open => fixed
2020-11-01 20:23 PhyllisSmith Fixed in Version => 2020-10
2020-11-01 20:23 PhyllisSmith Note Added: 0004340
2020-11-18 00:26 PhyllisSmith Status resolved => closed