View Issue Details

IDProjectCategoryView StatusLast Update
0000566Cinelerra-GG[All Projects] Websitepublic2021-09-11 21:30
ReporterThanatermesis Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2020-08 
Target VersionFixed in Version 
Summary0000566: Improved builds of cinelerra-gg & Elive Linux
DescriptionIn order to have a better and improved cinelerra-gg for Elive, I have recently working on making my own builds of cinelerra-gg

The build will automatically update (rebuild) when there's a new tag found on the git of cinelerra-gg, so this will keep cinelerra-gg always very up-to-date to their tagged releases, as we can see at:

> $ apt-cache policy cinelerra-gg
> cinelerra-gg:
> Installed: 1:5.1.202010+git3325029f91-1
> Candidate: 1:5.1.202010+git3325029f91-1

Notes:
 - the package is named cinelerra-gg and not "cin" anymore
 - the version includes the known version (5.1), the tag (202010), and the git commit on which the build is based upon (3325029f91), which is very useful to know the exact version built

May this information can be included in the downloads / distros page for those who wants very up-to-date builds of cinelerra-gg ?

I wonder if those packages can be offered in the downloads page with something like "updated packages provided by Elive Linux" for those who wants an always updated debian-stable build of it, so they can be found from: http://repository.elivecd.org/pool/multimedia/c/cinelerra-gg/ and just installed manually (dpkg -i )
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2021-09-04 21:10

manager   ~0004920

I meant to close this issue earlier but will do so in a couple of days. In rechecking our website I noticed that the download of the HTML manual in one place was not included so I just changed that now. It was in the Debian instructions documentation but not in the Elive Package documentation.
PhyllisSmith

PhyllisSmith

2021-08-13 17:39

manager   ~0004908

@Thanatermesis
Sorry for presenting a problem -- it is just my system that has the problem. It is Buster/Debian 10 BUT not updated at all - just a long ago late Beta version. So I need to get up to date but because that desktop has about 60 partitions on it for various Operating Systems and versions, I do not dare update it. Another single computer can be tried instead if needed later.
Thanatermesis

Thanatermesis

2021-08-13 13:40

reporter   ~0004907

You was not able to install the package?

Mmh, dpkg is a little more tricky than apt, if you install a package with dpkg it may fail due to missing dependencies, if im not wrong, what is needed to do is to run "apt-get -f install" after that and then it will be all correctly installed (that must be verified, and maybe also included in the howto?). Other tools like "gdebi" would do that much more easily (but not everybody has gdebi included in their systems so dpkg should be the more compatible way)

Note that this package is for Debian/Buster (or compatible) systems. Also, debian is going to release the next stable version very soon, I will update cinelerra-gg package for it too but not yet, too many tasks at the moment :)
PhyllisSmith

PhyllisSmith

2021-08-13 02:05

manager   ~0004906

@Thanatermesis
Thanks for pointing out what I forgot to fix and I fixed it several hours ago BUT it may not have propagated yet. It is updated on this laptop and on my Android phone but not on the desktop. Below is the updated last sentence where the last "here" points to the manual url.
***************
For Debian 10 Buster users (or for the current stable Debian release), Elive Linux is generously providing a package build here – just download the .deb file and install via “dpkg -i “. To include access from the program to the Alt/h hotkey help, you will need to also install the manual from here.
***************

I wanted to try the install myself and the dpkg -i blahblah.deb tried to install but I had not updated all of the libraries so did not get far but proved to myself it would work just fine.
Thanatermesis

Thanatermesis

2021-08-12 17:44

reporter   ~0004905

Ah thanks, yes it looks correct :)

By other side I meant more specifically in the instructions on the website, which if im not wrong there's only these ones?: https://www.cinelerra-gg.org/debian-package/
PhyllisSmith

PhyllisSmith

2021-08-12 17:23

manager   ~0004904

@Thanatermesis
I believe that I updated the manual correctly to include all 3 links - O/S, CinGG package, and Manual. You can check:
   https://cinelerra-gg.org/download/CinelerraGG_Manual/Elive.html
to verify. If there is an error or you think the wording should be changed or News updated, please let me know. Otherwise, I will close this BT in a couple of days.

Later today I am going to try to make sure an "inexpert user" (that's me!) can follow the instructions.
Thanks again.
Thanatermesis

Thanatermesis

2021-08-12 16:01

reporter   ~0004903

The new builds includes the -manual (extra) package, but as how the repositories works they are in a different directory, so for the instructions pages to install for Debian/Buster, it can be referenced to also install the extra package -manual to increase the functionality of cinelerra-gg (including the manual and also the Alt+h hotkey functionality). The link for it is exactly this one: http://repository.elivecd.org/pool/multimedia/c/cinelerra-gg-manual/
sge

sge

2021-07-08 16:32

reporter   ~0004885

@Thanatermesis
Glossary.html will be generated after you have upgraded latex2html to V2021.2. The older version simply does not support glossary yet.
But CGG context help works without Glossary exactly well. Congratulations!
Thanatermesis

Thanatermesis

2021-07-08 15:50

reporter   ~0004884

@sge: all your notes added in the build, by removing these "dvipng" and similar options the build was correct, I added all those commands you said, the generated files has real names now (not node-something), I only see that the "glossary.html" file is not generated, also the version of latex2html cannot be updated at the moment since depends on debian-stable version

final result: everything seems to work pretty well, alt+h works without issues too
sge

sge

2021-07-08 10:05

reporter   ~0004883

@Thanatermesis
Cannot find file "/tmp/l2h25707/image183.ps" sounds bad.
Try to use instead of '-use_dvipng -image_type png' the other options '-nouse_dvipng -image_type gif', then latex2html will give some more diagnostics.

To successfully translate CGG manual into html, you must have the following:
pdflatex
gs
netpbm
If any of these packages are missing, no chance to get the manual translated.

Then, latex2html itself must be at least version 2021.2, or taken from git master branch.

Then, after you fetch the latex sources of CGG manual from git, you find the file latex2html-init there. This file must be renamed (or copied) into .latex2html-init (starting with dot). If this is not done, translation cannot be successful.

Then, before running latex2html, you have to run pdflatex (3 times) and makeindex (3 times, twice for Index and once for Glossary). Only then you can begin with latex2html itself.

In the sources of CGG manual you find the shell script 'translate_manual'. Look into it, it is a working script to produce translation. You can adapt it to your installation or use as hints how the necessary command sequence should be.

You are right trying to setup translation yourself, and it will remain easy and robust as soon as you get it once set up and working.
Thanatermesis

Thanatermesis

2021-07-08 01:20

reporter   ~0004882

I tried building it with this command:

> latex2html -html_version 4.0,math -use_pdftex -use_dvipng -long_titles 5 -image_type png -nofootnode -split +3 -link 3 -bottom_navigation -local_icons -t 'CinelerraGG_Manual' CinelerraGG_Manual.tex

But then I got errors like this:

> Error: Cannot read 'img182.png': No such file or directory
> Converting image 0000183
> pstoimg: Error: Cannot find file "/tmp/l2h25707/image183.ps": No such file or directory
sge

sge

2021-07-07 17:43

reporter   ~0004881

@Thanatermesis
If you build html manual yourself:
1) You have to use at least latex2html version 2021.2 (released Yul 1, 2021), or the version from git of latex2html. Older latex2html does not have some features which are necessary to get CGG manual translated consistently.
2) To build that kind of CGG html manual which is expected by CGG context help (and which actually works with CGG context help), you have to use the corresponding set of options given to latex2html. For example, without options you get HTML files named 'node1.html', 'node2.html', etc. You will get neither Contents.html nor Index.html. To get them, you have to give the option '-long_titles 5' or something like this. Otherwise, if you insist on having 'node1.html', 'node2.html', etc. then you have to change the 'doc/ContextManual.pl' script to use 'node9.html' (or which number it actually has) instead of Context.html etc.
Please look the description of BT568 with the notes therein, there is much information on the art of translation of the CGG manual suitable for context help.
Thanatermesis

Thanatermesis

2021-07-07 04:29

reporter   ~0004880

yes I build it myself from git to a package, too difficult to do it from the tgz and automatically keep it updated

basically it only runs latex2html, and copy the "images/*" contents to the same target dir
sge

sge

2021-07-05 16:38

reporter   ~0004879

@Thanatermesis
There is Contents.html in both HTML_Manual-20210531.tgz and HTML_Manual-20210630.tgz.
But if you try to build HTML manual by yourself, ans miss some needed latex2html options, then you can easily end up with files named 'node<ddd>.html' instead of that names which were intended for context help. If you really build the manual by yourself, take a look on the translate_manual script inside the git distribution of the manual. Moreover, you have to install latex2html from its git master branch as the latest latex2html release does not yet have all the features necessary for the correct translation of the manual.
PhyllisSmith

PhyllisSmith

2021-07-03 17:38

manager   ~0004877

@Thanatermesis
Thank you very much. I will look into the Contents.html problem -- I am sure it is my mistake.
Thanatermesis

Thanatermesis

2021-07-03 16:59

reporter   ~0004876

The .deb packages are updated, available from the Elive repo, and also it has been included AND implemented the Alt + h feature, in case to use it the user must install the extra package too, from:

http://repository.elivecd.org/pool/multimedia/c/cinelerra-gg-manual/

BUG REPORT: the Contents.html file is not generated automatically, I needed to copy the node9.html file to Contents.html in order to make it work, so the build system for the manual pakcage must generate / copy the needed file to a file called Contents.html (required for cinelerra alt + h to work), I'm not sure if there's other files needed to be generated too
PhyllisSmith

PhyllisSmith

2021-06-15 22:43

manager   ~0004824

About the Bug Tracker, Sam reminded me again (why can't I remember this)
" when logging into the bugtracker the option "only allow with this IP address" has activated. This option needs to be disabled, then the bug tracker will work fine"
PhyllisSmith

PhyllisSmith

2021-06-15 18:45

manager   ~0004822

@Thanatermesis
OK, I am a bozo ! It is a lot of work to generate the HTML manual as there is a procedure to first create a PDF version and then create the HTML version. That is why we created the .tgz file which has all of the html files already created.

  https://cinelerra-gg.org/download/images/HTML_Manual-20210531.tgz

You asked about the manual GIT so I just responded without thinking. You can create the HTML files yourself but it is way too much work and you have to install latex2html + ... The GIT repository does contain the file "translate_manual" which is how the PDF/HTML manual gets created if you are adamant about doing that.
Thanatermesis

Thanatermesis

2021-06-15 18:34

reporter   ~0004821

@PhyllisSmith: I downloaded the git from: git://git.cinelerra-gg.org/goodguy/cin-manual-latex.git , with the README documentation it generates the documentation but I don't see any .html file generated

how I should compile it and which files are meant to be included in the OS in order to have alt+h working?
Andrea_Paz

Andrea_Paz

2021-06-15 18:14

manager   ~0004820

@Thanatermesis
I'm sorry but Chrome is not present in my Arch Linux: neither in the official repositories nor in the AUR. Only Chromium is available.

Lately there have been reported problems with MantisBT and the Forum.
Thanatermesis

Thanatermesis

2021-06-15 16:23

reporter   ~0004819

> No problem fron an android tablet with Chrome!

try in a desktop linux system with the official last chrome version, you should see the bug imho (unless its an extension issue on my side)

also the creation of New issue (from firefox, so not a chrome-specific issue for that) seems to have failed when I tried it
Andrea_Paz

Andrea_Paz

2021-06-15 16:09

manager   ~0004818

Last edited: 2021-06-15 16:11

View 2 revisions

test
No problem fron an android tablet with Chrome!

PhyllisSmith

PhyllisSmith

2021-06-15 15:38

manager   ~0004816

@Thanatermesis
I will ask Sam about a potential issue with BTS and see if Andrea has time to confirm.

@Andrea_Paz
I do not know if you can confirm the following? only if you have time though.

@administrator
About: "BTS important issue: Seems like the BTS has issues, I was unable to enter in this issue ID using chrome (firefox worked) but then I tried to report the website issue and seems like it was unable to create a new report issue (and then I lost my full new report by having not created the issue), hum! "
PhyllisSmith

PhyllisSmith

2021-06-15 15:31

manager   ~0004815

Last edited: 2021-06-15 15:41

View 2 revisions

@Thanatermesis
The Debian users really appreciate the package you create and I think they realize that it will be there when it becomes updated/available.

The GIT remote for the html manual is: https://git.cinelerra-gg.org/git/?p=goodguy/cin-manual-latex.git;a=summary
and you will see the same 2021-05 update TAG. I do not know anything about packaging or how that would work for the Alt/h hotkey connection where the html manual is expected to be in the {cinelerra package}/doc directory for access. (BT 0000568 has a lot of details on the Alt/h hotkey implementation and how to put it together, but it is way more information then you would need).

Thanatermesis

Thanatermesis

2021-06-15 14:25

reporter   ~0004814

BTS important issue: Seems like the BTS has issues, I was unable to enter in this issue ID using chrome (firefox worked) but then I tried to report the website issue and seems like it was unable to create a new report issue (and then I lost my full new report by having not created the issue), hum!
Thanatermesis

Thanatermesis

2021-06-15 14:19

reporter   ~0004813

Yeah, the builds are not guaranteed to be realtime (it can take maybe 1 week to be triggered in the build system) but yesterday I just noticed that cinelerra-gg was updating :)

Oh, hum... can you tell me the GIT remote for that documentaion? I think I should include a separate package for it then
PhyllisSmith

PhyllisSmith

2021-06-15 13:24

manager   ~0004812

@Thanatermesis
Thank you for providing the Debian package. A user was just asking about it yesterday and I see it is there now and dated 14-Jun-2021.

I have to apologize for not letting you know sooner, BUT Georgy added a Alt/h hotkey feature that uses an HTML version of the manual to provide easily accessed help on the user's local browser. Because the manual has its own GIT repository and it is big and would overwhelm the source code GIT, it is separate. Therefore to include the HTML manual in your package build, you would have to also download a TAG marked correspondingly dated tgz file containing the manual and unpack it to where the Cinelerra source files exist under {directory}/bin/doc.
 
The file to download is at: https://cinelerra-gg.org/download/images/HTML_Manual-20210531.tgz
The version that matches the TAG of the source code GIT will have the same release date (and there is a TAG in the manual's source GIT too matching that of the source code).

Sorry for the delay and it is NOT mandatory that the user have the Alt/h hotkey as they already have easy access to the manual via our website. If you have problems with implementation or understanding my blurb, please let use know.
PhyllisSmith

PhyllisSmith

2021-04-01 01:39

manager   ~0004698

@Thanatermesis
If you think the wording needs to be changed in any of the updated web pages, just let me know.

- page Download Distros with Cinelerra https://www.cinelerra-gg.org/downloads/#av-linux
- page Download Packages, Debian https://www.cinelerra-gg.org/debian-package/
- page Current News https://www.cinelerra-gg.org/news-updates/release-dated-03-31-2021-appimage-is-now-available/

Otherwise, I will assume it is OK and mark this Resolved and Closed in a couple of days after you get a chance to do the build.
And THANK YOU VERY MUCH !!
PhyllisSmith

PhyllisSmith

2021-03-31 19:16

manager   ~0004697

Thanks for the additional response.
I have created a new release so there is a new TAG now. Will be updating news and the download page information per your recommendation by the end of the day here in the U.S. (so it may be a few hours yet).
Thanatermesis

Thanatermesis

2021-03-25 17:37

reporter   ~0004696

Yeah exactly, the user only needs to download the .deb file and "dpkg -i " it (there's also some automated gui tools on desktop like gdebi that installs the package by double-clicking on it, but dpkg -i should be enough), I didn't tried so maybe there's a dependency problem after to install it ("apt-get -f install" should probably solve it by installing the missing packages)

Or by using the last beta versions of Elive there will always be the last version available

About the version, yeah it can be easily viewed from the URL which version is builted from (as said, the build will be automatically updated after a few days of the published tag release)

Yeah anybody can use the package for debian-stable like / compatible systems, good for devs or to provide alternatives to snap packages (also in a more compatible and reliable way for deb systems)
PhyllisSmith

PhyllisSmith

2021-03-25 17:22

manager   ~0004695

Last edited: 2021-03-25 17:23

View 2 revisions

That is GREAT that you are doing cinelerra-gg builds for Debian-stable / Elive.
There is a plan for a new release at the end of this month, March 31 so that will be the next Tag created.
I am fumbling here some, but I think I understand mostly what you are saying.
YES ! information can be included in the Debian (& Elive) downloads / distros page for those who want very up-to-date builds starting at the end of March (really will be April 1).
This would be a BIG help to us as otherwise we are only providing an AppImage now and no packages/tars. Many users prefer installing via the package system.

The only thing I do not fully understand, and probably do not have to in order to update the download page at that time, is whether or not I will have to provide information about the changed/new package name/version.git commit as outlined in your Notes above. BUT I assume that your url site reference will take care of this and all the user has to know is to do: dpkg -i ?

Issue History

Date Modified Username Field Change
2021-03-25 16:54 Thanatermesis New Issue
2021-03-25 17:22 PhyllisSmith Assigned To => PhyllisSmith
2021-03-25 17:22 PhyllisSmith Status new => acknowledged
2021-03-25 17:22 PhyllisSmith Note Added: 0004695
2021-03-25 17:23 PhyllisSmith Note Edited: 0004695 View Revisions
2021-03-25 17:37 Thanatermesis Note Added: 0004696
2021-03-31 19:16 PhyllisSmith Note Added: 0004697
2021-04-01 01:39 PhyllisSmith Note Added: 0004698
2021-06-15 13:24 PhyllisSmith Note Added: 0004812
2021-06-15 14:19 Thanatermesis Note Added: 0004813
2021-06-15 14:25 Thanatermesis Note Added: 0004814
2021-06-15 15:31 PhyllisSmith Note Added: 0004815
2021-06-15 15:38 PhyllisSmith Note Added: 0004816
2021-06-15 15:41 PhyllisSmith Note Edited: 0004815 View Revisions
2021-06-15 16:09 Andrea_Paz Note Added: 0004818
2021-06-15 16:11 Andrea_Paz Note Edited: 0004818 View Revisions
2021-06-15 16:23 Thanatermesis Note Added: 0004819
2021-06-15 18:14 Andrea_Paz Note Added: 0004820
2021-06-15 18:34 Thanatermesis Note Added: 0004821
2021-06-15 18:45 PhyllisSmith Note Added: 0004822
2021-06-15 22:43 PhyllisSmith Note Added: 0004824
2021-07-03 16:59 Thanatermesis Note Added: 0004876
2021-07-03 17:38 PhyllisSmith Note Added: 0004877
2021-07-05 16:38 sge Note Added: 0004879
2021-07-07 04:29 Thanatermesis Note Added: 0004880
2021-07-07 17:43 sge Note Added: 0004881
2021-07-08 01:20 Thanatermesis Note Added: 0004882
2021-07-08 10:05 sge Note Added: 0004883
2021-07-08 15:50 Thanatermesis Note Added: 0004884
2021-07-08 16:32 sge Note Added: 0004885
2021-08-12 16:01 Thanatermesis Note Added: 0004903
2021-08-12 17:23 PhyllisSmith Note Added: 0004904
2021-08-12 17:44 Thanatermesis Note Added: 0004905
2021-08-13 02:05 PhyllisSmith Note Added: 0004906
2021-08-13 13:40 Thanatermesis Note Added: 0004907
2021-08-13 17:39 PhyllisSmith Note Added: 0004908
2021-09-04 21:10 PhyllisSmith Note Added: 0004920
2021-09-11 21:30 PhyllisSmith Status acknowledged => closed
2021-09-11 21:30 PhyllisSmith Resolution open => fixed