View Issue Details

IDProjectCategoryView StatusLast Update
0000070Cinelerra-GG[All Projects] Featurepublic2019-05-03 16:57
ReporterSamAssigned Togoodguy 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2018-11 
Target VersionFixed in Version2019-03 
Summary0000070: Ressource window: thumbnail preview
DescriptionUnfortunately, my second computer does not have as much power as the other one. On this computer I always have to deactivate the preview videos in the resource window, otherwise the computer gets too slow. Would it be possible to enable a third setting in the Media tab?

Currently we have the following:

Preview active: thumbnails animated & mouse over = 5 seconds preview video
Preview disabled : thumbnail not animated & mouse over = nothing happens

My suggestion
Third preview option: thumbnail not animated & mouse over = 5 seconds preview video
TagsResources window

Activities

PhyllisSmith

PhyllisSmith

2019-05-03 16:57

manager   ~0001478

I reread the notes to make sure the expected implementation was complete and I didn't miss IgorB "sneaking" in another suggestion. I think it is. If I missed something, a new issue can be opened.
PhyllisSmith

PhyllisSmith

2019-03-14 22:54

manager   ~0001207

It looks pretty good now with pretty much all suggestions implemented. Will update documentation.
Sam

Sam

2019-03-13 16:41

administrator   ~0001200

The problem's gone, really weird. Today I compiled the newest version and everything works again.
IgorBeg

IgorBeg

2019-03-13 13:41

reporter   ~0001189

Sam's issue about "Drag&Drop for Resources to UserFolder", I don't see.
I tested it in all 4 (x2) Preview modes (with/without block modes= LineOverText ): Full Play, Mouse Over, Src Traget, No Play. Maybe Sam used a different workflow.
PhyllisSmith

PhyllisSmith

2019-03-13 02:32

manager   ~0001188

The latest builds for Mint and Ubuntu in download/testing include the cleanup of Preview.
I am still unable to duplicate the drag and drop into a user failure as reported by Sam. IgorB could you?
PhyllisSmith

PhyllisSmith

2019-03-11 20:18

manager   ~0001182

Who would have thought such a small change could cause so many problems? Anyway, thanks for the feedback. Changes were checked into GIT but no builds done until other fixes are ready.

Now when you use the MMB with the line strike through, it should be the equivalent of "No Play" with "No Popup". Src Target will look different now. There was no alpha available for the lettering so that is why a line was used instead of opacity, which would have looked a little nicer.

A problem was found with pulldown sizing and that is why the zoombar and XYZ box became incorrectly sized. A fix was put in but gg is still working on it because he found another problem.

SAM: We did a basic drag and drop into a user media folder and user clip folder and it worked at least once but I will figure out what is wrong next.
Sam

Sam

2019-03-11 20:03

administrator   ~0001181

@PhyllisSmith
I saw that there was a new update and compiled Cin new. The media drag and drop into the user folder doesn't work anymore. The user folder remains empty.
IgorBeg

IgorBeg

2019-03-11 14:41

reporter   ~0001180

Sam, I agree with you about MMB (Middle Mouse Button) and the new users, but consider that Cinelerra is a ProSumer (Professional - Consumer) software and then, like You and me, new user have to read the Manuals and eventually to ask to you (community).
I remember the first time I asked to Cinelerra-CV community some questions, Phyllis and Sam (you), kindly answered to me [the first contact]. ;-)

Sam: "By the way, the colored squares of the XYZ lines are no longer displayed at the bottom. "
Maybe is it child of PullDownMenu-Arrow.png #0001176 ?
Sam

Sam

2019-03-11 14:07

administrator   ~0001179

The problem I see is that when you drag a thumbnail/file from the media tab to a user tab, sometimes the preview in the media tab is still played, so you always have to toggle and activate "No play" so that the playback of the preview is not started. It would be better, if a file is dragged, then the preview is generally prevented. So the user doesn't get the problem that the preview is still played while dragging the thumbnail.

You are right, logically it makes more sense to have only three options. I agreed with you on this point. However, I'm afraid that new users won't know the option, that they can activate it with the middle mouse button. For this reason it would probably be better to leave this option in. This way they know that they can also activate it via the menu and not only via the middle mouse button. Some of the new users do not read the manual. If the four options menu is kept, it makes no sense to cross out "No Play", it only makes sense with the other three options.

I agree with you that my version with the darker text is more appealing, but I don't know how they used the crossed out version to make it more visible for people who can't see color differences so well. For people who can't see so well, the current display is better, but for aesthetic reasons I don't like this version.

By the way, the colored squares of the XYZ lines are no longer displayed at the bottom.
IgorBeg

IgorBeg

2019-03-11 13:11

reporter   ~0001176

1) A+++
2) IMHO the fourth option, NO Play, could be deleted. I try to explain why.
The “Mouse over” option play only one thumbnail, and save cpu consumes.
The “Src Target” option is always “NO Play” mode, and save a lot of cpu consumes.
I would suggest that the MMB function pressed on PullDown menu was used for “No Play” and “NO PopUp preview”, so it substitute the old icon preview use (one click). PopUp Preview disturb the users when them drag&drop from Resources to the Viewer or to the UserFolder, I think.
More, change the new line over the text of the PullDown menu with a different opacity of the text (about 40% ?), as Sam showed well (0001158 Preview.png), if possible. So, when the text is less visible means that the PlayAll/MouseOver/SrcTarget is disabled.
Finally if three option there are, the name “SrcTarget” should be changed to “No Play” because it doesn’t play the thumbnail and all of three option have LMB and RMB to show Preview and InterView function.
Sorry for all these my considerations.

Probably OT (maybe it is child of new PullDown menu):
In SUV theme, the arrow of the PullDown menu is not inside its border. It was aesthetically better before.
Added screenshot (montage)

PullDownMenu-Arrow.png (26,469 bytes)
PullDownMenu-Arrow.png (26,469 bytes)
Pierre

Pierre

2019-03-11 13:07

updater   ~0001174

Sorry, I forgot to translate:

I see no difference in the use of this particular mode compared to the normal operation of "Src Target".
Pierre

Pierre

2019-03-11 13:05

updater   ~0001173

Everything is working well as described.

But what's the point of: "if you use the middle mouse button (only choice available) it will draw a line through the current option and be in "no play" mode - this particular "no play" mode still allows for a pop so you can enlarge the image" ?

Je ne vois aucune différence à l'usage de ce mode particulier comparé au fonctionnement normal de "Src Target".
PhyllisSmith

PhyllisSmith

2019-03-11 04:06

manager   ~0001168

Pierre: the Src Target size change and fullscreen has been fixed.

New stuff:
 1 the name of the currently set option is in the button instead of the word Preview
 2 if you use the middle mouse button (only choice available) it will draw a line through the current option and be in "no play" mode - this particular "no play" mode still allows for a pop so you can enlarge the image
New builds:
  https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz
  https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-mint18-x86_64-static.txz
PhyllisSmith

PhyllisSmith

2019-03-10 16:35

manager   ~0001164

Fixing the "Src Target" mode for size change and fullscreen mode will be done first. These functioning was dependent on the animation so accidentally got dropped on the second round when no animation for just Src Target.

Then will be looking at the code for the toggle button mode as Sam illustrated. But the code is going to dictate which click would toggle on/off. I would like the current left click to continue to do the pulldown/popup mode for consistency and to me it is more comfortable.
IgorBeg

IgorBeg

2019-03-10 16:20

reporter   ~0001163

Waiting for Pierre, GG/Phyllis, (and others), handshake with you (Sam). ;-)
Sam

Sam

2019-03-10 16:20

administrator   ~0001162

I just noticed that the button next to it would have behaved differently. One button would open the menu with a left click and the other with a right click. I have no idea how to standardise it so that the users are not confused. Maybe Phyllis/GG can come up with a solution.
Sam

Sam

2019-03-10 16:08

administrator   ~0001161

Sounds good, I agree with you.
IgorBeg

IgorBeg

2019-03-10 15:48

reporter   ~0001159

I understand you. I agree with you for a part.
Usually the RMB (Right Mouse Button) is used for special menu, then your suggestion with only "Preview" button may be inverted:
- RMB open the menu with three option: Full Play, Mouse Over, Src Target. And you select ones of the three mode.
- LMB (Left Mouse Button) enable/disable the options; then when text Preview is darker = "No Play"
Sam

Sam

2019-03-10 15:19

administrator   ~0001158

Here the picture

Preview.png (75,155 bytes)
Preview.png (75,155 bytes)
Sam

Sam

2019-03-10 15:18

administrator   ~0001157

That is indeed a good point. Thank you for the more detailed explanation. I have an alternative so that you can go back and forth quickly. I'm working on the Cinfinity Design and have been involved with the design of the other professional video editing programs for a long time. There it is now standard to hide or darken unused functions so that you can see that the feature is not active. I made a photomontage of it. To activate the feature you only need a right click on this button.

As an example:
The option "Mouse over" is active. Right click on this button deactivates "Mouse over" and activates "No Play", the button "Preview" is darker, more precisely the text "Preview" is darker.
Another right click activates the "Mouse over" option again. This allows you to switch faster and with one click.

It has the advantage that you have a large button "Preview" compared to the smaller previous button. One button shows the state of the option instead of having two buttons. This makes it look tidier.
We would also adapt the design to the new standards. Everything looks clearer and tidier without having too many buttons. My goal is to make Cinelerra look clearer and tidier. Less is sometimes more. With my suggestion we achieve both goals, you get your feature and I get that we have fewer buttons and adapt a bit to the more modern design.
IgorBeg

IgorBeg

2019-03-10 14:28

reporter   ~0001154

I confirm what Pierre said:
"Src Target mode: But zooming the size of the source usage display windows (by the mouse wheel) does not work in this mode"

@Sam
I agree about the old icon, I don't like it.
I try to explain better my suggestion about "preview icon + DropDownMenu":
1) when I have Drag and Drop a clip from Resources to Viewer, the preview window is always open.
2) when I have Drag&Drop a clip from Resources/Media to Resources/newUserFolder, the preview window is always open.
3) to select more thumbnails I have to be in "No Play" mode to see better what I select in Resources/Media, else the preview window is always open.
Then if the preview icon there is, I (we) can disable all the modes with only one click. Faster.

Note: I like the two mode: "Mouse Over" and "Src Target"
Pierre

Pierre

2019-03-10 13:40

updater   ~0001152

Full Play" mode: I notice that the thumbnails are animated at the opening but that once a mouse over is made and removed from the source area, the animation of the thumnails stops and only returns at the moment of a mouse over.
I don't use this "Full Play" mode, so I leave this evaluation to Sam.

Mouse Over mode: The problem of animating the thumnails when opening is fixed and for the rest this mode works well, as expected.

Src target" mode: As for the corrections made to the mouse over which is now activated and deactivated by clicking on a thumbnail, it's perfect.
 
But zooming the size of the source usage display windows (by the mouse wheel) does not work in this mode, nor does its full screen mode by the "f" key which gives nothing... This is a big problem, these functions are very useful.

IgorBeg, I agree with your proposals for the preview menu and icon.
Sam

Sam

2019-03-10 13:29

administrator   ~0001151

As a designer I wasn't a fan of this icon before because it doesn't look good. I found this icon in the wrong place. I personally think the current solution is better because it is simple and I only have one button than in your example two. I'm a friend of keeping things simple. With this one menu I have all the options available, with the two interaction options ergo button and menu I make the whole thing again a bit more complicated. It's just my personal point of view and sense of taste.
IgorBeg

IgorBeg

2019-03-10 12:00

reporter   ~0001149

Waiting for Pierre,... for me it is perfect (and, as always thanks for the build).
I would like to suggest a "small" change, if possible and if Sam, Pierre, and others, agree with me.
I have done an animated gif to explain it.
- Add the old preview icon to enable/disable the feature: Full Play, Mouse Over, Src Target
- Of course "No Play" option (that has been erased from Preview menu) works when the old preview icon is disabled
- If possible, the "Preview" text is replaced by the name of the active option (in animated gif I have not change it)

So Enable and Disable that tool is faster, I think.

PhyllisSmith

PhyllisSmith

2019-03-10 04:21

manager   ~0001148

Thanks to all people providing feedback. An update to change for the suggestions has been checked in.
   https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-mint18-x86_64-static.txz
  https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

1 - Pierre pointed out that when you go to "mouse over" the animation does not stop until you click. Now fixed.
2 - Src target mode works like "mouse over" as you just go from one to the other after the single initial click.
3 - Added advantage in "full play" mode, if you start with using "src target", it continues to use that. If you want to switch to "mouse over", click and start that instead.
Pierre

Pierre

2019-03-09 22:12

updater   ~0001143

There could be a first click on a thumbnail that activates the mouse over the media file mode, and by a second click on a thumbnail, disables the mouse over the media file mode.
Pierre

Pierre

2019-03-09 22:01

updater   ~0001142

IgorBeg

You are right: "Src Target" as it is does not quite correspond to what I wanted.

My idea was to eliminate all animation from the thumbnails as well as the 5 seconds of video preview when mouse over the media file.

Currently, it is necessary to click individually on each thumbnail to bring up the source target window and click again to close this window.

Windows do not open by simply mouse over the media file. This is a problem, I would prefer that the mouse over the media file works to automatically open and close source target windows without, however, any thumbnail animation and without the 5 seconds of video preview.
IgorBeg

IgorBeg

2019-03-09 21:00

reporter   ~0001138

Sorry, I have explained myself bad.
"Mouse over" option it's okay, like you had requested and explained well.
My doubt is for "Src Target" option. Clicking over a thumbnail, it open the larger preview; moving the mouse pointer over another thumbnail not open the larger preview of that next thumbnail. It works only on that thumbnail.
I thought that it worked like "Mouse over" but without any animation, only static images for thumbnail and the larger preview. So we had not click one time to open the preview and click again to close the preview.
Maybe Pierre wanted that it worked as it is now; I don't know.
Sam

Sam

2019-03-09 20:14

administrator   ~0001137

in "3 Src Target - Pierre suggestion" mode (now "src static" mode), is it right that only clicking over the thumbnail (LMB or MMB) the preview (or Inter-View) is open, and then I have to click out to close the preview?
-> Yes, you are right.

At the beginning, I thought Pierre ( 0000271 ) means it works like Sam's suggestion (now "Mouse Over" option) but all static thumbnail/preview/InterView but moving mouse pointer over a thumbnail, it change its static preview. I am wrong?
-> I'm not sure what you mean by that. But you have to move the mouse over a thumbnail to start the preview. No clicking is required. All thumbnails are not animated, only the one thumbnail that you touch with the mouse is animated. Touching also opens the larger preview.
IgorBeg

IgorBeg

2019-03-09 17:22

reporter   ~0001133

I just tried the new feature with Ubuntu 16 build dated (2019-03-09), and thanks for it. Very good.

Only a question:
in "3 Src Target - Pierre suggestion" mode (now "src static" mode), is it right that only clicking over the thumbnail (LMB or MMB) the preview (or Inter-View) is open, and then I have to click out to close the preview?
At the beginning, I thought Pierre ( 0000271 ) means it works like Sam's suggestion (now "Mouse Over" option) but all static thumbnail/preview/InterView but moving mouse pointer over a thumbnail, it change its static preview. I am wrong?
PhyllisSmith

PhyllisSmith

2019-03-09 03:50

manager   ~0001121

He sees what you have confirmed and he will look into this tomorrow.
PhyllisSmith

PhyllisSmith

2019-03-09 03:42

manager   ~0001119

OK, I will have gg test. It is probably an "edge" case so thanks for confirming as I was not sure if we had explained the 4 options correctly.
Pierre

Pierre

2019-03-09 03:29

updater   ~0001117

I confirm what I described earlier;
If I open a project containing 70 media sources in "Mouse Over" mode, all thumbnails are animated at the same time, they only stop their animation if I move the mouse (which was in another screen at the time of opening) over one of them.
PhyllisSmith

PhyllisSmith

2019-03-09 02:59

manager   ~0001115

In Full Play, ALL of the media in the Resources window is constantly playing when your mouse is in the Resources window.
In Mouse Over, only the 1 media in the Resources window plays when the mouse is over it. You have to click outside a media to stop.
Unless maybe Mint is different than Fedora? Could you load multiple in the Resources window and check to see if this agrees?
Pierre

Pierre

2019-03-09 01:08

updater   ~0001114

Precision.... Under "Mouse over" the thumbnails are animated when Cin-GG opens. It's only when I pass the mouse over that the thumbnails stop animating.
Pierre

Pierre

2019-03-09 01:00

updater   ~0001113

With today's version "Src Target" works well as described.

But I don't see any difference between "Full Play" and "Mouse over":

Under "Mouse over", the thumbnails are also animated and mouse over = 5 seconds preview video.
Sam

Sam

2019-03-08 23:38

administrator   ~0001111

I just tested it and it works very well. Many thanks for the improvement! You are great!
PhyllisSmith

PhyllisSmith

2019-03-08 22:12

manager   ~0001107

Last edited: 2019-03-08 23:34

View 3 revisions

There are now 4 options to satisfy just about everyone. We did not do very thorough testing due to time constraints.

1 Full Play - default and same as it was
2 Mouse over - Sam suggestion to only preview when mouse over the media file
3 Src Target - Pierre suggestion (and my personal favorite) to only bring up the source target window for using Inter-View mode work
4 No Play - same as it was

There will be a Mint 18 and Ubuntu 16 builds for you to download in a couple of hours or so in the usual place.

https://cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz
https://cinelerra-gg.org/download/testing/cinelerra-5.1-mint18-x86_64-static.txz

IgorBeg

IgorBeg

2018-12-19 12:48

reporter   ~0000277

For my old PC would be better the Pierre' suggestion. Indeed, the first action I do, before loading a project is to disable the "preview". When the project is loading, Cin-gg have to draw the thumbnails on timeline and the PC's CPU goes to the stars. If the "preview" is enabled my old PC says to me: where do you want to go today? ;-)
Pierre

Pierre

2018-12-18 14:39

updater   ~0000271

Hi Sam.

I agree with your observation that the "preview" option creates a slowdown when there are many files in the resources.

I would even propose a fourth option: thumbnail not animated and no 5 seconds preview video ever, but the possibility of still having the display of "source targets" (the new functions).

Pierre
Sam

Sam

2018-12-18 13:22

administrator   ~0000270

The idea is to save some performance with it, if my idea would bring anything at all. I have no idea if it is so, only GG can say it. I just noticed that scrolling is much more difficult with the Media tab or Proxy tab when the thumbnails are animated, although I have it at very low settings. I have a lot of files in the Media tab and also in the Proxy tab, some projects have several hundred files. As soon as I deactivate the animation, I can scroll through more smoothly, but then I miss the great video preview function.
IgorBeg

IgorBeg

2018-12-18 11:16

reporter   ~0000268

On my very old computer I have to use proxy and, on Resources-> Proxy, I can see the preview well.
Maybe you have to use Media and not proxy for your reasons.

Issue History

Date Modified Username Field Change
2018-12-18 10:38 Sam New Issue
2018-12-18 10:39 Sam Tag Attached: Resources window
2018-12-18 11:16 IgorBeg Note Added: 0000268
2018-12-18 13:22 Sam Note Added: 0000270
2018-12-18 14:39 Pierre Note Added: 0000271
2018-12-19 12:48 IgorBeg Note Added: 0000277
2019-03-08 22:08 PhyllisSmith Assigned To => goodguy
2019-03-08 22:08 PhyllisSmith Status new => assigned
2019-03-08 22:12 PhyllisSmith Status assigned => feedback
2019-03-08 22:12 PhyllisSmith Note Added: 0001107
2019-03-08 23:11 PhyllisSmith Note Edited: 0001107 View Revisions
2019-03-08 23:34 PhyllisSmith Note Edited: 0001107 View Revisions
2019-03-08 23:38 Sam Note Added: 0001111
2019-03-08 23:38 Sam Status feedback => assigned
2019-03-09 01:00 Pierre Note Added: 0001113
2019-03-09 01:08 Pierre Note Added: 0001114
2019-03-09 02:59 PhyllisSmith Note Added: 0001115
2019-03-09 03:29 Pierre Note Added: 0001117
2019-03-09 03:42 PhyllisSmith Note Added: 0001119
2019-03-09 03:50 PhyllisSmith Status assigned => confirmed
2019-03-09 03:50 PhyllisSmith Note Added: 0001121
2019-03-09 17:22 IgorBeg Note Added: 0001133
2019-03-09 20:14 Sam Note Added: 0001137
2019-03-09 21:00 IgorBeg Note Added: 0001138
2019-03-09 22:01 Pierre Note Added: 0001142
2019-03-09 22:12 Pierre Note Added: 0001143
2019-03-10 04:21 PhyllisSmith Note Added: 0001148
2019-03-10 12:00 IgorBeg File Added: Resources_PreviewBtnMenu_animation.gif
2019-03-10 12:00 IgorBeg Note Added: 0001149
2019-03-10 13:29 Sam Note Added: 0001151
2019-03-10 13:40 Pierre Note Added: 0001152
2019-03-10 14:28 IgorBeg Note Added: 0001154
2019-03-10 15:18 Sam Note Added: 0001157
2019-03-10 15:19 Sam File Added: Preview.png
2019-03-10 15:19 Sam Note Added: 0001158
2019-03-10 15:48 IgorBeg Note Added: 0001159
2019-03-10 16:08 Sam Note Added: 0001161
2019-03-10 16:20 Sam Note Added: 0001162
2019-03-10 16:20 IgorBeg Note Added: 0001163
2019-03-10 16:35 PhyllisSmith Note Added: 0001164
2019-03-11 04:06 PhyllisSmith Note Added: 0001168
2019-03-11 13:05 Pierre Note Added: 0001173
2019-03-11 13:07 Pierre Note Added: 0001174
2019-03-11 13:11 IgorBeg File Added: PullDownMenu-Arrow.png
2019-03-11 13:11 IgorBeg Note Added: 0001176
2019-03-11 14:07 Sam Note Added: 0001179
2019-03-11 14:41 IgorBeg Note Added: 0001180
2019-03-11 20:03 Sam Note Added: 0001181
2019-03-11 20:18 PhyllisSmith Note Added: 0001182
2019-03-13 02:32 PhyllisSmith Note Added: 0001188
2019-03-13 13:41 IgorBeg Note Added: 0001189
2019-03-13 16:41 Sam Note Added: 0001200
2019-03-14 22:54 PhyllisSmith Status confirmed => resolved
2019-03-14 22:54 PhyllisSmith Resolution open => fixed
2019-03-14 22:54 PhyllisSmith Fixed in Version => 2019-03
2019-03-14 22:54 PhyllisSmith Note Added: 0001207
2019-05-03 16:57 PhyllisSmith Status resolved => closed
2019-05-03 16:57 PhyllisSmith Note Added: 0001478