View Issue Details

IDProjectCategoryView StatusLast Update
0000098Cinelerra-GG[All Projects] MantisBTpublic2019-01-08 17:13
ReporterMatNAssigned ToSam 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformARM smartphoneOSAndroidOS Version7.1
Product Version2018-12 
Target VersionFixed in Version 
Summary0000098: MantisBT text does not wrap on smartphone display
DescriptionI was viewing MantisBT entries on a smartphone using Firefox Focus. It looks OK, except that text in boxes donĀ“t wrap. You have to scroll veryy much sideays to read all, and lose the overview.
Does MantisBT have the possibility to wrap text for smaller displays? If so, can it be enabled?
Steps To ReproduceSee description
TagsNo tags attached.

Activities

Sam

Sam

2019-01-08 17:13

manager   ~0000533

I have inquired and unfortunately found no native setting that fixes this problem.

MantisTouch is a paid service that needs to be renewed every year. The source code seems to be included, but it is not written under which license this code is distributed, and what rights the owner reserves. I'm willing to donate money to support open source, but not if there is no clear information about the license, so I wouldn't want to install it on the server.

If you have an Android smartphone, you can download the MantisDroid Free app for free.
http://bit.ly/2FkrQmL
With it you can enter your data and log in directly, there the pages are displayed correctly for smartphone. However, you cannot close the current ticket there, you can only add notes.

There is also a version with costs for 1,49 Euro.
http://bit.ly/2GYvAgk

It has the full functionality, that means you can edit your own tickets directly there. I have tested it and it works quite well so far, I will use this app myself when I am on the road. The paid app is not free and the code is not visible, but everyone can decide for himself if he wants to use it or not, especially since it does not have to be installed directly on the server.
Sam

Sam

2019-01-06 20:55

manager   ~0000518

Thanks for the useful hint. I will take a look at it later this week.
MatN

MatN

2019-01-06 19:37

reporter   ~0000515

I just noticed Mantis had an add-on called MantisTouch for smartphones (https://mantisbt.org/addons.php). If this CMS supports that, might be worth a try.
Sam

Sam

2019-01-05 20:48

manager   ~0000498

Thanks for pointing that out, I'll check to see if there's a setting for that.

Issue History

Date Modified Username Field Change
2019-01-05 20:36 MatN New Issue
2019-01-05 20:48 Sam Note Added: 0000498
2019-01-05 20:48 Sam Assigned To => Sam
2019-01-05 20:48 Sam Status new => assigned
2019-01-06 19:37 MatN Note Added: 0000515
2019-01-06 20:55 Sam Note Added: 0000518
2019-01-08 17:13 Sam Note Added: 0000533
2019-01-08 17:13 Sam Status assigned => resolved
2019-01-08 17:13 Sam Resolution open => fixed