Notifications
Clear all

Crash at startup

Page 1 / 2
   RSS

0
Topic starter

Hello,

I have just switched my two computers to Debian 11.
With the old one, no problem, cinelerraGG works perfectly.
On the second one, no way to start cinelerraGG.

Here is what I get, on the second computer, when I launch CinGG-20210731-x86_64.appImage or CinGG-20210731-x86_64-older_distros.AppImage

$ CinGG-20210731-x86_64.AppImage
Cinelerra Infinity - built: Jul 31 2021 0957
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

init plugin index: /tmp/.mount_CinGG-l2U9lw/usr/bin/plugins
init lv2 index:
LOAD: http://calf.sourceforge.net/plugins/Analyzer
LOAD: http://calf.sourceforge.net/plugins/BassEnhancer
LOAD: http://calf.sourceforge.net/plugins/CompensationDelay
LOAD: http://calf.sourceforge.net/plugins/Compressor
LOAD: http://calf.sourceforge.net/plugins/Crusher
LOAD: http://calf.sourceforge.net/plugins/Deesser
LOAD: http://calf.sourceforge.net/plugins/Emphasis
LOAD: http://calf.sourceforge.net/plugins/EnvelopeFilter
LOAD: http://calf.sourceforge.net/plugins/Equalizer12Band
LOAD: http://calf.sourceforge.net/plugins/Equalizer30Band
LOAD: http://calf.sourceforge.net/plugins/Equalizer5Band
LOAD: http://calf.sourceforge.net/plugins/Equalizer8Band
LOAD: http://calf.sourceforge.net/plugins/Exciter
LOAD: http://calf.sourceforge.net/plugins/Filter
LOAD: http://calf.sourceforge.net/plugins/Filterclavier
LOAD: http://calf.sourceforge.net/plugins/Flanger
LOAD: http://calf.sourceforge.net/plugins/Fluidsynth
fluidsynth: warning: SDL2 not initialized, SDL2 audio driver won't be usable
fluidsynth: warning: SDL2 not initialized, SDL2 audio driver won't be usable
LOAD: http://calf.sourceforge.net/plugins/Gate
LOAD: http://calf.sourceforge.net/plugins/HaasEnhancer
LOAD: http://calf.sourceforge.net/plugins/Limiter
LOAD: http://calf.sourceforge.net/plugins/MonoCompressor
LOAD: http://calf.sourceforge.net/plugins/MonoInput
LOAD: http://calf.sourceforge.net/plugins/Monosynth
LOAD: http://calf.sourceforge.net/plugins/MultiChorus
LOAD: http://calf.sourceforge.net/plugins/MultiSpread
LOAD: http://calf.sourceforge.net/plugins/MultibandCompressor
LOAD: http://calf.sourceforge.net/plugins/MultibandEnhancer
LOAD: http://calf.sourceforge.net/plugins/MultibandGate
LOAD: http://calf.sourceforge.net/plugins/MultibandLimiter
LOAD: http://calf.sourceforge.net/plugins/Organ
LOAD: http://calf.sourceforge.net/plugins/Phaser
LOAD: http://calf.sourceforge.net/plugins/Pitch
LOAD: http://calf.sourceforge.net/plugins/Pulsator
LOAD: http://calf.sourceforge.net/plugins/Reverb
LOAD: http://calf.sourceforge.net/plugins/ReverseDelay
LOAD: http://calf.sourceforge.net/plugins/RingModulator
LOAD: http://calf.sourceforge.net/plugins/RotarySpeaker
LOAD: http://calf.sourceforge.net/plugins/Saturator
LOAD: http://calf.sourceforge.net/plugins/SidechainCompressor
LOAD: http://calf.sourceforge.net/plugins/SidechainGate
LOAD: http://calf.sourceforge.net/plugins/SidechainLimiter
LOAD: http://calf.sourceforge.net/plugins/StereoTools
LOAD: http://calf.sourceforge.net/plugins/TapeSimulator
LOAD: http://calf.sourceforge.net/plugins/TransientDesigner
LOAD: http://calf.sourceforge.net/plugins/VintageDelay
LOAD: http://calf.sourceforge.net/plugins/Vinyl
fluidsynth: warning: SDL2 not initialized, SDL2 audio driver won't be usable
fluidsynth: error: requested set value for setting 'synth.midi-channels' out of range
LOAD: http://calf.sourceforge.net/plugins/Vocoder
LOAD: http://calf.sourceforge.net/plugins/Wavetable
LOAD: http://calf.sourceforge.net/plugins/XOver2Band
LOAD: http://calf.sourceforge.net/plugins/XOver3Band
LOAD: http://calf.sourceforge.net/plugins/XOver4Band
LOAD: http://eq10q.sourceforge.net/bassup
LOAD: http://eq10q.sourceforge.net/compressor
LOAD: http://eq10q.sourceforge.net/compressor_sc
LOAD: http://eq10q.sourceforge.net/compressor_stereo
LOAD: http://eq10q.sourceforge.net/compressor_stereo_sc
LOAD: http://eq10q.sourceforge.net/eq/eq10qm
LOAD: http://eq10q.sourceforge.net/eq/eq10qs
LOAD: http://eq10q.sourceforge.net/eq/eq1qm
LOAD: http://eq10q.sourceforge.net/eq/eq1qs
LOAD: http://eq10q.sourceforge.net/eq/eq4qm
LOAD: http://eq10q.sourceforge.net/eq/eq4qs
LOAD: http://eq10q.sourceforge.net/eq/eq6qm
LOAD: http://eq10q.sourceforge.net/eq/eq6qs
LOAD: http://eq10q.sourceforge.net/gate
LOAD: http://eq10q.sourceforge.net/gate_stereo
LOAD: http://eq10q.sourceforge.net/matrix_lr2ms
LOAD: http://eq10q.sourceforge.net/matrix_ms2lr
LOAD: https://community.ardour.org/node/7596
LOAD: urna-comp
** segv at 0x7f2cd80813c4 in pid 4540, tid 4540
writing debug data to /tmp/cinelerra_4540.dmp
lock_items: 0
lock_frees: 4
Erreur de segmentation

 

The resulting /tmp/cinelerra_4540.dmp file is empty. So no info on that side.
I did try uninstalling Ardour thinking it would fix the problem but it didn't fix anything.
Then I compared the list of lv2 plugins installed on both computers using the lv2ls command.
I then discovered that there were the eq10q and zam-plugins on the one that doesn't start, so I uninstalled them.
Result, always the same error message.

At this point, I don't know what to do, I am distraught, can you help me please.

 

16 Answers
0
Topic starter

Hello,

I'm answering to myself but mostly to pass on the information to the community.
I managed to launch cinelerraGG.

In my previous message I uninstalled ardour and the result was still the same.
This time I used this command

# apt-get remove --purge eq10q zam-plugins ardour*

and there miracle cinelerraGG starts.

So I reinstalled the lv2 plugins

# apt-get install eq10q zam-plugins

and cinelerraGG still starts.

I reinstalled ardour

# apt-get install ardour

and the disaster, cinelerraGG does not start anymore.

Apparently the ardour plugins have changed and are no longer recognized by the current cinelerraGG.

 

This is of course a temporary solution until someone more qualified than me can find a lasting solution that would allow to use cinelerraGG with ardour installed.

0

@fary54

Thank you for passing this information along and providing the terminal messages which will help to resolve the problem.

I believe the problem is the LV2 plugins that Ardour uses.  And if I remember correctly, it sets up an LV2 path -- something like this example:

   export LV2_PATH=/tmp/j/balance.lv2/usr/local/lib/lv2/:/usr/local/lv2

You can see if this is the problem by using the printenv command to check:

   printenv

Then you can change it to try to start Cinelerra by setting it to empty or unset:

   export LV2_PATH=''                  ! not sure which quote to use

I will look at this in more depth later.

0

@fary54

In addition in Settings->Preferences, Interface tab you can set the LV2 path.

More information on this in the Plugins section of the manual.

Also, there is a blacklist for LV2 plugins that will not work with Cinelerra, and if we figure out from your terminal error message, we can add this.  Unfortunately, using the AppImage does not allow for the user to find the bad ones and add it to the blacklist that is incorporated into AppImage.

0
Topic starter

First of all, thank you very much for responding so quickly.

Here is the result of the printenv command

SHELL=/bin/bash
SESSION_MANAGER=local/3960x:@/tmp/.ICE-unix/2767,unix/3960x:/tmp/.ICE-unix/2767
QT_ACCESSIBILITY=1
COLORTERM=truecolor
XDG_MENU_PREFIX=gnome-
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
GTK_IM_MODULE=ibus
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
[email protected]=ibus
DESKTOP_SESSION=default
SSH_AGENT_PID=2487
GTK_MODULES=gail:atk-bridge
PWD=/home/fabrice
LOGNAME=fabrice
XDG_SESSION_DESKTOP=default
XDG_SESSION_TYPE=x11
GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent1
XAUTHORITY=/run/user/1000/gdm/Xauthority
WINDOWPATH=2
GDM_LANG=fr_FR.UTF-8
HOME=/home/fabrice
USERNAME=fabrice
IM_CONFIG_PHASE=1
LANG=fr_FR.UTF-8
LS_COLORS=rs=0*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.webp=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
XDG_CURRENT_DESKTOP=GNOME
VTE_VERSION=6203
GNOME_TERMINAL_SCREEN=/org/gnome/Terminal/screen/748fca45_2c44_4a52_bbb7_2d0cf4514156
CLUTTER_IM_MODULE=ibus
XDG_SESSION_CLASS=user
TERM=xterm-256color
USER=fabrice
GNOME_TERMINAL_SERVICE=:1.938
DISPLAY=:0
SHLVL=1
QT_IM_MODULE=ibus
XDG_RUNTIME_DIR=/run/user/1000
XDG_DATA_DIRS=/usr/share/gnome:/usr/local/share/:/usr/share/
PATH=/home/fabrice/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
GDMSESSION=default
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
_=/usr/bin/printenv

The line export LV2_PATH=/ does not exist in my system.
Let me know if you need me to send you more information.

0

@fary54

Your help is much appreciated because a new release of CinGG will be created on August 31 and it will be helpful for others to get this resolved. 

1) The additional information you sent is helpful but was printenv executed when Ardour was installed?  Does not matter, just moving on with steps below.

2) If not too much trouble for you, please go ahead and reinstall Ardour and then as a test, start CinGG as follows:

   CIN_CONFIG=/tmp/dummybcast5 ./CinGG  directory/cin-x86_64.AppImage

(basically just put CIN_CONFIG=/tmp/dummybcast5 in front of the startup)

3) If the above works with the dummy bcast5 then you can edit your $HOME/.bcast5/Cinelerra_rc (carefully and I know your are expert enough to do this) and change the line LV2_PATH to: LV2_PATH $CIN_PATH/lv2 . Then bring up CinGG again without the CIN_CONFIG in front of it.  You will not have any of the LV2 plugins but we can go from there.

Thanks so much for your reporting and help!

0
Topic starter

@phylsmith2004

Hello,

I followed the procedure you suggested to the letter and, miraculously, everything works correctly without any particular problem.
For the record:
1) Not executed.
2) Procedure ok.
3) Procedure ok.

Result: CinelerraGG starts without any problem with ardour installed. Thanks to your intervention, I discovered with amazement that /home also contains a .bcast5 directory

I'm at your disposal for further tests in order to solve this problem on the next release scheduled for August 31st.

Thank you very much for your insight and your quick reaction in the management of my problem which will be useful to the whole community.

0

@fary54

Excellent.  But now with the line LV2_PATH $CIN_PATH/lv2 you do not have access to any of the LV2 plugins.  If you never use them, then that is fine, but if you want them you will have to add them back in by going into Settings->Preferences, Interface tab and modifying Default LV2, Directory path name to include the ones you want BUT with version 11 of Debian, they may not work if they have not been recompiled for this new version and CinGG may crash.

To list the system installed lv2 plugins key in: lv2ls in a terminal window.  Then you can choose from that list ones that you want to add in Settings.  This is a personal choice and of course, if it fails you can always edit Cinelerra_rc carefully again back to the original LV2_PATH $CIN_PATH/lv2.

Unfortunately in your original forum topic, it looks like what should be blacklisted for the benefit of everyone, that is LOAD: urna-comp is not enough information for me to get the full name to add to everyone's blacklist:

LOAD: eq10q.sourceforge.net
LOAD: community.ardour.org/node/7596 
LOAD: urna-comp
** segv at 0x7f2cd80813c4 in pid 4540, tid 4540

It is possible that urna-comp is what is supposed to be added to the blacklist, but unless it can be tested on a similar system, I will not know for sure.  Using AppImage does not allow for this type of testing.  Attached is a copy of the current blacklisted lv2 plugins.

 

0
Topic starter

@phylsmith2004

I get the list of LV2 plugins via lv2ls.

Then in Settings->Preferences, Interface tab, I changed the default value of LV2 to:
http://calf.sourceforge.net/plugins/Analyzer

I validate and cinelerraGG restarts.

Cinelerra Infinity - built: Jul 31 2021 0957
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

init plugin index: /tmp/.mount_CinGG-fGvuDb/usr/bin/plugins
init lv2 index:
init ladspa index: /tmp/.mount_CinGG-fGvuDb/usr/bin/ladspa

The terminal does not tell me that it has loaded the LV2 plugin
plugin and I can't find any trace of this plugin in the resources window.

However, in the Cinelerra_rc file, the plugin has been added and no error return from cinelerraGG. (see attachment)

I tried with several other plugins and always got the same result.

 

Question: If the appimage does not return any useful information, wouldn't it be more productive for everyone if I compiled cinelerraGG myself. This would give you the name of the filter that is causing the problem. If so, having never done it:
- Is it accessible at my level?
- if I compile using your guide (file:///tmp/.mount_CinGG-fGvuDb/usr/bin/doc/CinelerraGG_Manual/single_user_build.html#1027) could this cause problems for my production cinelerraGG?

 

 

0

@fary54

I think we have gone as far with this problem as necessary and my best option is to warn  users in the next Release Notes to check their LV2 path in Cinelerra if problems on startup when system or application upgrades take place. 

Now I am just guessing, but I think that installing Ardour may have set up some kind of LV2_PATH that interfered with whatever you had for the original LV2 Path in your Cinelerra_rc file.   So I think it is too late to work on the original problem.

In your original forum post, it shows the name of each LV2 plugin as they are being loaded with each LOAD statement so some how that was the first time for the LV2 load.  However, in order to save time on startup, Cinelerra does not automatically reload the plugins once loaded so in order to see terminal messages and force a reload you would have to do:

Settings → Preferences → Interface tab → Reload plugin index and click on OK which does a restart.

Question: If the appimage does not return any useful information, wouldn't it be more productive for everyone if I compiled cinelerraGG myself. This would give you the name of the filter that is causing the problem.

You would still not get the name of the filter causing the problem because you would still not be automatically reloading the plugins.

If so, having never done it:
- Is it accessible at my level?
- if I compile using your guide (file:///tmp/.mount_CinGG-fGvuDb/usr/bin/doc/CinelerraGG_Manual/single_user_build.html#1027) could this cause problems for my production cinelerraGG?

Yes, I am certain you could do this but the first time, it takes quite a bit of work and going back and forth is quite time-consuming and if you have problems, I am not sure I can be much help.  Once you got it down, it is easy.  But I do not believe there would be any gain in addressing the original forum post problem.

If you compile using the single user build and you put it in a specific directory, it does not interfere with production.

0
Topic starter

@phylsmith2004

As you asked me, I just reloaded the index via Settings → Preferences → Interface tab → Reload plugins index and click on OK which performs a restart.

But no changes, no LV2 plugins are loaded and no feedback from the terminal.

Personally, I am disappointed that I did not find the plugin to be problematic.

But hey, I take it with philosophy and it at least allowed me:

  • to solve my launch problem.
  • to have succeeded for the first time in a single-user build compilation, even if it was not useful to us.

It is indeed a good idea, if we cannot go further, to add a note in the manual.

I remain at your disposal if you need more information.

Anyway, a big thank you for your help.

0

Thanks @fary54 and @phylsmith2004 for all your informations.

I had never used lv2 and Calf in CinelerraGG because it didn't work on my system on my first attempt. Keep in mind that my Linux knowledge is very very low, so excuse me for my low technical talk.
I have done some tests here and, after using my workaround, I can use a few of them in CinelerraGG with their GUI (not all). May be this workaround is wrong from an Linux Expert point of view.
I don't know if it works for other Linux distributions (Debian based).

Information about my system:
- UbuntuStudio_16.04-LTS_64bit
- Ardour 4.6.0 "Evening Star"

The paths where I found "lv2" and "calf" are:
/usr/lib/lv2
/usr/lib/calf

 

Inside /usr/lib/lv2/ directory there are a lot of plugins (directories) and one of them is "calf.lv2". In /usr/lib/lv2/calf.lv2/ directory I see some ".ttl" files, the "calflv2gui.so" file, and the "calf.so" link to "dot dot slash calf/calf.so". I think that last one points to "/usr/lib/calf", so it must go up two directories using "dot dot slash" twice.

My workaround.
0. Make a backup of your ".bcast5" folder (inside "/home/user/" directory).
1. Create a new folder in "/home/user/" named "plugins_lv2-calf_for_Cin" without double quote.
2. Copy and Paste "calf" folder from "/usr/lib/" to "/home/user/plugins_lv2-calf_for_Cin/".
3. Create a new "lv2" folder inside "/home/user/plugins_lv2-calf_for_Cin/".
4. Copy and Paste a few of folders (I started with 14 folders) from "/usr/lib/lv2/" to "/home/user/plugins_lv2-calf_for_Cin/lv2/". Among those folders you MUST copy "calf.lv2" folder, it is important for the "calf" directory.
5. Run CinelerraGG.
6. In CinelerraGG, change the "Default LV_PATH:", that you find in menu-> Settings-> Preferences...-> Interface tab, with "$HOME/plugins_lv2-calf_for_Cin/lv2" (without double quote), and press the Apply button. Cinelerra will restart.

In terminal you can see all the LOADs for the plugins.
You may need to press the "Reload plugin index" button in the Preferences window (Interface tab) to see all the plugins.
You should find those plugins in the Resources window->Audio Effects.

Then you can copy other folders from "/usr/lib/lv2/" to "/home/user/plugins_lv2-calf_for_Cin/lv2/" (see #4 point). If CinelerraGG doesn't start you can delete a specific folder (Effect) from "/home/user/plugins_lv2-calf_for_Cin/lv2/".

On my system it works fine with cinelerra-5.1-ub16.04-20201031.x86_64static and CinGG-x86_64-older_distros.AppImage.
I hope it works for you too. Let me know. Thanks!

0
Topic starter

@IgorBeg

 

I apologise for not replying earlier but I was unable to post anything on the forum.
I hope this time it will be the right one.

 

First of all, thank you very much for your help and for your precise tutorial.

Information from my system:
- Debian 11
- Ardour 6

Directory:
/usr/lib/lv2 - no problem
/usr/lib/calf - does not exist on my system

I have read your tutorial carefully but my file system seems to be different.
If I take your points one by one.

0 - no problem
1 - no problem
2 - In my case, the calf directory in the "/usr/lib/" directory does not exist. So I can't copy it.
3 - no problem
4 - no problem
5 - no problem
6 - no problem

When restarting Cinelerra, no feedback from the terminal informing me that the Calf plugin is loaded.
In the resources window, I can see the Calf directory and its subdirectories. But no filters in them...

0

Thanks for your test, @fary54

If installed in your system, could you search where calf folder is in your system, please? (I think @phylsmith2004 can help for that because she is a Linux Expert.

 

I tried another test on my system and changing my workflow a bit. The idea is only to see the lv2 effects, without calf effects.
From "/home/user/plugins_lv2-calf_for_Cin/lv2/" folder I deleted the "calf.lv2" folder and from "/home/user/plugins_lv2-calf_for_Cin/" I deleted the "calf" folder.
So, in "/home/user/plugins_lv2-calf_for_Cin/" directory I only see "lv2" folder.
Inside "lv2" directory there is the abGate.lv2 folder. If CinelerraGG will see this effect it will be in Resources->Audio Effect and its name is L2_abGate.
Now, in CinelerraGG, I can see the lv2 effects but not calf effects (because I deleted them). That is right.

Could you do a test with L2_abGate effect if this effect is present in your system, please?
Remember of press the "Reload plugin index" button in the Preferences window (Interface tab) and restart CinelerraGG.

0
Topic starter

@IgorBeg

"If installed in your system, could you search where calf folder is in your system, please? (I think @phylsmith2004 can help for that because she is a Linux Expert."

You will find attached a txt file detailing the directories and files on my system related to calf.

I think the main directories are :

  • /usr/share/calf
  • /usr/lib/lv2/calf.lv2

"Could you do a test with L2_abGate effect if this effect is present in your system, please?"

Sorry, I don't have this filter installed on my system.

 

I remain at your disposal if you need more information.

Page 1 / 2
Share: