Notifications
Clear all

Offset between read head and sound

   RSS

0
Topic starter

Hello,

Under Linux Ubuntu 20.04 with the Cin version in the repositories, I have a lag between the sound and the playhead. However, I have verified that my wav file is in 48 Khz and set similarly in the format parameters of Cin. Still in the settings my video is set to 59.9401 images / second, which is the original format of my video which is mp4. For the sound parameters, the problem is the same whether I am using pulse audio or Alsa with a Multiface 2 sound card, and when I go from 4096 to 2048 samples in the playback buffer, it doesn't change anything. Lagging the audio does not improve the situation either.

Do you have any idea where the problem might be?

Thank you in advance for your help.

Philippe

2 Answers
0

I do not know much about audio, but you can at least check under Settings->Preferences, tab Playback A to see if you have "Play every frame" enabled because the default is not to.  That probably is not the problem though.  It looks like you already checked the Format settings -- it will playback at what you have the Project sample rate set to; not what the file is encoded at.  Below is from the manual.

So, if an audio file’s sample rate is different than the project attributes, it is resampled. Similarly, if a video file’s frame size is different than the project attributes, the video is composited on a black frame, either cropped or bordered with black.

Also, you mentioned that you adjusted the lag and that did not help.  Did you do this via Nudge in the expanded patchbay? The nudge value is the amount the track is shifted left or right during playback. The track is not displayed shifted on the timeline, but it is shifted when it is played back. This is useful for synchronizing audio with video ...  When you adjusted the lag, does it just get further and further off?

 

Hopefully, someone else will have better suggestions.

 

0
Topic starter

Thank you very much for your answer,  disable "Play every frame" was the solution 😀 !!

All is fine now, it work perfectly.

Cheers

Share: