Notifications
Clear all

Installation issues on Linux Mint  

   RSS

0

Hi all,

I've decided to try installing Linux Mint to see how Cinelerra performs.

Following instructions from the Download page allows me to install from the repository, but I can't launch Cinelerra because it reports missing libpng12.  I found this and installed it manually (it's not available in the repositories), and then ran into a missing libva.  I haven't found a .deb to resolve this issue, so at this point I gave up and installed a single-user static build, which works fine (but doesn't seem like an ideal long-term solution).

I think it would be worth updating to the latest version of Mint on your build system (I presume building based on outdated libraries is what's creating these problems).  Incidentally, Cinelerra seems to perform MUCH better on this OS than AVLinux.  I will try to get some objective results to share.

Dan

@dankinzelman

April News 2019 on the website:

"Usage of the graphics board GPU in certain cases will result in decode speed up for playback. To make this option available, you will need to install your Operating System’s libva-dev and libvdpau-dev (or libva and libvdpau). Without these libraries installed, Cin will not start and you will see a message that looks something like:

error while loading shared libraries: libva.so.1 cannot …"

------------------------------------------------------------------------------------------------

..".it would be worth updating to the latest version of Mint on your build system"

YES, we are planning on doing this about 1 week before the end of the month.  Generally we do this about every 3 months - the last time was November, 2019 so it is time.  There are a lot of operating systems for us to do and every month we have to do Arch and now Tumbleweed because they are rolling releases.

 

This week we are updating about 15 thirdparty libraries to include x264 and x265.

 

@dankinzelman

That is strange. I recently created a new Mint 19.3 XFCE system and Cinelerra installed fine (after creating the empty file additional-repositories.list to be able to add the repository). But that is not needed anymore if you apply all updates.

After adding it to the repositories, I could simply install it and it ran. I did not have to install any extra libs. I did install something to be able to use va-api from Cin, but it ran fine without that.

@dankinzelman

Ah, I found which libs I have for va-api (search for lib-va in Synaptic).

libva-drm2, libva-wayland2, libva-x11-2, libva2 I do not have libva-dev installed. I also install vainfo to see which hardware acceleration my setup supports.

2 Answers
0

Hi,

Are you running a static tarball on AV Linux? Or the Debian Repository packages? Running the same version on both OS' will give you a more accurate benchmark.. It is quite possible the tarball may have some subtle differences, I recently found a difference (and improvement) in how the tarball handles importing fonts vs. the repository Cin packages.

For the record a new AV Linux ISO based on Debian Buster is in the works and will likely be released an a month or so.. Nothing at all wrong with Mint though, when I'm asked by friends and family to set up a Linux system and they don't have specific A/V requirements Mint is my go to!

@avlinux

I stand corrected. On a fresh Mint 19.3 cin (202001) does NOT run. Following are the steps I took to test.

- Live Mint 19.3 XFCE boot, runs kernel 5.0.0-32-generic
- libva etc was present after boot, verified with Synaptic and (installed) vainfo, GPU driver amdgpu, Mesa 19.0.8 .
- Downloaded CinGG static tar does not run: libIlmThread-2_2.so.12 not found.
- Downloaded CinGG non-static tar into different directory: same error.
-Do "sudo apt update", followed by "sudo apt upgrade" (picks up many updates)
- Same CinGG error.
- Added CinGG repository (after all the updates no need for manual file creation).
- "sudo apt update" , " sudo apt install cin" , move to non-cin directory so it doesn't pick up the static/non-static.
- Start cin, same error.
- Used Synaptic to find ilmthread, package is libilmbase12. "sudo apt install libilmbase12" to install.
- Start cin, all seems ok.

So I do not have the libva missing or the png. I have not tested if libva etc is present immediately after a fresh install (rather than live boot), will try later.

For testing, I normally use the repository, and normally use Mint. I switch between generic and real-time kernels if needed.

@MatN

It looks like we need to do more work on Mint 19.3 for this month's build (including looking into BT #365 for all of the extraneous messages during installation).  Because now I am confused as to why this is needed:

  libIlmThread-2_2.so.12

and still why Dan had the libpng12 issue too?  We may have to do a brand new install of Mint to work out the details because unfortunately  we just do upgrades so that libllmTh... is probably already in from our original Mint 19 install.

@avlinux

I believe I installed Mint Mate (I like Caja dual pane view, and have never learned to love Thunar, although its batch-rename feature is really handy on occasion).

I'll try installing the libilmase package tomorrow and report back.

Dan

0

@dankinzelman

As you suggested we did a fresh install of Mint 19.3 here.  When we attempted to do a package install of CinGG from the 01/31/2020 package Cin was not able to start due to missing libIlmThread-2.2.so.12 and libIex-2.2.so.12.  This confirms what MatN already verified but does not match exactly the problem you reported of wrong libva..., etc.  Anyway we build 19.3, build CinGG, and Cinelerra ran without problems so we will use this for the monthly builds.  There is a test package build at:

    https://cinelerra-gg.org/download/testing/cin_5.1.mint19.3-20200224_amd64.deb

if anyone wants to try it before March 1.

Share: