Problems loading a file  

   RSS

0

Loading media files from the main drive where the Cinelerra project is saved is no problem. But when I try to load a file located on my second (internal) drive, or from an attached USB external drive, the navigation options within the Cinelerra Load dialogue will not see those places. Any ideas why?

I have tried to simply drag/drop a video file into the resources panel, but unlike with some other NLEs, these just bounce back and won't load in that way.

In the Load dialogue there is a Directory field, but after I enter a pathway into that field, what do I do next to get Cinelerra to look there? If I use the Enter key, my pathway in the field is just deleted.

It sounds too simple, but are you sure the extra drive(s) are mounted? I have two internal drives for video which I mount each time I boot the machine, then to get Cinelerra to see them, in my case, it's /run/media/username/drive name/directory. Once it has been there, Cin saves the location.

4 Answers
0

Probably the easiest way to avoid the confusion by the different way it works is to just use the "up a directory"icon arrow on the right side on the top line of the Load menu.  It will probably go all the way up to just / and then in the "File" box below the "Search" box, you will see all of the mounted directories.  If you did not mount the USB, it will not show and you will know what the problem is.

I make this mistake still after 3 years -- DO NOT type the filename in the "Directory" box, just the directory name AND use the / character at the end.  For example: /root/media1/ instead of /root/media  (that is without the slash).

Maybe until you get used to it, you can just type in the "File" box at the bottom, the entire file name to include the directory path -- that is easiest for me; for example:

File:     /mnt9/myvideofile.mp4    followed by the Enter key.

 

0

Thanks so much for the replies. Using the Linux Mint Drive utility, my second internal drive had been set for "mount at startup" and the drive label appears in the fstab file. Therefore I felt that was not my problem, and when for example using the image editor GIMP, I can navigate to the second drive to load files without issue. It was actually me not knowing how to approach the Cinelerra load dialogue!

I have used the Up arrow in the Load dialogue to get to the top (at / level), but in the results window below I would just see the file system folders without the second drive visible. However, when entering "/mnt/my-second-drive-label/" in the Directory field, sure enough the sub-folders on that drive suddenly appeared below in the results window, allowing me to start navigating through them to the files I want.

Hopefully, the same holds true when navigating to a plugged in external drive - I haven't had time to try that out yet, just wanted to thank you for your helpful and quick responses.

0

One method I prefer is the project folder based approach. For this I created templates for CGG and a script that creates the project with all necessary directories and copies the corresponding CGG template like HD25p, FullHD50p etc. into the project and names it internally. Then I check which footage I want to use and create links in the previously created folders like archive material, raw material, graphics, sound, etc. This makes working with the file dialog a lot easier, I have everything in one place and the paths are short.

For a given project I have two external drives which are copies of each other (for safety), and usually I alternate from one to the other as the project progresses to keep them up to date. In using Premiere I would just copy the current NLE project file into the other drive, and because all the folder layouts were the same between both drives, I could go ahead and work on the other drive. Premiere overlooked the fact that the actual drive labels were different -- "PD1a" and "PD1b" -- because the project file operated within the confines of the external drive, in which everything was the same. Hopefuly Cinelerra will do the same, or will it all be off-line because the drive labels are different?    

A simple solution for an unusual setup:

mkdir -p /home/TrueIndigo/path/to/projekt/raw
sudo /bin/mount --bind /media/PD1a /home/TrueIndigo/path/to/projekt/raw
# sleep 28800
sudo /bin/umount /home/TrueIndigo/path/to/projekt/raw
sudo /bin/mount --bind /media/PD1b /home/TrueIndigo/path/to/projekt/raw

This works always and independent of the used software.
0

I do not think it will work like in Premiere.  The method I would use would be to use in the File pulldown, the Export option.  You can just experiment with this or read a short paragraph about this in the CinelerraGG_manual.pdf section 5.4.2.  Of course, you will have to be very careful to make sure you are exporting in the right direction.

Share:
  
Working

Please Login or Register