Notifications

Some installed fonts don't show up in Cin-GG?  

   RSS

0

Hi,

On a few projects I've noticed that fonts that are available on my system for GIMP and LibreOffice aren't showing up in Cin-GG, unfortunately they're some of my most used fonts for graphics and title work. Are there certain constraints for fonts that get accessed by Cin? I have rebuilt the font cache on my system a few times before posting this question so I know the fonts are visible to other apps in the system.

I've attached a menu screenie from Cin, and one from GIMP's menu in the comment below

This topic was modified 2 months ago 2 times by AVLinux

It seems I can only attach one image per post so here is the second menu image from GIMP

6 Answers
0

To add additional fonts to Cinelerra (assuming that they have a fonts.scale file already set up and they probably do if they work in gimp, else run mkfontscale) all you have to do is type this from a window before starting Cinelerra:

    export BC_FONT_PATH=<color-separated-search-path-for-fonts>

for example:

    export BC_FONT_PATH=/usr/share/fonts

The Cinelerra fonts in the default path are automatically included.  The BC_FONT_PATH environment variable stays in effect until it is unset or on a reboot.  You can read more details in the manual at the end of the Title plugin.

 

 

@phylsmith2004

Hi Phyllis, thanks for the reply and advice..

I ran mkfontscale and then I ran the command you provided with my correct font paths, there are only the two usual places on my system with fonts: /usr/share/fonts and /$HOME/.fonts. so I don't have a non-standard font location. Then I ran Cin in the same terminal I had exported the path in just to be safe but alas still missing fonts. I don't think the problem is the path because Cin is finding 99% of the other fonts located both in /usr/share/fonts and in .fonts in my home folder so it's not like Cin is missing a particular folder path, it's just not loading those particular fonts for some other reason.

I'm attaching a zip with two of the troublesome fonts in it if you and GG want to see if they load for you, they are not commercially licensed fonts they are freebies from the usual sites like Squirrelfonts and 1001 Fonts.

Thanks, Glen

0

@AVLinux

We had specifically tested punkrockshow.zip yesterday before replying but apparently that is different than CF PunkRockShow.

THIS HAS BEEN EDITED as I was wrong and hopefully you made the same mistake!  They both work, it is just the name that you might be looking for is wrong.

For example: chant... is really "channel tuning (misc)" and CF Punk.. is really "punkrockshow (misc).

This post was modified 2 months ago by PhyllisSmith

@phyllissmith

Hi, well my hopes were up but I'm not seeing that here.. I checked multiple times and once again ran the export commands just to be safe. They don't show up as the alternate names you're seeing there for me... I'm on Debian if that makes any difference to font handling. Could simply changing the name of the '.ttf' file work? Or is the name hardcoded into the font file itself?

0

Maybe the fonts.scale file is bad.  When I unzipped the file you sent, I ran mkfontscale where /tmp/fonts contained the chant... and CF Pun... so:  cd /tmp and mkfontscale/fonts

The contents of the /tmp/fonts/fonts.scale was:

2
CF PunkRockShow.ttf -misc-punkrockshow-medium-r-normal--0-0-0-0-p-0-iso10646-1
chant___.ttf -misc-channel tuning-medium-r-normal--0-0-0-0-p-0-iso10646-1

 

Does the fonts.scale file which contains Punk and chant have similar lines?  We will test on Debian to see if a difference (but probably not until tomorrow)

@phyllissmith

I get the same results as you when I run that command here, I've found a handful of other fonts that also don't appear, would you like me to attach them or do you figure the answer for one is the answer for all..?

0

Although not on Debian, GG already ran the 2 in the debugger and they showed up as he executed the code line by line. Possibly something else is preventing them from being displayed.  We have not had the time to test on Debian yet though because that computer is in high use right now.  Maybe you should send the handful then at least I can see if there is any obvious commonality and test on my laptop.  (P.S. we had a lot of fun playing with Punk Rock and added the Rumbler plugin it to it!)

@phyllissmith

Sounds like things are making some progress, thanks so much for looking into this, even I didn't realize how many fonts weren't displaying in Cin (I literally have hundreds of fonts). So the first zip is some otf fonts that aren't working..

 

@phyllissmith

And here are some ttf ones, there are probably more but after an hour of crosschecking I was getting googly-eyed..lol

PS. I did not have anything to do with naming these fonts!

0

@AVLinux

Check permissions on the fonts.scale file to make sure it is 644 so that it is readable by an ordinary user. 

@phyllissmith

Yep, 644 all the way!

0

Just tested on Debian 10 using the static tarball from January 31 and in the bash shell.  Everything we try works - both chant and punk rock with export BC_FONT_PATH...

We are clueless.  If you start Cinelerra from a terminal window, you can also:

export BC_FONT_DEBUG=1      and it will print out on the terminal window each font as it scans it to see if one of them is troublesome. 

 

 

 

 

 

@phyllissmith

OK, It's working better here, but still doesn't work without explicit debugging... running a Cin session without export and debug still doesn't show all fonts.

What I did:

  • Checked fonts.scale permissions
  • Manually cleaned my fontconfig caches and ran fc-cache -f -v both as Root and User
  • Moved my home fonts to /usr/share/fonts
  • Uninstalled larabiefonts Debian packages with Synaptic (I had a few duplicates none of which were the fonts that were giving me problems)

Now running export and debug will give me access to all fonts in Cin so I can live with that.. Thanks very much for the help!

 

Share: