View Issue Details

IDProjectCategoryView StatusLast Update
0000454Cinelerra-GG[All Projects] Bugpublic2020-07-03 09:15
Reporterhouku Assigned ToPhyllisSmith  
PriorityhighSeverityminorReproducibilitysometimes
Status feedbackResolutionreopened 
PlatformLinuxOSendeavourOOS Version
Product Version2020-04 
Target VersionFixed in Version 
Summary0000454: cinelerra doesnt launch, and i really wanted to try it :(
Descriptionso i was scrolling around youtube for the heck of it, and i saw a comment on a random linux video suggesting cinelerra GG, and it said that it aims to be linux only alternative for premere and (if i remember correctly) as good as davinci resolve, now, i was using davinci on windows since i couldnt get rid of it, unfortunatly for me, after i learned so much about davinci resolve, i couldnt get out of using it, but when i heard cinelerra was as good, i thought i could finally get out of using windows, i followed the steps for arch, since i was using endeavourO in which is based on arch, and when added and updated, i installed it, and it installed quite fast, but i got this error:" cin: error while loading shared libraries: libaom.so.0: cannot open shared object file: No such file or directory "
so i did what a programmer does when having as issue and googled an answer, which led to this: https://forum.manjaro.org/t/cin-gg-dont-launch-itself-any-more-solved/79843 "
so i added the the new edit stuff with nano, and updated + install, copied, and it still didnt launch, i removed it and installed the git version from AUR, and i got this: Cinelerra Infinity - built: Jun 16 2020 19:36:26
git://git.cinelerra-gg.org/goodguy/cinelerra.git
(c) 2006-2019 Heroine Virtual Ltd. by Adam Williams
2007-2020 mods for Cinelerra-GG by W.P.Morrow aka goodguy
Cinelerra is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions. There is absolutely no warranty for Cinelerra.

BC_WindowBase::init_im: Could not open input method.
unjoined tids / owner 1
  00007f3bf148e700 / 00007f3bfe4b5c80 12BC_Clipboard

at that point i was confused, i dont want to go insane so im just gonna ask for help from the bug report, and if i find a solution with help or alone, i would edit it and add the solution, thanks in advance
Steps To Reproducegoogled and added
[cingg]
SigLevel = Optional TrustAll
Server = https://cinelerra-gg.org/download/pkgs/arch
# end of cingg
Additional Informationit doesnt open
TagsNo tags attached.

Activities

Andrea_Paz

Andrea_Paz

2020-07-03 09:15

updater   ~0003724

@MatN
It seems to me that "Q" only queries the local database; for the remote database it needs "F".

[PS(OT):Cinelerra-CV has a new website http://cinelerra-cv.wikidot.com/ I don't know if we should update wikipedia or IgorUbuntu, the creator of the new site, should do it.]
MatN

MatN

2020-07-01 17:55

reporter   ~0003721

Thanks Andrea, vainfo is indeed in the libva-utils package.
For EndeavourOS, "sudo pacman -S libva-utils" will install it.
Strangely, the "pacman -Q -o vainfo" does not show which package it is in, returning "error: No package owns vainfo".
But after installing libva-utils, the same cmd tell you it is in libva-utils.
In Mint, "aptfile find xxx" allows one to find out which package to install to get xxx in the machine.
PhyllisSmith

PhyllisSmith

2020-06-30 23:41

manager   ~0003713

Per Andrea's note 3700, I have corrected the README.arch (but GG has not uploaded to the website yet). I plan to update the Arch install procedure to refer to Manjaro and EndeavorOS but did not get to it yet.
Andrea_Paz

Andrea_Paz

2020-06-30 14:40

updater   ~0003710

"vainfo would be nice but is apparently not in the normal repositories."

In arch vainfo is contained in the libva-utils package; I think the same is for EndeavourOS.
MatN

MatN

2020-06-29 10:00

reporter   ~0003702

Indeed Andrea,
thanks for the correction. I should use copy-paste instead of typing it again...
Andrea_Paz

Andrea_Paz

2020-06-29 08:50

updater   ~0003700

I was looking at MatN fixes, also reported in:
https://www.cinelerra-gg.org/download/README.arch
There's an oversight to be corrected in two lines:

sudo pacman -install numactl ==> sudo pacman -S numactl
MatN

MatN

2020-06-23 17:41

reporter   ~0003641

@houku,
I have now tried EndeavourOS as well. I got the same libaom error, but was able to fix it and two others. For the record, these are the problems and my fixes. I did not compile or build anything. After each fix, I tried to start CinGG again, and got the next error.
endeavouros-2020.05.08-x86_64
- Problem missing libaom.so.0, but pacsearch shows aom installed, and there is /usr/lib/libaom.so.2
  Fix in /usr/lib: "sudo ln -s libaom.so.2.0.0 libaom.so.0" ( make a symbolic link liboam.so.2 that points to libaom.so.2.0.0 , which is the actual code).
- Problem missing libGLU.so.1
  Fix "sudo pacman -S mesa"
- Problem missing libnuma.so.1
  Fix "sudo pacman -install numactl"
After these three fixes Cinelerra-GG starts up. I have not done any testing with it, could well be that if you use libaom (for AV1 videos) you get an error because it is the wrong release.

I recommend these other installs: mesa-demos inxi vdpauinfo clinfo . vainfo would be nice but is apparently not in the normal repositories. If you are missing a file, usually pacsearch will tell you which package it is in.

Please report back with any problems you still might have.
PhyllisSmith

PhyllisSmith

2020-06-23 16:18

manager   ~0003640

@MatN
Reopening.
PhyllisSmith

PhyllisSmith

2020-06-23 01:53

manager   ~0003639

Good news. Sounds like the problem is solved.
MatN

MatN

2020-06-22 19:25

reporter   ~0003638

@houku
I did a quick test on a virtual machine (VirtualBox). After installing Manjaro 20.0.2, adding VB guest editions (and set VGA driver to VBoxSVGA), and updating the system, I installed the tar Phyllis pointed to (just extracted it to a directory). When in that directory i did ./cin, it said it was missing libnuma.so.1 . I fixed this by installing numactl, in a terminal: "sudo pamac install numactl" . After that, ./cin works fine.
Please let us know how you get on.
PhyllisSmith

PhyllisSmith

2020-06-20 03:08

manager   ~0003635

@houku
Let us know if you have resolved this issue or are still stuck.
MatN

MatN

2020-06-18 18:57

reporter   ~0003629

@houku,
It is running for me on the latest Manjaro. I think I had to install an extra something, but didn't write it down, sorry.
I use the static tar that Phyllis points to.
PhyllisSmith

PhyllisSmith

2020-06-17 17:10

manager   ~0003623

@houku
This has been the most interesting bug issue I have seen so far and I enjoyed reading it because it sounds just like something I would think!

Quickest answer: use the tar file at: https://cinelerra-gg.org/download/tars/cinelerra-5.1-arch-20200531.x86_64-static.txz
which has the capability of easily being deleted when you no longer want it (apparently unlike what you see with DaVinci). You probably already know exactly how to handle a tar but here is a README.txt at: https://cinelerra-gg.org/download/README.txt .

Maybe even Quicker answer: "error while loading shared libraries: libaom.so.0: cannot open shared object file". I am not familiar with endeavorO, or Manjaro, or know much about Arch, BUT it seems that if you still have this version installed, you just need to also install libaom. This may not be listed in the README.arch file that you might have looked at if you referred to the Cinelerra-gg.org website package install for Arch.

Confused answer: "installed the git version from AUR, and i got this: Cinelerra Infinity - built: Jun 16 2020 19:36:26
git://git.cinelerra-gg.org/goodguy/cinelerra.git". WOW, I did not know anyone was building this that quickly as mods were added on June 14. So I have no idea what this build was based on. My concern is that Arch, because it is a rolling release, is out of synch with CinelerraGG library usage. The error "unjoined tids / owner " makes me think that because you did a package install first from the website and then used the AUR, parts of each are installed and they simply do not match.

In Summary: safest procedure is just to build it yourself using the manual as a reference (which might also make you insane!) and will involve more time than you would like to spend because you just want to try it. My advice is to "use that static tar" just to give it a try. P.S. I know absolutely nothing about any other NLE, but as far as being as good as others, I think it has plenty of capability and features, but does not operate the same.

Issue History

Date Modified Username Field Change
2020-06-17 14:34 houku New Issue
2020-06-17 17:10 PhyllisSmith Note Added: 0003623
2020-06-18 18:57 MatN Note Added: 0003629
2020-06-20 03:08 PhyllisSmith Assigned To => PhyllisSmith
2020-06-20 03:08 PhyllisSmith Status new => acknowledged
2020-06-20 03:08 PhyllisSmith Note Added: 0003635
2020-06-22 19:25 MatN Note Added: 0003638
2020-06-23 01:53 PhyllisSmith Status acknowledged => resolved
2020-06-23 01:53 PhyllisSmith Resolution open => no change required
2020-06-23 01:53 PhyllisSmith Note Added: 0003639
2020-06-23 16:18 PhyllisSmith Status resolved => feedback
2020-06-23 16:18 PhyllisSmith Resolution no change required => reopened
2020-06-23 16:18 PhyllisSmith Note Added: 0003640
2020-06-23 17:41 MatN Note Added: 0003641
2020-06-25 21:53 houku Issue cloned: 0000457
2020-06-29 08:50 Andrea_Paz Note Added: 0003700
2020-06-29 10:00 MatN Note Added: 0003702
2020-06-30 14:40 Andrea_Paz Note Added: 0003710
2020-06-30 23:41 PhyllisSmith Note Added: 0003713
2020-07-01 17:55 MatN Note Added: 0003721
2020-07-03 09:15 Andrea_Paz Note Added: 0003724