View Issue Details

IDProjectCategoryView StatusLast Update
0000115Cinelerra-GG[All Projects] Featurepublic2019-04-01 21:16
ReporterPhyllisSmithAssigned ToPhyllisSmith 
PrioritynoneSeveritytrivialReproducibilityhave not tried
Status closedResolutionreopened 
Product Version 
Target Version2019-01Fixed in Version2019-03 
Summary0000115: Quick Start pdf
DescriptionTerje provided information for producing a Quick Start .odt / pdf file via an earlier email. Since I had started attempting to do a tutorial for just getting started with Cin-GG last summer, I took that and created a short Quick Start with it. The resulting pdf file is based on an example Terje provided. It is at:

   https://www.cinelerra-gg.org/download/QuickStart.pdf

8 pages / 8 figures ! If there are less experienced users who could review this, that would be helpful. And if you find something that needs correction, please include the corrected material. For example, if the figure is bad, provide a replacement.
TagsHELP needed

Activities

PhyllisSmith

PhyllisSmith

2019-04-01 21:16

manager   ~0001289

Since I have mostly fixed any deficiencies as noted in feedback for the Quickstart, I am closing this as DONE.
I have started a Tutorial based on Terje's and other's suggestion based on The Forgotten Guide and other Tutorials. When I get a first cut of that ready, I will open an issue so I can get feedback and review on that.
PhyllisSmith

PhyllisSmith

2019-02-20 22:29

manager   ~0000961

Last edited: 2019-02-20 22:35

View 2 revisions

Andrea: "I don't see it on Download page?" - I finally added it by replacing Change Log with Quick Start because I wanted it to be in the top section. Change Log was for what documentation had changed in Feature5.pdf, but still working on replacing with a real manual so it is not all the useful. Probably this will affect your Italian translation?

Terje: "File>Open menu works a bit quirky" and even for me still. Thanks for pointing out the obvious instructional deficiencies. GG has checked in changes to implement your suggestions. They will be in the package builds at the end of this month.
  - added "Directory:" as help text to left of location for directory path;
  - added "File:" as help text to left of where the filename can be typed in.
We have not come up with a less confusing idea for avoiding use of a previous remembered "Specify filter", such as "dv". I miss this myself sometimes, but on the other hand we do not want to erase it as some users always want just those files to show. Leaving it for now because one can only assume that if a user has gotten familiar enough with this field to actually use it, then they will be able to overcome missing it fairly easily.

Terje: cut-and-paste editing mode is the default mode. The only other mode is "drag and drop editing mode" which lets you work a little differently. To check, look in the main timeline window where all of the transport icons are and see if there is gold color surrounding the diagonal left-pointing arrow (this mode is often referred to as "arrow" mode") or if there is gold color surrounding the capital letter I (this cut-and-paste mode is also called I-beam mode, for you building engineers).

Also, added a tooltip to the down arrow to the right of the "Directory" textbox to help.
I will be closing this issue in a day or so. I will open a new issue for when I get around to working on a more useful Tutorial.

Andrea_Paz

Andrea_Paz

2019-02-08 17:35

updater   ~0000809

I noticed that the Download page of the site does not contain the link to cinelerragg_quickstart.pdf. But the link you provided works and makes you download the file. Only I don't see it on Download page?
terje

terje

2019-01-30 14:05

reporter   ~0000713

MatN, Phyllis:
This is more Cinelerra than Quickstart:
I.m.o the File>Open menu works at bit quirky at least for new users trying Cinelerra. The question is if a little better explained layout will help.
Samples follows and a screenshot is attached:

If pasting in a file path/name "/video/DV/dv01.dv" into the upper text field (above Search), nothing will be opened. This is a location (directory path) field only. What about adding "Location" as help text to the left of this field (similar like Search below)?

If pasting in the directory name "/video/DV" the list box will be empty if the last used/remembered filters (i.e *.mp4, *.mov) don't match any file types (.dv) in the new location. This is not wrong, but can be confusing before accustoming.

If pasting in a file path/name "/video/DV/dv01.dv" into the text field below the "List box" and Return or green-checked, this file will be loaded indipendent of filter settings and file content in the list box. If also selecting a file in the listbox and checked, both files will be loaded on each track.
What about adding "File" as a help text to the left of this field?

(Another desktop sample:
If entering ffplay in a terminal and then pasting a file name (get prefix file// added) from the graphical file browser, i.e
  ffplay file:///video/DV/dv01.dv
This works; similar for gedit and pasting a text type file name)

Cin_File-open.png (47,226 bytes)
Cin_File-open.png (47,226 bytes)
MatN

MatN

2019-01-30 11:44

reporter   ~0000710

@terje: RMB means Right Mouse Button. Sorry, too much geek talk.

The problem I still have with all drop-down boxes on Cinelerra is that if you click on it, you MUST move down vertically with the mouse cursor in order to select one of the items. I find I have a natural tendency to move the mouse down and sideways to select a much shorter entry, but that disable the drop down immediately. For Instance, in the load file text box, the drop down list includes a short ¨home" entry. I am not sure how to convey this in a QuickStart manual.
As an alternative, I proposed to use the system´s file manager, and copy a file from there, and paste it into the file load text box. This pasting will paste (at least on my system) the full file name, not the file itself. If instead you paste then in another directory, it will copy the whole file.
terje

terje

2019-01-29 23:07

reporter   ~0000708

MatN:
>> ¨navigate to some video file somewhere, do Copy (RMB), then paste in the textbox: this will copy the file name, not the file." - I do not understand >> what you are trying to convey with this sentence?
> was trying to convey to newbies an additional way of getting a file name in there, I frequently use it because I find the file manager easier to navigate > with than Cinelerra. But apparently it is unclear, so forget it.

Though that is targeted to Phyllis (and I am not sure what "RMD" mean), it seems to me this was the same as the second method I listed below
-> copy&paste (from my desktop File browser)
https://www.cinelerra-gg.org/bugtracker/view.php?id=115#c693
(I use it with good experience for other applications too, i.e PDF-shuffler)
MatN

MatN

2019-01-29 22:41

reporter   ~0000705

¨navigate to some video file somewhere, do Copy (RMB), then paste in the textbox: this will copy the file name, not the file." - I do not understand what you are trying to convey with this sentence?
I was trying to convey to newbies an additional way of getting a file name in there, I frequently use it because I find the file manager easier to navigate with than Cinelerra. But apparently it is unclear, so forget it.
MatN

MatN

2019-01-29 15:51

reporter   ~0000701

Name: CinelerraGG_xxx seems fine to me, such a name has just 2 parts. I would avoid having both a hyphen and an underscore in the name, so cin-GG_xxxx looks less nice to me, having 3 parts.

Having said that, I much like the small deviation from the name in that the program itself is now called cin. GG could have saved even more by just calling it ´c´ ! (Just joking). Reduces the wear on the keyboard too...
terje

terje

2019-01-29 07:35

reporter   ~0000698

MatN:/Phyllis:
" that works only if in cut-and-paste editing mode" - good point, I included wording to check for cut & paste mode first."

Here I ask as a newbie on editing with Cinelerra:
What is "cut-and-paste editing mode" and how do I check for it (possibly other modes)?
PhyllisSmith

PhyllisSmith

2019-01-29 05:05

manager   ~0000697

MatN: I followed your suggested edits as best I could and will put a newer version out there after we agree on a name.

" that works only if in cut-and-paste editing mode" - good point, I included wording to check for cut & paste mode first.
"The shortcuts described for normal/fast forward etc work only if you use the alt- variant here" - I did not make a note of this because if someone is just starting with Cin, they are not going to be using shortcuts yet.
 "Choose output format be better?" - much better so I changed it to your suggestion.
"... a textbox where you type in a directory path of where your files are ..." . No-one is going to do that! " - fixed to say use down arrow,
" navigate to some video file somewhere, do Copy (RMB), then paste in the textbox: this will copy the file name, not the file." - I do not understand what you are trying to convey with this sentence?
terje

terje

2019-01-28 23:39

reporter   ~0000696

Phyllis:
I agree the abbreviation Cin-GG or CGG used here are unknown for others or new users. I looked at the CV site which use "cinelerra_cv_manual_en.pdf" for the download. The HV site seems to have only the html version of "Secrets of Cinelerra". So something like "CinelerraGG_Quickstart" seems to reflect the title of this guide.
By the way, the content is more important than the name. What do you think, MatN ?
PhyllisSmith

PhyllisSmith

2019-01-28 22:45

manager   ~0000695

I like the idea of "CinelerraQuickstart" as the name but am concerned that without the GG in it, it may still be confusing.
GG and I did NOT pick the name Cinelerra-GG but it got sort of forced on us, BUT now it is associated with the working cinelerra version so it seems like the name should include GG in it.

"Cin-GG_Quickstart, Cin-GG_Tutorial, Cin-GG_Manual" are good names too and not too long, BUT then I don't know if people out there will realize that Cin means Cinelerra. Cin is the name gg likes to use because Cinelerra is too hard to type! and he has gotten used to GG by now - again because it is easy to type!

Terje and MatN - you can decide which is best and let me know. Thanks.
terje

terje

2019-01-28 22:34

reporter   ~0000694

No edit option here (?)
"my desktop browser" should be "my desktop file browser" (Gnome Files or Nautilus in my case)
X-copy (when it works between applications) is sometimes the easiest
terje

terje

2019-01-28 22:22

reporter   ~0000693

I would would suggest Cin-GG_ (or Cinelerra-GG_ somewhat long) as a prefix to differ the documentation from other Cinelerra versions. That is Cin-GG_Quickstart, Cin-GG_Tutorial, Cin-GG_Manual.

Yes, there are Media files and Device media ...
Personally I don't use the word "Media", but more directly the type of input files (i.e source Video, Audio, Images etc) and lastly the resulting video for output/export.

Regarding entering directory or file paths, I use or combine all methods for Cinelerra like other applications

keyboard written (if short)
copy&paste (from my desktop browser)
Ctrl+C & Ctrl+V (from terminal)
arrow down the three structure (in Cinelerra)
MatN

MatN

2019-01-28 20:47

reporter   ~0000692

Some review notes:
Document title: I have multiple ¨quickstart" documents, what about naming it "CinelerraQuickstart¨ ?

Section 6, Edit/Compose. The text says the easiest way is to select something using the mouse. However, that works only if in cut-and-paste editing mode. I think it is important to say first how to do that, before selecting what to delete.

The shortcuts described for normal/fast forward etc work only if you use the alt- variant here (I´ve mentioned this before). But there is an issue with the tooltips: for normal forward it says alt-l (lower case L), but I mistook it for lower case i. The difference is not clear at this font. And alt-i (lower case i) works, plays slowly, so I though first it was a bug...

Section 4, ¨Format your media¨, this I find a confusing title. I most specifically do not want to format my SSD, DVD-RW, or USB stick! Would not a title like "Choose output format" be better?

Section3, "Load Media" . It includes the text ¨... a textbox where you type in a directory path of where your files are ..." . No-one is going to do that! Point them to the down arrow at the end, and that it will allow you to navigate the file system (by moving vertically from the arrow!). Although it is possible on my XFCE desktop to use its Thunar file manager, navigate to some video file somewhere, do Copy (RMB), then paste in the textbox: this will copy the file name, not the file.
terje

terje

2019-01-28 16:47

reporter   ~0000689

Yes, I would even suggest to extract, customize and update the best and relevant parts from "The Forgotten Guide" with the previous mentioned "Quick Start" (which is really more than that) from http://www.assistcg.com/component/content/article/70.html

I've read both and like the working style. Beside I support what you say to use small portions of the main Manual, and/or additional appropriate stuff from the excellent Feature5.
PhyllisSmith

PhyllisSmith

2019-01-27 22:42

manager   ~0000686

Terje: I forgot to mention I am envisioning that this Forgotten Guide outline can be used for a cin-gg Tutorial as you had mentioned earlier. It makes a good starting point and I think a Tutorial can best be derived by using small portions of the main Manual to get there.
terje

terje

2019-01-27 22:31

reporter   ~0000685

Active links to the chapters (sections) of the Forgotten Guide in the left column of the page
https://www.calcmaster.net/cinelerra/forgotten-guide/
PhyllisSmith

PhyllisSmith

2019-01-27 21:55

manager   ~0000683

Opening up again and including Terje's comments next -

Would'nt it be useful to include a section about the Project setup/configuration already from start here?
I see Project setup are described in other Cinelerra Quick Start guides, and even in the Premiere pro this is emphasized.

(I have also added a "notice in brackets for the Quick Start Guide in my recent comment to 0000077 the the manual on MantisBT)

Re. Tutorial sample/guide
In addition to the previous attached Premiere tutorial and the Cinelerra "Quick Start" from assistcg.com, I attach a third "Cinelerra - The forgotten Guide" from Calcmaster.net

In my opinion some text and parts from older Cinelerra guides and experiences can still be useful to-day, not only as background information, but also for editing and updating it to Cin-GG, without re-inventing everything from scratch. Attached here is my generated pdf and odt for "The Forgotten Guide", and as follows also links to its original html pages

https://www.calcmaster.net/cinelerra/forgotten-guide/
PhyllisSmith

PhyllisSmith

2019-01-24 23:35

manager   ~0000670

I made a couple of changes locally that are trivial and later it will be replaced on the server location. But after nnot looking at it for 1 week, I ran through it as a new user and I decided "It was perfect" - just kidding!!
terje

terje

2019-01-17 20:42

reporter   ~0000624

Phyllis did it again - thanks.
I can join in reviewing it - the more the merrier ;)

Issue History

Date Modified Username Field Change
2019-01-17 00:21 PhyllisSmith New Issue
2019-01-17 00:21 PhyllisSmith Status new => assigned
2019-01-17 00:21 PhyllisSmith Assigned To => PhyllisSmith
2019-01-17 00:21 PhyllisSmith Tag Attached: HELP needed
2019-01-17 20:42 terje Note Added: 0000624
2019-01-24 23:35 PhyllisSmith Status assigned => closed
2019-01-24 23:35 PhyllisSmith Resolution open => fixed
2019-01-24 23:35 PhyllisSmith Note Added: 0000670
2019-01-27 21:55 PhyllisSmith Status closed => feedback
2019-01-27 21:55 PhyllisSmith Resolution fixed => reopened
2019-01-27 21:55 PhyllisSmith Note Added: 0000683
2019-01-27 22:31 terje Note Added: 0000685
2019-01-27 22:42 PhyllisSmith Note Added: 0000686
2019-01-28 16:47 terje Note Added: 0000689
2019-01-28 20:47 MatN Note Added: 0000692
2019-01-28 22:22 terje Note Added: 0000693
2019-01-28 22:34 terje Note Added: 0000694
2019-01-28 22:45 PhyllisSmith Note Added: 0000695
2019-01-28 23:39 terje Note Added: 0000696
2019-01-29 05:05 PhyllisSmith Note Added: 0000697
2019-01-29 07:35 terje Note Added: 0000698
2019-01-29 15:51 MatN Note Added: 0000701
2019-01-29 22:41 MatN Note Added: 0000705
2019-01-29 23:07 terje Note Added: 0000708
2019-01-30 11:44 MatN Note Added: 0000710
2019-01-30 14:05 terje File Added: Cin_File-open.png
2019-01-30 14:05 terje Note Added: 0000713
2019-02-08 17:35 Andrea_Paz Note Added: 0000809
2019-02-20 22:29 PhyllisSmith Note Added: 0000961
2019-02-20 22:35 PhyllisSmith Note Edited: 0000961 View Revisions
2019-04-01 21:16 PhyllisSmith Status feedback => closed
2019-04-01 21:16 PhyllisSmith Fixed in Version => 2019-03
2019-04-01 21:16 PhyllisSmith Note Added: 0001289