View Issue Details

IDProjectCategoryView StatusLast Update
0000192Cinelerra-GG[All Projects] Bugpublic2019-05-03 16:28
ReporterPhyllisSmithAssigned Togoodguy 
PrioritylowSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-04 
Summary0000192: Aging plugin may crash
DescriptionIgorB sent a dump with issue 184 that gg looked at. It may be too difficult to reproduce the bug, but he thinks it happens because the test is for "greater than" and it should be "greater than OR equal". This is only a potential fix as it may not be the exact problem encountered, but needs to be done anyway.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-04-21 16:36

manager   ~0001404

IgorB: thank you for testing. Yes, there is a "drop shadow" on each of the square and diamond shapes. GG says the original coder was big on drop shadows so they seem to be everywhere.

Thanks for the procedure to create the Aging bug -- that way we know it is really fixed.
IgorBeg

IgorBeg

2019-04-21 10:13

reporter   ~0001399

Thanks GG and Phyllis.
 I just tested the new build April 20 2019. For me it is okay. Really stable, no crash, no dump. Really very good, thanks.

The diamond and square shapes are very useful to understand on the fly the type of keyframe, thanks. I am seeing there is a kind of shadow in the shape, I think 1 pixels on right side and bottom side, which confuses the display. But maybe it was done to see better when the track thumbnail is enabled.


PS:
Before testing the new build, I have reproduced the steps to do. I write here for memorandum (I don't know if Mantis-BT keep an archive):
FIle to use "WhatTimeIsIt.xml", link for source and project files to
https://www.dropbox.com/s/o9i44fnszrt6wjq/WhatTimeIsIt.tar.gz?dl=0
- Proxy enabled, NO Scaler= 1/4
- Show safe regions (F10) = Enabled
- "ColorGrading" video track-> Projector: x=90, y=50, z=50
- "V1a" video track-> added "AgingTV" effect for all length of the track
Move the cursor quickly on all timeline, from left to right and vice versa; after a few times CInelerraGG exit and a dump file is created.
PhyllisSmith

PhyllisSmith

2019-04-20 20:00

manager   ~0001391

Last edited: 2019-04-20 20:43

View 2 revisions

IgorB: since you were able to create this bug 4 out of 6 times, if you have a chance tomorrow to test, it is hopefully fixed. GG is creating an Ubuntu16 build now but has not uploaded it yet. It will be in the usual "testing" subdirectory.

Also, this new version as checked into GIT restores the diamond shaped icons for Bezier versus the square shaped icons for Linear on certain autos.

OK, the new build is at:
https://cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

Issue History

Date Modified Username Field Change
2019-04-14 16:56 PhyllisSmith New Issue
2019-04-14 16:56 PhyllisSmith Status new => assigned
2019-04-14 16:56 PhyllisSmith Assigned To => goodguy
2019-04-20 20:00 PhyllisSmith Note Added: 0001391
2019-04-20 20:43 PhyllisSmith Note Edited: 0001391 View Revisions
2019-04-21 10:13 IgorBeg Note Added: 0001399
2019-04-21 16:36 PhyllisSmith Status assigned => resolved
2019-04-21 16:36 PhyllisSmith Resolution open => fixed
2019-04-21 16:36 PhyllisSmith Fixed in Version => 2019-04
2019-04-21 16:36 PhyllisSmith Note Added: 0001404
2019-05-03 16:28 PhyllisSmith Status resolved => closed