View Issue Details

IDProjectCategoryView StatusLast Update
0000292Cinelerra-GG[All Projects] Bugpublic2019-09-14 21:53
Reporterv4tAssigned Togoodguy 
PrioritynormalSeverityblockReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2019-06 
Target VersionFixed in Version 
Summary0000292: Update Error
Description
Something went wrong during the update. I get this error message
Fehler: Konnte Datei 'cin-5.1-arch-20190831-x86_64.pkg.tar.xz' nicht von cinelerra-gg.org übertragen : HTTP server doesn't seem to support byte ranges. Cannot resume.
Warnung: Konnte einige Dateien nicht übertragen
Fehler: Konnte den Vorgang nicht durchführen (Fehler in der Bibliothek für Downloads)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2019-09-11 02:07

manager   ~0002117

@v4t

I updated the installation instructions for Arch on the web page which now reads as follows in that area:

"pacman -Sy
pacman -S cin

NOTE: please complete these 2 steps in order – that is do not run the 2nd at a later time – to avoid the risk of a partial upgrade."

I hope this is sufficient to warn users of a potential pitfall. Thanks for letting us know.
v4t

v4t

2019-09-10 11:19

reporter   ~0002102

I had probably brought about these problems myself. I have reinstalled everything now everything works again.
Please change the installation instructions for Arch
If you do not finish -Sy and then the upgrade and later the pacman -S $ package, there is a risk of a partial upgrade.
Pacman installs this package and installs / updates its dependencies.
7. You have installed another package in step 1, depends on the package, the your new program used. However, you have just updated this package as it depends on the new program. Old program is broken now.
In the best case, you can not open a side program until you have updated the rest of the packages. In the worst case, you break a system-level package like systemd without noticing it until you reboot and your system stops booting.
PhyllisSmith

PhyllisSmith

2019-09-02 18:44

manager   ~0002063

OK, we downloaded the package on Arch here with no problem.
From your error message, it looks like the download simply got interrupted and there was a temporary network failure and it could not "resume".
Can you start over again?
PhyllisSmith

PhyllisSmith

2019-09-02 18:08

manager   ~0002062

GG is testing it here first before replying.
v4t

v4t

2019-09-02 17:15

reporter   ~0002061

What is meant by mistakes in the library?

Issue History

Date Modified Username Field Change
2019-09-02 17:13 v4t New Issue
2019-09-02 17:15 v4t Note Added: 0002061
2019-09-02 18:08 PhyllisSmith Assigned To => goodguy
2019-09-02 18:08 PhyllisSmith Status new => assigned
2019-09-02 18:08 PhyllisSmith Status assigned => acknowledged
2019-09-02 18:08 PhyllisSmith Note Added: 0002062
2019-09-02 18:44 PhyllisSmith Note Added: 0002063
2019-09-10 11:19 v4t Note Added: 0002102
2019-09-11 02:07 PhyllisSmith Note Added: 0002117
2019-09-14 21:53 PhyllisSmith Status acknowledged => resolved
2019-09-14 21:53 PhyllisSmith Resolution open => fixed