View Issue Details

IDProjectCategoryView StatusLast Update
0000552Cinelerra-GG[All Projects] Websitepublic2021-03-02 17:50
Reporterairstreamer Assigned ToPhyllisSmith  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformX86OSOpenSuseOS VersionTumbleweed
Product Version 
Target VersionFixed in Version 
Summary0000552: opensuse Tumbleweed install repositories bad
DescriptionI went to the website https://cinelerra-gg.org/downloads and selected openSUSE. I followed the instructions for the Tumbleweed version and got this:

INSTALL Repository:

[email protected]:~> sudo zypper ar -f https://cinelerra-gg.org/download/pkgs/tweed/ cingg
[sudo] password for root:
Adding repository 'cingg' .......................................................................[done]
Repository 'cingg' successfully added

URI : https://cinelerra-gg.org/download/pkgs/tweed/
Enabled : Yes
GPG Check : Yes
Autorefresh : Yes
Priority : 99 (default priority)

Repository priorities in effect: (See 'zypper lr -P' for details)
      90 (raised priority) : 1 repository
      99 (default priority) : 13 repositories

I then disabled the GPG check which went OK.

I then did the next step:

INSTALL program:

[email protected]:~> sudo zypper install -r cingg cinelerra
Retrieving repository 'cingg' metadata .........................................................[error]
Repository 'cingg' is invalid.
[cingg|https://cinelerra-gg.org/download/pkgs/tweed/] Valid metadata not found at specified URL
History:
 - [cingg|https://cinelerra-gg.org/download/pkgs/tweed/] Repository type can't be determined.

Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Skipping repository 'cingg' because of the above error.
Some of the repositories have not been refreshed because of an error.
Loading repository data...
Reading installed packages...
'cinelerra' not found in package names. Trying capabilities.
No provider of 'cinelerra' found.
Resolving package dependencies...
Nothing to do.

Checking further I found that there is no directory for tweed in https://cinelerra-gg.org/download/pkgs/. However, I found a package in download/old_pkgs/tweed/cinelerra-5.1-tweed-20200930.x86_64.rpm which I installed.

It appears to be working OK for now.

Perhaps your web site needs to be updated... Tom.

 

TagsNo tags attached.

Activities

PhyllisSmith

PhyllisSmith

2021-03-02 17:50

manager   ~0004662

The last tar/package for tweed is in old_pkgs and old_tars. Website has been updated to inform users to use AppImage.
PhyllisSmith

PhyllisSmith

2021-03-01 16:10

manager   ~0004659

The AppImages will be named differently from now on to include the date. For example:
   CinGG-20210228.AppImage
airstreamer

airstreamer

2021-02-09 20:44

reporter   ~0004626

Your wish is my command.

I downloaded the AppImage and ran a simple edit with no problems. Everything seemed to work properly.

Thanks... Tom.
PhyllisSmith

PhyllisSmith

2021-02-09 19:12

manager   ~0004625

@airstreamer
You are right -- I need to update ALL of the directions on the website. We had to drop Tumbleweed from the monthly builds because every time when we updated Tumbleweed distro, it took hours and instead of doing an update, it was literally reinstalling the entire O/S -- remember, we did a lot of different distros and did not boot each of them on a daily basis for them to be continuously updated. Which meant that there were gigantic updates to be done all at once. Because Tumbleweed became such a big issue and there was little usage, we eliminated from the builds upon agreement in the Mailing List where some really sophisticated users gave up on it as being too messy.

But that's not important right now. We have been working on creating an AppImage for the Linux distros now due to unforeseen circumstances and this is the way new builds will be disbursed probably from now on. Of course, it is always possible to do a build manually if you prefer as outlined in the manual.

    https://cinelerra-gg.org/download/testing/
   file: cin_for_newer_distros.AppImage

If you have the opportunity to test this on Tumbleweed and report back, that would be much appreciated as it is new and usage has not been that high yet.

Issue History

Date Modified Username Field Change
2021-02-09 18:49 airstreamer New Issue
2021-02-09 19:12 PhyllisSmith Note Added: 0004625
2021-02-09 19:13 PhyllisSmith Assigned To => PhyllisSmith
2021-02-09 19:13 PhyllisSmith Status new => acknowledged
2021-02-09 20:44 airstreamer Note Added: 0004626
2021-03-01 16:10 PhyllisSmith Status acknowledged => resolved
2021-03-01 16:10 PhyllisSmith Resolution open => fixed
2021-03-01 16:10 PhyllisSmith Note Added: 0004659
2021-03-02 17:50 PhyllisSmith Status resolved => closed
2021-03-02 17:50 PhyllisSmith Note Added: 0004662