通知
すべてクリア

OpenGL texture limit 0

7 投稿
3 ユーザー
0 Likes
548 表示
0
Topic starter

Good Day,
I change computer the old version (ACER Intel 7 7th generation and Nvidia geforce 960) accept 4K video,
New computeur (Asus Intel 7 14th Generation, Nvidia Geforce RTX4060) send me warning message when I open project or new files

Void AWindowsGUI::update_asset_list():

 Warning:/directory/name of pictures or video files

  dimensions 3840x2160 exceed OpenGL texture limit 0

 

If I close the Messages errors, I can work.

Which paramaters I have to change?

I'm under Ubuntu Studio 23.10, last version of Cin (Appimage),  Plasma Wayland, nvidia-drivers-535

Thanks by advance

Jacques

This topic was modified 3か月前 2回 by Jacques CITERICI
phylsmith2004 01/02/2024 10:54 pm
This post was modified 3か月前 by phylsmith2004

@jacques-citerici 

Not sure if any of the information I provide is useful, but I am fairly sure that you can continue to work just fine after getting this error message.

 

This error message is coming from awindowgui.C and is about picons.  Picons are just the video thumbnails on the main program window timeline as well as the thumbnails in the Resources Window.  So that is why you can continue to work as usual.

 

// Create new listitem
if( !exists ) {
AssetPicon *picon = new AssetPicon(mwindow,
this, current);
new_assets.append(picon);
if( current->width > ASSET_MAX_WIDTH || current->height > ASSET_MAX_HEIGHT ) {
eprintf(_("Warning: %s\n"
" dimensions %dx%d exceed asset maximum limits %dx%d\n"),
current->path, current->width, current->height,
ASSET_MAX_WIDTH, ASSET_MAX_HEIGHT);
}
else if( mwindow->edl->session->playback_config->vconfig->driver == PLAYBACK_X11_GL ) {
int texture_limit = BC_DisplayInfo::get_gl_max_texture_size();
if( texture_limit >= 0 &&
(current->width >= texture_limit || current->height >= texture_limit) ) {
eprintf(_("Warning: %s\n"
" dimensions %dx%d exceed OpenGL texture limit %d\n"),
current->path, current->width, current->height, texture_limit);

 

Do you get this warning message when loading new video or only video that you had previously worked with on the older computer/graphics board?  If you do NOT get this warning when loading a video that you have never loaded before and it is 3840x2160, then that means you might want to recreate index files.  If so, please reply.

 

You can also choose to NOT draw the picons on the timeline by changing the draw media toggle in the patchbay to speed up operations, but this makes it too hard to work.  Although, it might be a way to determine for sure that that is the exact problem.

phylsmith2004 01/02/2024 10:59 pm

@jacques-citerici 

You may also want to check your thumbnail size in Settings->Preferences, Appearance tab or temporarily turn them off just to see if that could be a problem.

 

2件の回答
0

Unfortunately, I have an AMD card and do not have your warning. I have tried up to 8k with no problem.
Yours is just a warning for that you can continue editing.
Try setting vdpau in Settings --> Preferences --> Performance --> Use HW Device.

In Preferences --> Playback A is the driver X1-OpenGL set?

Jacques CITERICI Topic starter 01/02/2024 8:57 pm

@andreapaz n Preferences --> Playback A is the driver X1-OpenGL set? YES

I try to switch from Cuda to vdpau, but no change

0

Another response found on the mailing list:

"

well, user mentioned wayland .. may be Xwayland (+ nvidia)  does not report
some opengl limits correctly? Historically GL was highly linked to X
server, I bet move to wayland might broke less common cases like pbuffers
we use  ... If warning will prove to be important I guess there will be two
ways to avoid it :  move back to X session (and report bug to freedesktop)
or just report bug to very same body and do not use opengl

"

https://lists.cinelerra-gg.org/pipermail/cin/2024-January/007935.html

Jacques CITERICI Topic starter 01/02/2024 8:58 pm

@andreapaz I need to repair Plasma (X11) and come back to X session.

Jacques CITERICI Topic starter 01/02/2024 8:58 pm

@andreapaz Thanks for your support

共有: