View Issue Details

IDProjectCategoryView StatusLast Update
0000247Cinelerra-GG[All Projects] Bugpublic2019-08-01 20:37
ReporterOlaf Assigned ToPhyllisSmith  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-07 
Summary0000247: Mask does not receive keyframes
Description

The mask does not receive keyframes during editing, only after wild clicking like deactivating OpenGL, but then the data for the respective position is not taken over. Can anyone confirm this?

And also, how do I get an overview of all masks used on a track to see if and how they harmonize with each other? And how do I temporarily switch off the masks on the track in order to be able to continue working at normal tempo (the mask consumes RAM without end, it is already swaping)?

Steps To Reproduce

If "generate keyframs while tweeking" is switched on, add a mask and edit this mask elsewhere.

TagsIn and Out point, Keyframe, Mask

Activities

PhyllisSmith

PhyllisSmith

2019-07-27 23:55

manager   ~0001987

Resolved in a manner that avoids inadvertent Keyframe Spanning causing problems. This capability may not be useful to many, but the original author added it for a very good reason to avoid a time-consuming/accident prone alternative and gg finds it extremely handy.

IgorB: in answer to this question: "was that feature (no In and Out point have to be there to insert a keyframe) a bug?" - I am not clear on the question but if it was, I think gg would have let me know.

IgorBeg

IgorBeg

2019-07-20 08:43

reporter   ~0001957

Sam explained the point well. Thanks Sam!
And I would like to add: was that feature (no In and Out point have to be there to insert a keyframe) a bug? Only the developers and old users (like Igor_ubuntu?) know, I think.

Sam

Sam

2019-07-19 16:28

administrator   ~0001954

I can understand Igor's reasoning very well. For me this button has no function worth mentioning. If this button would be used very often, I would also understand that it is deposited in the function bar.
I would generally put functions that are not used so often in the settings in order not to make the already complex appearance of Cinelerra more difficult. It is only my humble opinion on this topic.

PhyllisSmith

PhyllisSmith

2019-07-19 15:26

manager   ~0001953

IgorB: Also, the rotated keyframe icon seems to fit it well with the Generate keyframes ... and gg is happy with the way it looks, but if you are unhappy with how it looks gg is not opposed to changing it to your design instead.

PhyllisSmith

PhyllisSmith

2019-07-19 15:18

manager   ~0001952

IgorB: "could you delete the option in timeline and put it in Preferences, please? (and also because the two keyframe icons could now confuse the user) ".

Although it may be a little confusing, the tooltip shows up really fast while hovering the mouse trying to decide! I think it is best as a toggle for 3 reasons. 1 - those using it need to toggle it on and off easily without having to go through a lot of work to use Settings...and a lot of clicking to find it. 2 - it fits in with the rest of the timeline toggles like Generate keyframes and Lock labels as it is something you do and then undo relatively soon so that you do not forget. 3 - since the default has been "allow spanning" for years, we do not want to make it difficult for users who take advantage of this feature to have to search for how to do this -- after all, we are already changing the default to off instead of on so it may already be an inconvenience. Also, if I was to add a 4, it would be that GG uses it and wants it easily accessible.

IgorBeg

IgorBeg

2019-07-19 06:44

reporter   ~0001951

@PhyllisSmith and Others
Thanks.
I think that this option would be better in Preferences window, not in Timeline because, I think that a lot of user (let say, 95%?), will use with the new mode.
If Sam, Olaf, and others confirm, could you delete the option in timeline and put it in Preferences, please?
(and also because the two keyframe icons could now confuse the user)

Sam

Sam

2019-07-18 22:46

administrator   ~0001950

Great! Thx.

PhyllisSmith

PhyllisSmith

2019-07-18 22:29

manager   ~0001948

Last edited: 2019-07-18 22:31

View 2 revisions

Sam says: "disable this function permanently in the settings, so that this accidental overwriting doesn't happen anymore".

OK, the latest GIT checkin has a new toggle on the timeline with the default settings being Off for "Allow keyframe spanning". The toggle is to the right of the "Generate keyframes while tweaking. So when you do want the old behavior, you will have to check this icon On. I will update the local documentation.

A new Ubuntu 16 build is at:
https://www.cinelerra-gg.org/download/testing/cinelerra-5.1-ub16-x86_64-static.txz

(Now I will try to catch back up on issue 0000002, and then only 200+ more issues to go!!!)

Sam

Sam

2019-06-23 19:49

administrator   ~0001771

This is indeed a better solution, if it were technically feasible, I would welcome this change.

PhyllisSmith

PhyllisSmith

2019-06-23 13:33

manager   ~0001770

Last edited: 2019-06-23 14:00

View 2 revisions

Re-opening and maybe there is a better implementation strategy to get the feature without the confusion. But I do not know. Initially gg will try to at least remove the keyframe spanning feature from the In/Out pointers and have it take effect ONLY with a marked selection.

Sam

Sam

2019-06-23 09:53

administrator   ~0001761

I must honestly say that this feature with the inpoint and outpoint and overwrite the keyframes within this range only causes confusion. I have so often mistakenly overwritten existing keyframes because I have set the inpoint and outpoint before and forgot to delete them again. It annoys me again and again. For the intuitive work it is rather disturbing. I use the Inpoint and Outpoint too often and the function of overwriting keyframes in this range not at all. I would very much appreciate it if I could disable this function permanently in the settings, so that this accidental overwriting doesn't happen anymore.

PhyllisSmith

PhyllisSmith

2019-06-23 00:49

manager   ~0001757

Will add to issue 0000002, a suggestion to be able to enable/disable masks temporarily. IgorB's demo works well to see how all of the masks on a track harmonize.

PhyllisSmith

PhyllisSmith

2019-06-23 00:24

manager   ~0001756

Last edited: 2019-06-23 00:43

View 2 revisions

Happily IgorB was able to deduce what the problem was. Otherwise I would have had to mark this as unable to reproduce, not knowing that the In/Out pointers or a selection was in effect.

KEYFRAME SPANNING was added by the original author in 2010. It is a handy feature but unless you know about it, seems confusing. It was not documented in the cv manual as far as I can tell. It is in section 13.9 of the Secrets of Cinelerra Original manual. I will add it to the gg manual as something like the following quote:

"To change a single parameter in multiple keyframes without changing the other parameters, highlight a region on the timeline and adjust the parameter. Instead of a new keyframe being created, the existing keyframes are modified and only the changed parameter is modified. If does not matter if auto keyframe is enabled. It only works when the keyframe stores multiple parameters. Only mask and effect keyframes do this. Other types of keyframes are generated as usual.

Keyframe spanning for effects & masks:

  • Select single point in time & it uses default keyframe generation as before.
  • Select a range & it copies the changed parameter to all selected keyframes."
IgorBeg

IgorBeg

2019-06-16 09:35

reporter   ~0001731

Thank you Olaf!

Olaf: <i>You immediately recognized that in and out points were set.</i>
Time ago it happened to me and then in Cinelerra-CV_mailing list I had done a request for that to see better when In and Out point were set: "Connect In and Out point with a line".
Thanks to this feature I can always see if In and Out point are there.
https://lists.cinelerra-cv.org/pipermail/cinelerra/2018q3/009487.html

Olaf: <i>I would prefer a switch on the dialog of the mask itself.</i>
For the Masks you are right but sometimes You (all) and me have to find a different one workaround (like in Blender that you know, I think), or at least until next feature.
I think it would be better a switch in the Timeline's track to Show/Hide all the Masks in that track.

Olaf

Olaf

2019-06-16 07:35

reporter   ~0001730

Igor, I like your short films. You know how to get to the heart of the matter without words. Your videos should become or at least include a manual.

You immediately recognized that in and out points were set. Is it a feature, or isn't that possible from the programming point of view? How should the user recognize the respective behavior of the in and out points?

As far as the overview of the masks is concerned, I would prefer a switch on the dialog of the mask itself. There would be enough space if the redundancy in the upper area were removed. But what do I know, I am now the fool who edits the mask while in and out points were set.

IgorBeg

IgorBeg

2019-06-15 22:35

reporter   ~0001729

@Olaf
Always check that in Timeline there are not, In and Out point. If In and Out point are setted, you can not add keyframes.
To delete In and Out point quickly I use "Ctrl+t" shortcut.

I don't know your workflow and project but I usually use Master track to make trim/cut and a track with shared video where I make ColorGrading and eventually to add Masks (sometimes I use another video track for masks).
To answer quickly at your:
<i>"And also, how do I get an overview of all masks used on a track to see if and how they harmonize with each other? And how do I temporarily switch off the masks on the track in order to be able to continue working at normal tempo"</i>
In my cases I use the shared track. Take a look please at:
https://streamable.com/3jz6x

Mmmh, It's too late here! Good night.

PS:
I don't know what Cinelerra version and OS you are using.
I am using UbuntuStudio_16.04 and ...

  • cinelerra-5.1-ub16.04-20190531.x86_64-static
  • cinelerra-5.1-ub16-x86_64-static_20190608_by-testing
Olaf

Olaf

2019-06-15 20:59

reporter   ~0001728

Now I have marked everything on both tracks except the first keyframe of the masks and applied delete keyframes. The two masks are still there, but have no effect.

Issue History

Date Modified Username Field Change
2019-06-15 18:47 Olaf New Issue
2019-06-15 20:59 Olaf Note Added: 0001728
2019-06-15 22:35 IgorBeg Note Added: 0001729
2019-06-16 07:35 Olaf Note Added: 0001730
2019-06-16 07:36 Olaf Tag Attached: Mask
2019-06-16 07:36 Olaf Tag Attached: In and Out point
2019-06-16 07:36 Olaf Tag Attached: Keyframe
2019-06-16 09:35 IgorBeg Note Added: 0001731
2019-06-23 00:24 PhyllisSmith Note Added: 0001756
2019-06-23 00:43 PhyllisSmith Note Edited: 0001756 View Revisions
2019-06-23 00:49 PhyllisSmith Assigned To => PhyllisSmith
2019-06-23 00:49 PhyllisSmith Status new => resolved
2019-06-23 00:49 PhyllisSmith Resolution open => no change required
2019-06-23 00:49 PhyllisSmith Note Added: 0001757
2019-06-23 09:53 Sam Note Added: 0001761
2019-06-23 13:33 PhyllisSmith Status resolved => acknowledged
2019-06-23 13:33 PhyllisSmith Note Added: 0001770
2019-06-23 14:00 PhyllisSmith Note Edited: 0001770 View Revisions
2019-06-23 19:49 Sam Note Added: 0001771
2019-07-18 22:29 PhyllisSmith Note Added: 0001948
2019-07-18 22:31 PhyllisSmith Note Edited: 0001948 View Revisions
2019-07-18 22:46 Sam Note Added: 0001950
2019-07-19 06:44 IgorBeg Note Added: 0001951
2019-07-19 15:18 PhyllisSmith Note Added: 0001952
2019-07-19 15:26 PhyllisSmith Note Added: 0001953
2019-07-19 16:28 Sam Note Added: 0001954
2019-07-20 08:43 IgorBeg Note Added: 0001957
2019-07-27 23:55 PhyllisSmith Status acknowledged => resolved
2019-07-27 23:55 PhyllisSmith Resolution no change required => fixed
2019-07-27 23:55 PhyllisSmith Fixed in Version => 2019-07
2019-07-27 23:55 PhyllisSmith Note Added: 0001987
2019-08-01 20:37 PhyllisSmith Status resolved => closed