View Issue Details

IDProjectCategoryView StatusLast Update
0000350Cinelerra-GG[All Projects] Bugpublic2020-01-01 00:19
ReporterOlaf Assigned ToPhyllisSmith  
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2019-12 
Summary0000350: Transcode fails if the video to be transcoded does not contain audio.
DescriptionIt is not possible to deselect audio, if it is supposedly disabled by the user, the default audio codec is used. If the video to be transcoded does not contain audio, the operation will fail. I have tried it with several different videos and the result is always the same.

convert: failed=0 canceled=0
TranscodeRender::run: done in 0:00:00
void AssetPicon::create_objects():
Unable to open [path removed]/01-Video-wo-Audio.convert-mkv.mkv
in asset: 01-Video-wo-Audio.convert-mkv.mkv

Furthermore, I was not able to change the "Tag suffix", instead of my entered wish, the default suffix ".convert" was retained.




2020-01-01 00:19

manager   ~0002622

Appears that the problems are fixed and no new transcode problems have been reported. If new problems do crop up, a new BT can be opened.


2019-12-18 21:27

manager   ~0002586

Transcode fixes just checked into GIT include the reported problems here and at least 1 from 0000346 (but not the vdpau issue yet):
 - video files only, that is there is no audio, now convert correctly
 - single frame files, like png's, fixed to convert better.
 - if you have a video file that also contains audio, and you convert only the video, the original audio will stay on the timeline if do not check "Remove originals from project". Or vice versa if audio converted and not video.
 - You will get an error message if you already have a convert file in the selected format with the same suffix name and try to transcode it again with a different selection made -- i.e. the already converted file has both video and audio and now you request video only. So you will have to delete that file first.
 - There was a problem with changing the suffix tag in some case and a fix was put in and I hope we got all of the cases. If not, outline the steps to produce the problem so we can fix that case too.

Just a note to remind me to add to documentation, that multiple stream media, will only transcode the first stream (this would be like the TV channel recordings here in the U.S.)


2019-12-13 17:15

reporter   ~0002576

For the manual. The process of transcoding works directly from the resource, it is independent of the timeline. However, the settings of the project have an effect, for example the dimensions are taken into account. The resulting files are also larger than if they were created directly with ffmpeg.

Phyllis, the part after the "but" I unfortunately can't understand, I assume it's important because there's an exclamation mark at the end. I already delivered the solution in the beginning.


2019-12-13 16:44

manager   ~0002573

OK, you are right. I had tested with an mp4 file that had audio and simply deleted the audio tracks before transcoding -- that seemed to work. So now, I tested with an mp4 that started out with no audio and it confirms the failure. But , fixing for my mkv test case failure most likely would have fixed all cases. I have to make sure I can create the error or there is no way to fix it or tell if it is fixed!


2019-12-13 09:28

reporter   ~0002570

Thanks for playing along, but your observation doesn't coincide with mine. The video to be transcoded can be in any container, important is, it doesn't contain audio. Under these conditions, an empty file is created, where the transcoding process does not report an error. Only when it is replaced by CGG is it discovered that something is wrong with the transcoded file. To create a video file without audio, proceed as follows: ffmpeg -i $IN -an -sn -c:v copy -map 0:0 $
The "-an" and "-sn" switches prevent the editing of audio and subtitles, "-map" points to the video and must be determined if necessary (fprobe $IN 2>&1 | grep 'Stream.*Video'). Instead of "mov" you can of course also use its derivative "mp4". Be so good and check it again.


2019-12-13 01:58

manager   ~0002569

I have confirmed part of this using an "mkv" file with no audio. An mp4 file where the audio tracks were deleted still worked.
Also confirmed that the name change from the default of what is in the individual's preferences file ($HOME/.bcast5/Cinelerra_rc) does not seem to allow for changing the name.

Issue History

Date Modified Username Field Change
2019-12-11 10:23 Olaf New Issue
2019-12-11 10:23 Olaf Tag Attached: Transcode
2019-12-13 01:58 PhyllisSmith Assigned To => PhyllisSmith
2019-12-13 01:58 PhyllisSmith Status new => confirmed
2019-12-13 01:58 PhyllisSmith Note Added: 0002569
2019-12-13 09:28 Olaf Note Added: 0002570
2019-12-13 16:44 PhyllisSmith Note Added: 0002573
2019-12-13 17:15 Olaf Note Added: 0002576
2019-12-18 21:27 PhyllisSmith Note Added: 0002586
2019-12-18 21:28 PhyllisSmith Status confirmed => feedback
2020-01-01 00:19 PhyllisSmith Status feedback => closed
2020-01-01 00:19 PhyllisSmith Resolution open => fixed
2020-01-01 00:19 PhyllisSmith Fixed in Version => 2019-12
2020-01-01 00:19 PhyllisSmith Note Added: 0002622