Benachrichtigungen
Alles löschen

LOG window

10 Beiträge
3 Benutzer
0 Likes
830 Ansichten
0
Themenstarter

Hello,

 

I have a problem with the LOG window opening unexpectedly. The solution is to stop closing it and minimize it for peace of mind, but is there a way to deactivate it?

 

On the other hand, I put a screen copy of what appears in the window, but I don't know how to interpret it and how to fix it. Maybe you can help me solve this problem, which doesn't seem to affect the smooth running of the software.

 

Thank you very much in advance 🙂

Kind regards

phylsmith2004 20/02/2024 1:43 am
Diese r Beitrag wurde geändert Vor 5 Monaten von phylsmith2004

@chapolin 

My previous suggestion did NOT work so I deleted it.  I will experiment some more and maybe Andrew-R has a good solution.  It was to File pulldown, Save as... the project again or File pulldown, Save backup -- it did not work and the error was still there.

phylsmith2004 20/02/2024 2:05 am

@chapolin 

The following worked but you must be VERY CAREFUL:

1. make 2 backup copies of your Project file

2. very carefully or YOU COULD LOSE YOUR WORK, edit your project file and look for the section <ASSETS>.  After this line you will see the mistake files that are giving you the error messages.  Generally each file has 5 lines -- delete these lines for the mistake files.  The lines to be deleted begin with the following and end with the next.

  <ASSET SRC=...     is the first line and the last line for that mistake file will be:

  </ASSET>

 

 

7 Antworten
0
Themenstarter

Sorry it took me a while to reply, I had to spend a lot of time finalizing sequences in opentoonz for my project (...). Anyway, thank you very much for your help. So I tried your solution and it works, but the problem is that the imported files also disappear from the project and the editing has to start all over again. So for the moment I'm not applying the solution and I'm ignoring the error messages by simply minimizing the log window. I'm going to try again as soon as I have a moment, because I tested the solution quickly and perhaps I didn't see everything.

0

@chapolin

@andreapaz

I looked at your screenshot more carefully and now I see that you have "real" image files that have a ".sh" extension - usually the .sh extension represents shell commands but in your case they seem to be images !!  The solution I proposed was meant for rogue files that were actually shell commands and should not have been there so does not apply in your scenario.  I can not track where the error message you see of "file not found" is actually coming from and could be only because of the unusual .sh extension.

Your solution of ignoring the LOG file may be the only solution.

0

I cannot reproduce any test in which a LOG window opens. I have tried renaming a mov file to .sh and it loads and works, but no LOG window comes up.

0
Themenstarter

but in your case they seem to be images

 

Yes, it's a .sh file that points to a folder containing png images to create a stop-motion animation.

I followed the instructions on this page dedicated to cinelerra-cv: Stop-motion

They advise naming the file with the .txt extension but it doesn't work. I've found, I don't remember where in another tutorial, the advice to name the file with the .sh extension and it works very well.

Here is an example of the file used:

PNGLIST
12.500000
1280
720
/home/moi/anim/00.png
/home/moi/anim/01.png
/home/moi/anim/02.png
/home/moi/anim/03.png
/home/moi/anim/04.png
/home/moi/anim/05.png
/home/moi/anim/06.png
/home/moi/anim/07.png

 

0
Themenstarter

So when I looked at one of the files in more detail I realised that I'd forgotten one of the images listed, probably by moving them from one folder to another. I'm very busy at the moment but as soon as I have a moment I'll check everything again in detail and see if the error messages continue.

0
Themenstarter

So I continued to work on my project by importing new .sh files pointing to png and I made sure there were no errors in my images and CIN kept sending me the same error messages as above. If I ignore the logs, there's no problem continuing to work and I'm going to continue like this for this project.
But for the future, what other method can I use to build png-based sequences that can be used in CIN for academic purposes?
The advantage of png is that there's no background in the images, which makes for very interesting effects and overlays. Obviously, if you build a .mp4 file based on png, you lose the transparency of the backgrounds and it's no longer interesting... The other advantage, it seems to me, is that with the method I'm using, CIN will read the images on the hard disk one by one, and I have the impression that it's very efficient and lightweight, but I could be wrong on this last point.

phylsmith2004 21/04/2024 4:26 pm

@chapolin 

Like @andreapaz , I have attempted to create a scenario that gives me a LOG message popup based on the information you provided.  Still, I get no errors and it works correctly.  Below is my file on /tmp which I named "test.sh" and the png files were just legitimate png files of a circle.

PNGLIST
12.500000
1280
720
/tmp/00.png
/tmp/01.png
/tmp/02.png

Only if you have time, could you try just this simple case with the above in a test file and (if you want to) substitute /home/moi/anim instead of /tmp.  First, create the 0x.png files using what I have attached here just so that we are doing the exact same thing.  Then load test.sh using the strategy of "Replace current project".  BE ABSOLUTELY SURE you don't already have something you are working on or it will get replaced and you may lose work.

If the above test works and no error LOG popups, then there is something in your case I am unable to diagnose that is wrong. If it does not work, a second test to try this again after starting up Cinelerra using a temporary startup file -- type in:    CIN_CONFIG=/tmp/bcasttemp ./cin/bin   (where ./cin/bin is whatever you use to start Cinelerra, like the AppImage name).

 

0
Themenstarter

Hello,

Thanks again for your help. I did exactly as you told me (the interface is not the same as usual, so I think everything is quite new compared to my environment in other projects). So I still get the error messages. You can see on the attached screenshot :

 
To start I used this command line
 
CIN_CONFIG=/home/chapolin/Plop/bcasttem /usr/bin/cin
 
Teilen: