Proxies and keyfram...
 
Benachrichtigungen
Alles löschen

Proxies and keyframes

4 Beiträge
4 Benutzer
0 Likes
1,503 Ansichten
0
Themenstarter

I am working on a 1080 30p project using 4K material. The project heavily relies on the projector/camera features of Cinelerra.

I have to edit with proxies. When I render with proxies enabled everything is o.k. When I disable the proxies for quality rendering the zooms and movements of the camera/projector are rendered incorrectly.

It seems to me that Cinelerra does not automatically recalculate the keyframes of the projector/camera, which were set with the proxy material, to fit the much larger original material.

What can I do to make Cinelerra set the keyframes correctly when proxies are disabled? I cannot find the answer in the Cinelerra manual. Have I overlooked something?

4 Antworten
0

@Gerd

@IgorBeg

Because of time zones, this was late in getting approved so be patient for a response.  IgorBeg is an expert on proxies, so hopefully he will provide feedback even if it is Sunday.

Meanwhile, I would suggest that you make sure that OpenGL is not misleading you.  When you render, it always uses only Software so that depending on your graphics library, it could be different.  To temporarily see what software only does, go to Settings->Preferences, tab Playback A tab and switch from X11-OpenGL to X11.  If you not using OpenGL, ignore this suggestion and it is always possible that there is a bug in CinGG.

0

It is really strange @Gerd. The Camera and Projector tools work good for Proxy.
The values X/Y/Z of the Camera/Projector are recalculated when you disable/enable Proxy.
I just tried a test here using 4k media on a 1080@30p project. It works right. The output of the Rendering is the same but low quality for Proxy, of course.

What you see, is it only in the Rendering output or also in the Compositor window when you enable/disable Proxy?
I remember that when Proxy is enabled and you want to insert a video from Resources window to the Timeline you must drag from Resources->Proxy bin instead of Resources->Media bin.

0

Could it be that in the proxy/original switch the range limits of X,Y and Z are altered?

0
Themenstarter

Thank you very much for your quick response. I have made some small tests. You are absolutely right. Everything is instantly recalculated and is working. I must have overlooked one or the other PNG for moving titles (lower thirds) and not proxied them correctly in the current project.

Teilen: