Retirer tout

Update breaks Cin

17 Posts
4 Utilisateurs
3,620 Vu
Début du sujet

I thought you might like to know, I've been using the Arch build package of Cin on Manjaro KDE. Manjaro had an update and afterwards Cin would not re-start, even after a re-boot. I tried the single-user build and it would not start, is missing and there is currently no way to install it. It is affecting Firefox for some folks too. This is not a Cinelerra bug, but it may as well be.

I tried Kubuntu and it was exactly the same.

I got around it by installing Mint Xfce. For what it's worth, I tried Mint Mate first and it didn't run Cin properly, the Program window was stuck as the front window and nothing could go over it. Changing to Xfce fixed that. Just thought I would mention it!

11 Réponses


Thanks so much for letting us know.  We have built some of the older distros for CinGG without libdav1d so we may have to do the same for Manjaro Arch when we do this month's build.  But that may be a little tricky because we would not want to delete it from "regular" Arch.  We do not have a specific version of Manjaro Arch on our build computer, but I think we can do 2 different builds with and without libdav1d.  Hopefully, Manjaro Arch users will see the different one.  Or maybe another solution will come up by then.

DeJay Début du sujet 18/11/2019 4:53


Thanks Phyl, my reading of the Manjaro forum suggests some form of downgrading is needed, but I did not fully understand it as I am not that deep into Linux, I just use it. I get the impression that the Manjaro devs will get it sorted soon, but I want to use Cinelerra now, hence my move to Mint. But as it's the same on Kubuntu it's obviously not Manjaro per se.


Just for information, here I have no difficulty using Cinelerra-GG infinity under Linux Mint Mate. This, with three computers; the first (desktop i7) under Linux Mint Mate 18.3 64bits and two others (desktop Duo and laptop i5) with Linux Mint Mate 19.2 64bits.


DeJay Début du sujet 18/11/2019 5:01


Thanks Pierre, on the strength of your reply I think I may give LM Mate another go, as I am experiencing some instability with Xfce. If it works I may stick with Mint, as I am thinking that maybe I shouldn't use a rolling release for something I want to rely on, even though this is the first problem of this nature I have had with Manjaro over the last few years.


Just a point of clarification.... My two computers running Linux Mint mate 19.2, were initially installed with 19.1 and later updated to 19.2. It is possible that an installation directly from 19.2 may suffer from some missing dependencies, that I don't know.


Additional information....

Since a long time when I install from zero linux mint, I then apply most of the optimization recommendations offered on this site:

The list is long and takes a long time to apply, but I have always observed an improvement in performance afterwards.

DeJay Début du sujet 19/11/2019 9:00


Thanks again Pierre, I've bookmarked that lengthy list to try later. FYI it gets worse when I install the proprietary graphics driver.


In arch linux the libraries are located in /usr/lib/...
I don't have and I don't have problems (with Arch). However a workaround not really correct, but that generally works is:
1- open a file manager (I use Dolphin).
2- open root --> usr --> lib (/root/usr/lib)
3- Look for the library ""
4- If such a library exists, open a terminal (I use konsole)
5- create a soft link (symbolic link):
         sudo ln -s /usr/lib/ /usr/lib/

Check if Cinelerra starts. If it does not work better remove the soft link created:
        sudo rm /usr/lib/

6- I also have the librearias "" and "". If point 5 didn't work, try making a soft link to these too:
        sudo ln -s /usr/lib/ /usr/lib/
        sudo ln -s /usr/lib/ /usr/lib/

DeJay Début du sujet 19/11/2019 8:58


Thanks Andrea. I have the same libraries, so I can try this later.

DeJay Début du sujet 20/11/2019 9:33


It doesn't work for me. Never mind, I'll use Mint because it is working. Thanks anyway.


I installed Manjaro and then I compiled CinGG. First I installed all the necessary dependencies. Everything works well for me, with no errors.
Do you install the binary or compile it?

Début du sujet

For the record, I got some help from the Manjaro forum and it seems that libdav1d is provided by numactl, installing it fixed the problem.

FYI it is something that Xfce always required installing separately to run Cin, but never before KDE.

Andrea, you posted while I was writing, thankyou. I had the installed Arch package, but I also tried the Arch single-user build (which I always keep handy in case of a bad Cin update).


Just to verify, I made sure that "numactl" was listed for Arch install in README.arch file and it is there.  I guess I should have mentioned looking at this file early on but I am not sure why an update of Manjaro would not already have the required files since Cinelerra was working on the earlier version?:

Début du sujet
Posted by: @phylsmith2004

I am not sure why an update of Manjaro would not already have the required files since Cinelerra was working on the earlier version

Exactly that. Bear in mind that Manjaro is a rolling release and updates are only partial, so why should I immediately think that file had gone missing?


DeJay Début du sujet 01/12/2019 8:26

Update, for the record. I went back to Manjaro KDE.

Andrea, the link does work, but I had to run pacman -S numactl first. It still leaves the question of where it went in the first place, of course!


If this is your first installation of CinGG, you should first install all the dependencies listed in the Phyllis link, so no problem. However, in your case there is no way to realize that before there was "numactl" and now no more (and maybe other dependencies).
Who knows what it was that removed numactl from your system; a system update? A package that you uninstalled and brought with it numactl?
Perhaps you could make a script that, when problems arise, you run it to check for the presence of all dependencies. In short, the same as "" for other distributions. A normal Arch user would be able to do that, but not me 🙂
I'll try to see how it's done, it would be a convenient addition.

Début du sujet
Posted by: @andreapaz

Who knows what it was that removed numactl from your system; a system update? A package that you uninstalled and brought with it numactl?

It was definitely a system update. I was using Cin the previous evening, next morning there was an update which I applied and after that, no Cin.