High frame rates (and slow motion)  

   RSS

0

Hi together,

 

I'm new to cinelerra-gg and was using cinelerra-cv in the recent years. 

 

I mostly use clips with frame rates like 29.97. Also the results of my projects are finally rendered to 29.97 fps. But my camera is able to capture clips with rates up to 239.7602 fps which I slow down with reframeRT.

When I wanted to implement some slow motion sequences in my project I alwas had to set the project frame rate to 239.7602 otherwise - even with reframeRT - many frames of the clip with high frame rates were lost (only every 8th frame is used).

 

I tried the same procedure with cinelerra GG:

- set the project frame rate so that it matches the 239.7602 of my resource clip

- put it on the timeline and attach reframeRT an made my adjustments (slowing it down 8x -> 0.125)

When I want to render the project I receive an "check_frame_rate error"

 

By some research I found a topic from April this year dealing with a similar problem occuring on clips with 119.88 fps when using the proxy setting. So or now I found a workaround for me:

- start a new project

- load my 239.7602 fps clips into resources

- set the frame rates of the clips in the resources window (RM on the clip; "info ...") to 240 fps

- match the project rate (and size) to the clips of the resources window

- using reframeRT or the (new to me) the speed adjustment curves of the timeline --> to 0.125

- rendering then goes well

 

 

Is this the appropriate procedure or is there a more simple way to work with clips at those frame rates, to use them for slow motion sequences? Cinelerra-gg cannot render projects with frame rates like 239.7602?

 

Best regards,

Mat

6 Answers
0

This is a "hack" answer as I am not very technical.

As far as I know, the procedure you have found to work is the best or only one mentioned the last time this issue came up for handling unusual framerates.  So far I have not heard of a different way, but maybe someone else has.

Quote: "Cinelerra-gg cannot render projects with frame rates like 239.7602?"

When I asked GoodGuy about this, he said it is the codec being used that determines supported frame rates and Cinelerra just reports back check_frame_rate as passed back from ffmpeg.  As an example, to render audio using Opus, only 5 sample rates are supported by Opus.  If you try to render a file that has a sample rate of 44100, you will get a similar error of check_sample_rate.

0

Thank you very much for your reply!

1. I'll stay with the described procedure to handle those clips with the high frame rates, as it is the established way to realize that.

2. Regarding the rates determined by the codec I'm wondering because cinelerra-cv did not have the comfortable proxy service which is provided by cinelerra-gg. So in the past I had to convert the clips to reduce compression before loading the clips into cinelerra for more comfortable editing. I used ffmpeg for this conversion and never had issues with ffmpeg and rates like 119.88 (29.97 x 4 equals 120,000/1001) or 239.76 (29.97 x 8 equals 240,000/1001).

Ok, nonetheless for the time being I'll change the rate in the resource window from 239.76 to 240 as described above.

 

Thanks so far!

0

Hi,
you could try to change the internal engine: instead of ffmpeg return to the classic Cinelerra engine, based on quicktime. Use the "I" (or "FF") button in the top right of the main window or in Settings --> Preferences, as described in "5.3.3 Probe Order when Loading Media" in the manual.

0

Oh, I remember, I've read this chapter in the manual before but did not check this yet. So thank you for this hint! I'll give it a try and will report if it was working and how it went.

0

Hi,

changing to the classic cinelerra engine did not solve the problem. The error occurs again if I do not change the frame rate of the source media from 239.76 to 240 fps.

0

I think CinGG uses the internal engine of Cinelerra-HV and not Cinelerra-CV.
To sum up:
- Ffmpeg works at 239,7602 fps.
- Cin-CV works at 239,7602 fps.
- CinGG does not work with 239,7602 fps nor with ffmpeg nor with the Cin-HV engine.
If I understand correctly and that's the case, then you could open an issue in the Bug-Tracker.

Share:

Please Login or Register